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Contents in Summary

Introduction

Chapter 1: The art of animation in Flash 8

Animators and designers have used Flash, animations and other Flash authored content

on web sites for many years now. While the content provided a rich experience for users,

large file sizes often meant long download times. In response, Macromedia has introduced

several advances in Flash 8 that allow for even richer content while also lowering the

file size of the finished Flash project. Using a very basic character with minimal detail

I have put together in Chapter 1 a simple tutorial that looks at a basic walk. Applying

the principles you learn in this chapter to your own characters will be effortless.

Once you’ve mastered this basic walk, then you can give your character your own style

and characterization.

Chapter 2: Planning and production

The traditional large team’s sole responsibility was to track who is doing what and when.

To some extent all this can be done with Flash 8 by one person. Before we go into

the depth of animation we need to plan our processes. This chapter looks at the process.

It is broken up into three parts.

The first section looks at planning and storyboarding the traditional way but using Flash 8.

The middle section demonstrates a simple design methodology that plans out all the assets

required for a game or animation.

The final section at productivity tips to improve your workflow and organize your workspace

while using Flash 8.

Chapter 3: Character animation

We start this chapter by looking at simple techniques of drawing. When you were a child

your teacher taught you how to draw the basic shapes like; the triangle, the square, the

circle. Things do not really get any more complicated than that. Everything in the

known universe can be drawn using combinations of two or more basic geometric shapes.

The animator must have the ability to draw or pose characters, but also have an acute

sense of timing, of observation, mannerisms and movement. This chapter covers all

the major techniques for drawing and producing realistic character animations, and

includes hands-on examples and a number of tips and tricks.

Chapter 4: Facial animation and lip syncing

If you’ve ever animated a character and you have wanted to make it talk or sing, then

you will have touched on the art of lip syncing. This is the art of taking a pre-recorded

vii



dialog, and making a character move its lips as if to speak this dialog. This involves

figuring out the timings of the speech (breakdown) as well as the actual animating of the

lips/mouth. In addition making the actual setup or mouth positions needed can also

be considered a part of the entire lip sync process. Creating speech may appear to be

difficult. This chapter looks at the art of lip syncing using eight basic mouth expressions

to represent English speech. We also look at the process of scrubbing. ‘‘Scrubbing’’

is a preview of the sound when moving the playhead along the timeline. You need

to set your voice over audio file to Stream. Not only will this preserve the lip sync, but

it will also allow you to ‘‘Scrub’’ back and forth across the timeline to hear your sound

frame by frame.

Chapter 5: Sound and dialog

This chapter outlines how you can use sound to make your animations more fun

and exciting. You will learn how to edit sound effects and how to integrate these

sounds into Flash 8. The chapter also covers compressing sounds for optimal playback

and descriptions of the different digital sound formats. I hope the Sound Object is

demystified with tutorials that explore the construction of the sound object and its

implementation into a movie.

Chapter 6: Titling, pixel fonts and typography

Although this book is about animation it seems unlikely that the animator or designer

will not encounter a situation where type is needed in the project. The Internet has

changed the nature of type. What at one time was solid and made of lead and had its

rules is now reduced to dots on a screen completely in the designer’s control. This chapter

takes a look at using typography effectively in a number of common situations in

your animation. It first covers the art of animated para and then moves on to look at

pixel fonts. In Appendix A we have a potted history of typography for the budding

typorgrapher. The closing tutorial looks at the different fonts used in our game and looks

at the different tools and decisions that affect the final style.

Chapter 7: Flash mobile and Flash Lite 2

This chapter is an overview of developing content for Mobile Phones and the Pocket

PC. In this chapter I spend some time explaining the Macromedia Flash Lite 2 new

features as well as describing some best practices for creating content for these mobile

devices.

You will be taken through essential issues such as interface design, movie size and

format and optimum movie size for playback on handheld devices. This chapter discusses

in depth the importance of mobile communications as we look into the future, and

how they will change the multimedia industry. On a practical point I feature two

products with all the source code and a template for all mobile development including

running video on mobile.

Contents in Summary
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Chapter 8: Introduction to video

When people talk about broadcast quality they are usually referring to NTSC/PAL/

SECAM standards. This chapter looks at the production of video and the issues around it.

The focus is around development for television and video, and how to optimize your

Flash movies for publishing on video, film and DVD. I start by demystifying this world

and then move on to explaining the basic principles of exporting your movie to other

formats preparing the way for the more advanced chapter on Flash Video. At the core of

Flash Video is the Flash for Video (FLV) file format. FLV files include encoded audio and

video data that is optimized for delivery through the Flash Player. This keeps the Flash

Player footprint as small as possible by using a single video rendering format.

Chapter 9: Flash Professional and video for broadcast

Macromedia Flash Video easily puts video on a web page in a format that almost anyone

can view. This chapter provides an introduction to Flash Video, including information on

how to create and publish Flash Video. Flash Video is based on the technology behind

the Flash Player – so it’s ready to play in almost all of PCs worldwide. This means:

No more massive player installations.

No lengthy registration forms.

No ads attempting to upsell you to other players.

Chapter 10: Advanced video techniques

In addition to explaining the process of live video, I will, in this chapter, look at keying

effects using the Final Cut Pro keying process and a walk through using Adobe After

Effects. Once we have created our video content I produce a cue movie. The way you

provide the video stream for live video is by using a source of live video, which must be

encoded in real time as it is captured. Unlike the procedure for on-demand video, with

live video the capturing, encoding and publishing steps all happen at the same time.

Because of the need to setup a streaming service I look at am not going to do a tutorial on

live streaming video. But I am going to get you started and in addition I will point you

to services on the web that offer the Flash Media Server for the streaming video.

Chapter 11: 3D animation in a 2D environment

So the first thing you should know about 3D and Flash is that there is no 3D in Flash.

So to attempt to make things look 3D in Flash you need to fake it. Animation is basically

one trick after another. Whatever it takes to get your vision on screen is the right

way. Regardless of the software, whatever you produce will finally be judged on its

appeal and quality. Creating a real 3D scene in a program outside of Flash and bringing

in a pre-rendered 3D animation which is to be displayed frame-by-frame as though

a movie is one approach. Using mathematically calculated 3D from Actionscript

requires an understanding programming and we touch on this and offer a number of

examples for the animator to play with.

Contents in Summary

ix



Chapter 12: Flash Professional tips and tricks

This chapter is all about those little snippets that can make the difference to an animation

production. They are very loosely split into Animation, Flash 8 application and

ActionScript. Sometimes the difference is purely that you organized a large project well

or you spell checked the title. It is unlikely that even the most ardent of Flash animators

developer will not find something interesting in this chapter. The features I cover in this

chapter will save you countless hours by reducing mouse clicks. It has been compiled

from best practices from a number of different sources and then worked on in real

situations over a number of years and then finally adapted to Flash 8.

Showcase

A vibrant showcase of work and games covering animation, typography, mobile content

all using Flash.

Appendix A: Fonts

Appendix B: Flash Lite 2 scripting

Appendix C: Shooting terms

Appendix D: Animation terms

Appendix E: Animation software

Appendix F: TV organizations

Appendix G: CD content

Index

Contents in Summary
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Introduction

Who this Book is for
If you want to learn how to create quality professional animation using Flash and deploy

it across platforms varying from computer screens, PDAs to cell phones, then this is the

book for you. Whether you are a designer who hasn’t yet used Flash, or a professional

animator who wants to create digital animation for the first time, this book will take you

from your first drawing and animation project in Chapter 1, through to a strong

foundation for animation techniques that are just as applicable to the animation world

as they are to the world of the Flash user. This book is thorough and practical, and

tutorial-led, where each chapter helps to build up an understanding through case studies

and example projects reinforcing what you’ve learnt in that section and how it can be

applied in real projects. By having working examples to follow, difficult animation

can become understandable, even easy. However, even if you are not an animator, but

want to learn about enhancing your web presentation by using animation, then you can,

from the material we provide.

Free Commercial Games
I have included a PC Flash game and five (mobile) Flash Lite 2 application in the

showcase and on the CD. The purpose here is not to take you through streams of code

but to allow you to practice your animation skills in a multi-platform environment

animating very basic button through to full character design. In addition to the games,

I have also featured a number of useful code-driven animation that you might find useful

as effect.

There are plenty of great sources for learning Flash basics. In this book we focus on those

aspects of Flash that facilitate animation and sound for multi-platform playback. We start

with the principles of animation and go through to the advanced features. We also

examine animation that takes advantage of the playback device and its limitations. The

intention is that the animator understands the restrictions of different devices and how

to compensate for those devices. If you have never animated before, persevere as the art

of animation is very accessible and Flash can take your spontaneous doodle and, with

creativity and care, turn it into a compelling piece of animation.

xiii



Figure I.1 Commercial site retailing games from this book
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What is Flash?
Flash is one of the most significant applications in the web creation process. It has become

a ‘‘killer app’’ that has been embraced by a wide spectrum of developers. Flash has a large

community with developers freely sharing tips, tricks and processes with each other, and

also contributing to the development of the application itself.

Before Flash, creating animated web sites (complete with sound) involved large files,

which required equally large bandwidth. Flash files are vector based and in contrast,

can be very small, making bandwidth and loading times less of a concern. Furthermore,

Flash has brought a level of advanced animation and interactivity previously unavailable

using traditional Internet technology. Though Flash is predominantly used for the

Internet it is also used outside of the web, for kiosks, for presentations and CD-ROMs,

among other things.

You work in Flash by creating a movie by drawing or importing artwork, arranging it on

the Stage, and animating it with the Timeline. You make the movie interactive by using

actions to make the movie respond to events in specified ways.

The Flash Player
When the movie is complete, you export it as a Flash Player movie to be viewed in

the Flash Player, or as a Flash stand-alone projector to be viewed with a self-contained

Flash Player included within the movie itself. In this book you will learn how to do

all this.

The Flash Player functions as either a stand-alone player or as a web-browser plug-in,

which is available for the two most popular web browsers, Netscape and Internet

Explorer.

Movie Formats
Flash files are often referred to as movies, whether in the authoring environment or in the

final playable form. You create animation and interactivity in Flash-format files, whose

file extension is .fla. To create viewable movies you convert these to Flash Player format,

whose extension is .swf.

Flash is the foremost application for creating the swf format files. The swf files need the

Flash Player plug-in from Macromedia to playback the swf animation. But Flash is not the

only application for creating swfs. Throughout the book I will highlight the different

tools available for building Flash Applications for both Flash and swf playback. Also, if you

need to download the application, Macromedia offers a free 30-day trial of the software

on its site.

xv
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The Flash Player is now available to create animation for all kinds of devices from Internet

pages on computers through to mobile devices such as PDAs and phones. So now we can

watch rich animation using Flash on PDAs whilst on the move. We can watch and play

Flash games in the interactive TV environment from the comfort of our sofa and we can

use Flash to build clear focused interfaces for business products.

This book will teach you the process of animating, using Flash for deployment across all

platforms from cell phones through to PDAs and computers. By looking at detailed

examples provided on the CD, I will take the reader through each stage of creation, build

and deployment. We will look at the complexities of the interfaces and how we cater

for them. Animators can now realize their vision with just an idea and talent, or just

pure enthusiasm and drive.

Flash Professional 8
Flash Professional 8 is the industry’s most advanced authoring environment for creating

interactive web sites, digital experiences and mobile content. For most of the mobile

applications that we have included on the CD and all the Flash Lite scripting you will

need the Flash Professional 8 version and not the standard version.

Flash Professional 8 and Video
Take advantage of the most widely deployed video platform on the Internet. Flash,

originally a web site animation tool, has emerged as a potentially formidable competitor

in the race to build powerful web-based applications and could challenge Microsoft,

RealNetworks and Apple and up-end the web video market with Flash 8. The software’s

video capabilities that are stirring the most interest, particularly among those who

think the new version’s improved codec, which is its particular video compression

format, and various other advantages could make it a significant threat to Microsoft’s

Windows Media technology, RealNetworks’ Real format and Apple Computer’s

QuickTime format.

Many of the big changes in Flash 8 centre on its video capabilities. Flash 8 boasts a new

codec, On2 Technologies’ VP6, that both companies claim will provide dramatically

improved quality over the Flash 7 video codec. Flash 8 also supports alpha transparency,

which lets authors combine Flash video with text, vector graphics and other Flash

elements.

Macromedia published its specification for the swf format allowing numerous alter-

natives to Flash for creating swfs. In the world of 2D we have LiveMotion, Illustrator,

After Effects, Fireworks and Freehand. In the 3D world, every 3D application of note
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has the facility to export content in the swf format. In this book we will look at both

Swift 3D and Poser 6.

There is no shortcut for skills and knowledge, so before you get too involved in looking

at the different tools available, you need to consider and plan your animation. This is

thinking about the project, identifying the right tools and deciding on the right resources

for the right approach.

About Bitmaps and Vectors
Computers display graphics in either vector or bitmap format. Understanding the

difference between the two formats can help you work more efficiently. Flash lets you

create and animate compact vector graphics. It also lets you import and manipulate vector

and bitmap graphics that have been created in other applications.

The data that creates vector and bitmap graphics is similar, they are both mathematical

instructions, but bitmaps are more complex, and result in less manageable graphics.

Vectors are compact and fully scaleable, but are less complex graphically. Bitmap

instructions break the graphic into little dots and have to tell the computer where to place

each dot; vector graphics describe graphics as a series of lines and arcs. If you zoom in on

Figure I.2 Avector image scaled up
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a bitmap you will start to see the image reduce to its dot or pixel structure. If you zoom

in on a vector image you will see that the quality of the line work is maintained. You will

read more about vectors throughout the book.

The tradition of drawn animation is an art form that has only developed in this century.

Film has been the vehicle for this great technology. Traditionally, an animator needed

a large team of artists to produce any moving image. The industry had to standardize

itself; in this standardization, the craft of animation was born. Animation is an art form

that has no limitations but is a discipline that needs to be studied and tailored for whatever

format or environment you are creating content.

Character Development
I have not covered the process of character design in this book, but for me every-

thing starts with the drawing. Drawing on paper still offers the most spontaneous

creative results. The design of a character is explored by sketching from different

angles. This evolves into a clearer character that is then thoroughly worked out in the

Figure I.3 Abitmap graphic with a close-up of the detail
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rough stages. It may take hours of frustration to get to this part but if you persevere

here you will have a solid foundation for a character that might end up living longer

than you.

I tend to sketch with Chromacolor blueline, as the duck drawing shown on the top

left-hand side (Figure I.4). This is my ‘‘work in progress’’ rough. It’s a rough because

it still needs color and shading. As the line work becomes more visible we move onto

the ‘‘clean’’ drawing. I start to add color in pastels. Working in blueline is the way I have

been shown how to do it and I believe that it is still the way of both traditional and

computer animators. All the animators I know draw their roughs in blue pencil.

Specifically Col-erase blue no.1276 from Chromacolor.

The rough is scanned as a JPG and imported into Flash.

The aim now is to recreate classic comic book style lines that look as if they have been

done by drawing with a brush. Brushed lines tend to start off thick and taper to a point.

Ink brushed lines have direction they add weight, depth and subtle perspective to the

drawing. Even in the most modern technical ‘‘Managa’’ style you find this type of line

work. It gives the drawing a dynamic feel. Keep the shapes nice and smooth and keep

the file size down by keeping the anchor points down to a minimum.

I tend to keep all my roughs on Layer 1 and then I lock it. This is to stop it being

accidentally selected and moved about.

On Layer 3, I build up all the ink lines.

Layer 2, I usually put down all the color work and shading. Although to be honest this

usually ends up around a dozen layers.

The final duck image shows the ink lines colored and grouped as required with Flash

shading. Highlighting around the edges helps to give the drawing depth.

xix
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Figure I.4 A duck character in development
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Figure I.5 Drawings can be scanned and auto traced and then tidied up for sharp finished line work. Compare the two halves
of this figure

xxi

Introduction



A Breakdown of the Book
The first part of this book looks at some of the basics of animation which

includes applications for quick animation prototyping (Poser 6), lip-syncing and sound,

as well as other helpful animation tips. We also look at the process or science of

animation. This takes us from in-betweening to walks, runs and exaggeration in the

animated body.

We then move on to bringing sound into the animation. This starts initially with some

basic principles of interactivity and continues through to some complex sound editing.

All the tutorial material is provided with clear explanation on its usage as well as how to

edit it. Although I do not go into the code of the commercial games as that is beyond the

scope an animation book, it is all there for the budding programmer. All examples

throughout the book are contained on the accompanying CD.

The final part of the book looks at the delivery of a completed animation, for computers

that have varied resolution, television screens, PDAs and cell phones that have only

140� 220 pixels with which to play.

Throughout, the chapters are supported by complete FLA files containing all the elements

you need to build your own version of the examples. Also included are games where you

can redraw the characters testing out your new computer-based animation skills in games

development. I recognize the importance of ActionScript and so I have introduced both

basic concepts and complex routines that can be used in the animation process. This will

save time and money. The level of ActionScript we present is geared to give confidence

to the animator to amend and customize code.

xxii
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Figure I.6 Game image from one of the tutorial files on the CD
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Chapter 1
The Art of Animation in Flash 8

Flash Professional 8 is the industry’s most advanced authoring environment for creating

interactive animations, digital experiences and mobile content.



Animators and designers have used Flash, animations and other Flash authored content on web

sites for many years now. While the content provided a rich experience for users, large file sizes

often meant long download times. In response, Macromedia has introduced several advances

in Flash 8 that allow for even richer content while also lowering the file size of the finished

Flash project.

One of the great things that Macromedia did with Flash 8 authored content is to offload much

of the rendering work to Flash Player 8. Using tags in the Flash project, the player can now render

filters in real-time as the user interacts with the project.

But all this technology cannot make an animation work unless the ingredients are there in the

first place. So in the following chapters, I hope to build up a knowledge of professional animation

that is then applied to the Flash environment and not just any Flash environment but Macromedia

Flash 8.

Throughout the book, we will apply some of our newfound knowledge to a game which we

will develop with the chapters. The game has a lot of code that drives it which you are welcome

to use in your own commercial situations. But there will be minimal reference to the code with

just the basics to allow the animator to customize the graphics and no more. More focus will be

given on the techniques of using Flash in a professional environment to produce animations.

We will also look at the art/science of animation.

Making a character’s walk look realistic is a long-lost, and long-cherished, secret of animation.

There’s no simple magical way of doing this but the steps can be broken down into easily

digestible bites that are easy to understand and recreate.

Probably, the most basic yet the most difficult animation is the simple walk cycle. Not only do you

have to decide on the angles of viewing but also you need to think of pace, gait and at the same

time you need to draw this. To help in this process you can use many different aids, the simplest

is your own body. You can watch yourself move and record this. You can ask a friend to do a walk

cycle and grab that. Apart from this, I use the character modeler Poser 6. The following Figure 1.1

is a screen grab of a top-down animation for a Power Rangers game where I use single frame

output from Poser and redraw the frames in FreeHand for final import into Flash 8. You can also

see the original shot of a helmet from a Power Ranger model.

Throughout the book we will be working up a version of this game. Although it is a top-down

view of the game, the issues of movement, frame rate and the animated game play are all the same.

Before you even begin to create animations, there are several important aesthetic issues to take

into account. You need to consider some basic questions, such as:

What is its purpose?

What kind of audience do you want to attract?

Animating with Flash 8
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What are you trying to say?

It is also important to remember, not to overwhelm your audience with moving images. Make

sure that the animation is beneficial to your web site, otherwise you will lose your audience.

Animations that cycle endlessly can quickly become annoying. Design your animation with

a finite number of loops, so that it eventually stops.

Once you’ve decided to create an animated sequence, you need to start with the fundamentals.

Of these, a crucial step is the creation of the storyboard. Here, you detail the animation in a precise

fashion with sketches, scripts, transitions, timing, etc. It is with the storyboard that you can

workout many creative difficulties. More on storyboards is described in Chapter 2.

When objects are in motion, the eye is not able to discern information one would normally

see in a still image and is much more forgiving. This means that detail can be reduced and

made simpler.

Using a very basic character with minimal detail, I have put together a simple tutorial that

looks at a basic walk. Later in Chapter 3 there is a more in-depth analysis of over 20 different styles

of movement with added personality with exaggerated positions, or different speeds, or crazy

walks. In theory you need only a basic knowledge of Flash 8; applying the principles you learned

Figure 1.1 The red circle is the final version of a single frame from the character

Chapter 1: The Art of Animation in Flash 8
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here to your own designs will be effortless.

Once you’ve mastered this basic walk, then you

can give your character your own style and

characterization.

Let’s start building our character using simple

shapes.

Starting with launching man.fla project.

Create a new symbol. From the main menu, go

to the Insert menu, then choose New Symbol.

A new window will open. Click on the graphic

and name the new symbol ‘‘Man’’. Symbols

allow you to use the same asset more than once

without storing multiple copies of it in your

FLA file. You store the symbol in the Library

panel, and drag instances of the symbol to

the Stage when you need them. Think of

symbols as a set of boxes that fit into each other,

you’ll always find a smaller one inside. This

nested hierarchy allows you to have several

levels of animation cycles. For example, let’s

say you have a symbol of a character walking,

inside of which you have another symbol with

the body going up and down, inside which you

have the symbol of the arms moving. Inside the

arm symbol, you could have a hands symbol,

inside which you could have a fist clenching.

I use three levels for this:

� head, torso and front arm layers for the

‘‘Top’’
� 2 legs layers ‘‘Legs’’
� with the back arm layer ‘‘Back Arm’’

This is significant because, as you will see later,

the two halves of the body complement each

another. The legs swing one way while the upper

body swings the other way. The back arm should

stay behind the legs and the body, which is why

it’s on its own layer, obscured from full view.Figure 1.2 Here is the guy we are going to animate

Animating with Flash 8
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The Top
Select the first layer in the layer palette, and rename it ‘‘Top’’. Either using the predrawn assets

or using the shape tools, create a circle for the head and a small square for the nose, like in

Figure 1.3, below. When using your shape tool, be sure to select the stroke color as black and

use white for your fill color. Later, you can recolor your walking man as you choose, but for

now this will keep things clear and easy.

Dragging the selected shapes with your mouse, arrange the nose on the head so the whole

assembly resembles a profile. To select one shape, use the Arrow tool and double-click the fill.

When your creation looks like a face, select the two shapes, go to the Insert menu and choose

‘‘Convert to Symbol’’ and name the symbol ‘‘Top’’. Also, make sure to choose ‘‘Graphic

Behaviors’’, as this will make previewing the animation easier. Now double-click on the

‘‘Top’’ symbol you just created. Select the layer where the head is, then double-click on it and

name it ‘‘head’’.

The Body
Add a new layer with the Insert menu, or click the Add Layer button at the bottom of the

Timeline. Name this new layer ‘‘body’’. You can build the body using the polygon tool or you

can use the predrawn shapes in man.fla.

Figure 1.3

Chapter 1: The Art of Animation in Flash 8
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Select the torso and convert it to a symbol by using the Insert menu. When the symbol dialog

appears, name the symbol ‘‘body’’ and choose ‘‘Graphic Behaviors’’.

Add a second layer underneath using the Insert menu. A shortcut for this is simple – just click the

Add Layer button at the bottom of the Timeline.

Layers are like transparent sheets of acetate stacked on top of each other to help you organize

the artwork in your document. You can draw and edit objects on one layer without affecting

objects on another layer. Layers are totally transparent. Only one layer can be active at a time,

even though more than one layer can be selected at a time.

To draw onto a layer or folder, you select the layer in the Timeline to make it active. A pencil

icon next to a layer or folder name in the Timeline indicates that the layer or folder is active.

When you create a new Flash document, it contains only one layer. You can also hide, lock

or rearrange layers.

Layer folders allow you to organize and manage layers by placing layers in them. You can

expand or collapse layer folders in the Timeline without affecting what you see on the Stage.

In addition, you can use special guide layers to make drawing and editing easier, and mask layers

to help you create sophisticated effects.

Figure 1.4 Your character should look like this
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The Flash tutorials that come with Flash 8 have a great overview of layers. Here is how to find

it; select Help4Flash Tutorials4Basic Tasks4Work with Layers.

The new layer appears higher than the ‘‘head’’ layer in the layer palette, drag it underneath the

‘‘head’’ layer with your mouse. We need to keep the head as the highest layer in the hierarchy

right now.

Name the new layer ‘‘right arm’’. We’re calling it ‘‘right arm’’ because a ‘‘left arm’’ will be added

later. Build the arm by drawing two long rectangles and a small polygon for the hand, as shown

in the illustration. Select the arm and convert it to a symbol using the Insert menu. When the

symbol dialog appears, name the symbol ‘‘right arm’’ and choose ‘‘Graphic Behaviors’’.

Now that we’ve built the symbols for the upper body, make sure that each symbol is on its

own layer, and that the layers are in the following order:

1. ‘‘head’’

2. ‘‘right arm’’

3. ‘‘body’’

You can always change the order of the layers by dragging them around the Layer palette

with your mouse.

The Legs
Click on ‘‘Walk’’ in the top left-hand-corner of your window to go back to the first symbol

we created.

Add a new layer from the Insert menu and name it ‘‘Legs’’. Build a basic outline of a leg or

use the library image as shown in Figure 1.5. It’s easiest to use two long rectangles for the

two different sections of the leg, and then add a triangle for the foot.

Select all of the elements in the leg and convert the leg to symbol.

Name the symbol ‘‘Legs’’, and remember to choose ‘‘Graphic Behaviors’’. Next, change the name

of the ‘‘Legs’’ layer, renaming it ‘‘Front leg’’.

Copy this leg by selecting the symbol and choosing ‘‘Copy’’ from the Edit menu. Add a new layer

using the Insert menu and name it ‘‘Back leg’’. Select the new layer and choose ‘‘Paste in Place’’

from the Edit menu.

To be able to animate each leg separately, we need to create a different instance symbol for each

leg. When we built the back leg, we used the same instance of the symbol as the front leg. Unless

we change this, we will end up with two front legs going through the same motions.
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Select the leg on the ‘‘Front leg’’ layer. In the property panel there is a ‘‘swap’’ button, that

opens the pop-up. With the pop-up open, click on the duplicate button. This will cause

a symbol window to open. Change the name to ‘‘front leg’’ before clicking OK. Do the

same process for the back leg as well, just be sure to name the symbol ‘‘Back leg’’ before

clicking OK.

Now you have 3 leg symbols, 2 of them on Stage as instances and one backup in the library.

Whatever you do to the instanced symbols will not affect the backup one.

We have two layers in our ‘‘Legs’’ symbol

� A top layer called ‘‘Front leg’’
� A second layer called ‘‘Back leg’’

We are going to add a guideline to animate his legs more easily. By placing a guiding circle in

the walk symbol, we won’t risk having it in the way during animation, but we’ll still be able to

see it with onion skinning turned on.

Figure 1.5

Animating with Flash 8

10



Onion Skinning
Flash displays one frame of the animation sequence at a time on the Stage. To help you position

and edit a frame-by-frame animation, you can view two or more frames on the Stage at once.

The frame under the playhead appears in full color, while surrounding frames are dimmed,

making it appear as if each frame were drawn on a sheet of translucent onion-skin paper and the

sheets were stacked on top of each other. Dimmed frames cannot be edited.

Add a layer from Insert menu and keep it selected. Click on Modify in the menu bar and then

on ‘‘Timeline’’ and a pop window will open. Mark this layer as a guide by checking ‘‘Guide’’.

Guide layers are simply layers to guide the positioning of the artwork. Be sure to keep this layer

at the lowest position in the layers palette. For help in aligning objects when drawing, you can

create guide layers. You can then align objects on other layers to the objects you create on the

guide layers. Guide layers are not exported and do not appear in a published SWF file. You can

make any layer a guide layer. Guide layers are indicated by a guide icon to the left of the layer

name. You can also create a motion guide layer to control the movement of objects in a motion

tweened animation. Here is how to find more on guided layers; select Help4Flash

Tutorials4Basic Tasks4Work with Layers.

Figure 1.6 Example of using guide layers as well as onion skinning
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We need to setup a few guiding points to make the walk smooth. Double click on the legs

within the man symbol and add an upper guide layer. This makes sure that the top of your

walker’s legs move from the correct points.

To do this, click the upper layer in the layer palette to make it active, then click on the

add layer icon. Select this new layer, then go to the Modify menu and choose ‘‘Timeline’’

(in previous version of Flash it is called layer). From here, you can turn your normal layer

into a guide layer. Just make sure that the layer underneath the topmost layer doesn’t

become guided. If the layer underneath the topmost layer is guided, select it, go to the

Modify menu and choose Layer. If the ‘‘Guided’’ option is turned on, switch it off. What

we need to make sure here is that, we avoid any dependency from the guide layer to any layers

underneath.

On the new guide layer, create a circle and place it at the top of the legs. The circle should be

the size of the legs’ width, as the two legs should cross each other within the circle. Because

the circle is on a guide layer, it won’t show up in the final animation.

Lock the ‘‘Front leg’’ layer by clicking on the lock symbol in the layer palette. Click on frame 1

of the ‘‘Back leg’’ layer. This will make sure that you avoid working on the wrong leg.

The walk cycle always has one foot up in the air while the other one is on the ground except

for a very brief period of time when both feet are touching the ground. This is called the

‘‘contact position’’ and it is going to take up only one frame of our animation. It is also going to

be our first keyframe.

In animation, keyframes are the main drawings of a movement, such as the first and last frames,

from which we create the in-between frames. To build a keyframe, click on frame 1 of the

‘‘Back leg’’ layer. Using the rotate tool, arrange the legs as shown below.

Go to the Insert menu and choose ‘‘Keyframe’’. You want to insert a keyframe for

each leg layer, one for the front and one for the back. This creates the last contact position

of the step. The left leg moves from behind to forward while the front leg moves forward

to behind.

The front leg is going to swing backwards and end up in the exact same spot where the back

leg touches the ground. The back leg will also swing forward and end up in the same forward

position as the front leg. All you need to do here is reverse the leg positions to create the opposite

extreme within the walk cycle. Copy the frame ‘‘Front leg 1’’ to ‘‘Back leg 2’’ and ‘‘Back leg 1’’

to ‘‘Front leg 2’’. Figure 1.8 shows the legs after they have been reversed. The clue here is

in the leading arm which tell you which leg is in front. However, you might want to color the

legs differently.
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Before we forget, let’s label those two keyframes we just created. That way, when we add more

frames, we know which ones are our keyframes simply by looking at the labels.

Create a new layer, name it ‘‘Labels’’ and add a blank keyframe in frame 1. Select the blank frame,

then go to the Window menu and make the Frame panel visible by choosing ‘‘Panels’’ then

‘‘Frame’’. The Frame panel will appear. Type ‘‘Contact’’ for the label name. Also label frame 2 as

‘‘Contact2’’ to identify these two keyframes as main contact positions for our walker’s legs.

When our walker reaches the midpoint of his step, his legs will pass each other while travelling on

their respective paths. For this reason, we’re going to place a new keyframe right in the middle of

the step. This is called the Passing position.

Hold down the command key (on a Mac) or right-click (in Windows) and select frame 1 all

the way across on each of the three layers and add a frame. To add a frame, go to the Insert

menu and select ‘‘Frame’’. Be sure to add one frame for each layer. With your ‘‘command’’

key down, or while right-clicking (in Windows), select the new frame you just created and

turn it into a keyframe. Label the keyframe ‘‘Passing’’. Next, select the blank frame on the

‘‘Labels’’ layer, then go to the Window menu and make the Frame panel active. When the

Figure 1.7 This is the keyframe for the contact position
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Frame panel appears, the blank frame within the ‘‘Labels’’ layer will be selected. Type ‘‘Passing’’

as the label name.

Arrange the legs so that the front leg is straight at the knee and the back leg is bent. You can toggle

the visibility of the legs in order to make it easier to position them if you’d like.

This passing position is our second keyframe out of three total keyframes. The first and third

keyframes are our contact positions. Next, we need to define the movement of the legs that

appear between our keyframe positions.

To acheive a full step you need to create Flash keyframes by selecting frame 1 from the ‘‘Label’’,

‘‘Right leg’’ and ‘‘Left leg’’ layers and add two frames to each of the two layers. To do this, go

to the Insert menu and select ‘‘Frame’’ while the layers are selected. Be sure to add two frames to

each layer. Now you have two frames in between keyframe 1 and keyframe 2.

To produce a slower walk, you could add three frames in the in-between positions instead of

two, or you could add only one to make the walk faster. Now we need to turn these new

frames into keyframes. With your command key down (right-click in Windows), select the

Figure 1.8 Shows the legs after they have been reversed
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new frames you just created on the two layers. Go to the Insert menu and choose ‘‘Keyframe’’.

Position the legs in between the contact and the passing positions. Use the rotate tool and turn

on onion skinning to help get the positioning just right.

Now we have five frames:

� Frame 1: contact position
� Frame 2: an in-between
� Frame 3: another in-between
� Frame 4: passing position and
� Frame 5: the second contact position

With your command key down (or right-click in Windows), select frame 4 on both layers. Insert

two frames on both the ‘‘Front leg’’ and ‘‘Back leg’’ layers between frames 4 and 5. This pushes

the last contact position all the way to frame 7.

With your command key down (right-click in Windows), select the two frames you just created,

frames 5 and 6, and make them keyframes.

Figure 1.9 This is how each leg should look with onion skinning turned on
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Next, position the legs to fill both frames, creating two more positions between the Passing

position (frame 4) and the Contact position (frame 7). Turn on onion skinning and use the rotate

tool to place the legs.

This is half the walk cycle, which is one step of the legs – the full walk cycle will have two steps.

To check the animation, be sure to put seven frames in the walk symbol as well as seven frames

in scene one. Then, test the scene!

Next, we are going to animate the arms in coordination with the legs. Remember that when

you walk, your arms move in opposition to your legs. To reproduce this effect, we need to

know where the contact and passing positions for the legs are and use them as a reference.

Copy the labels we created in the ‘‘Legs’’ symbol.

Double-click anywhere on your character’s leg to go back to the Legs symbol. Select the whole

‘‘Label’’ layer, then go to the Edit menu and choose ‘‘Copy Frames’’. Click on the top half

of your walker’s body and add a new layer using the Insert menu. Name the layer ‘‘Labels’’, then

add a keyframe on frame 1. Within this new keyframe, choose the ‘‘Paste Frames’’ function

from the Edit menu so that the contact and passing references are duplicated and ready to be used

on the arms.

Go back to the ‘‘walk’’ symbol by clicking on the walk icon in the top left of your

window. To begin working on the arms, double-click on the ‘‘Top’’ symbol by clicking on

your character’s upper body. You can always select the ‘‘Top’’ symbol from the Symbol

menu on the top right side of your Flash window, but by doing so, you won’t see the

onion skinning of your other symbols. So click on your character’s head or torso to begin

working on the ‘‘Top’’ symbol. You will be able to see the onion skinned movement of

the Legs layer.

In the same way we did the legs, let’s animate the front arm. The back arm will eventually need

to be moved down in the layer hierarchy so that it is below the legs. We will take care of the

back arm animation later.

Within the ‘‘Top’’ symbol, add a guide layer at the top. To do this, insert a layer then go to the

Modify menu and choose guide. We are looking for a guide layer as in Figure 1.16.

In the guide layer all that we are trying to do is have the advantage of a construction line that

becomes invisible in the final animation. Name the guide layer ‘‘Connect’’ and use the circle tool

to build a circle in the empty layer. Position the circle on the top of the front arm and the centre

of the body as shown in the illustration below. It will be our guide to animate the arm.

Using the rotation tool, set up your two contact positions in frames 1 and 7 at the beginning

and end of the walk-cycle, and establish a straight-armed passing position in frame 4.
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Again, we have 7 frames.

� Frame 1: ‘‘Contact’’
� Frame 2: in-between
� Frame 3: in-between
� Frame 4: ‘‘Passing’’
� Frame 5: in-between
� Frame 6: in-between
� Frame 7: ‘‘Contact2’’

Now we should have the arms moving back and forth within our keyframes. Before we build

the in-between phases, we have to create some vertical movement in the torso to imitate the

way our bodies naturally move up and down when we walk.

Within the ‘‘Top’’ symbol, setup the first and last contact positions. Go to the last contact position

(frame 7, ‘‘Contact2’’) and select the ‘‘head’’, ‘‘body’’ and the ‘‘Connect’’ guide layer. With your

command key held down (or right-click in Windows), create a keyframe. Inserting a keyframe

with all three layers selected ensures that the keyframe exists on all three layers.

Also create a keyframe in the passing position (frame 4, ‘‘Passing’’) on the ‘‘head’’, ‘‘connect’’

and ‘‘body’’ layers.

Figure 1.10 Arms animate in the same way as the legs
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Select the ‘‘Passing’’ frame and with the command key down (or while right-clicking in

Windows), select the frame all the way down on each of the four top body layers: ‘‘head’’,

‘‘Connect’’, ‘‘body’’ and ‘‘Front arm’’. Insert a keyframe here.

With onion skinning active, move the four layers upward using the up arrow key, as shown in

the illustration.

On each layer use a little motion tweening. Make sure you secure the ‘‘Front Arm’’ by locking it –

select the layer and click on the padlock icon. To apply the motion tweening, select your

first keyframe, which should be our first contact position in frame 1. Be sure to select frame 1

on all the layers except ‘‘Front Arm’’. Next, activate the Frame palette. Within the Frame palette,

find ‘‘Tweening’’ and click on the ‘‘Motion’’ option. Flash automatically creates in-between

frames for your vertical movement from frames 1 through 4 on all your selected layers. Do the

same thing to create the reverse vertical motion between frames 4 and 7, leaving the ‘‘Front Arm’’

layer locked.

Create the in-between frames for the movement of the arms.

Begin with frames 2 and 3. Create keyframes in frames 2 and 3 on the arm layer and position the

arms in between frame 1 and 4. Again, use the rotate tool with onion skinning turned on.

Figure 1.11 Point of passing
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Continue rotating the arm in frames 5 and 6 to create the in-between frames for the second

half of the forward swing. This is the same process that we used for the legs. These frames are

Flash keyframes, which give us much better control over the figure.

Now we have animated the arm through half of our walking cycle, we still need to swing the

arm back towards the start position.

Whilst still on the ‘‘Top’’ symbol, you will see the ‘‘Top’’ icon in the upper left-hand-side of

your Flash window. Now select frame 7, and make sure to select it across all four layers:

‘‘Connect’’, ‘‘body’’, ‘‘Front Arm’’ and ‘‘head’’. Go to the Insert menu, choose ‘‘Frame’’ and

add six more frames up to frame 13. Be sure that the additional frames are added across all

four upper-body layers.

On the ‘‘Front Arm’’ layer, select frames 1 to 6 with your command key down (or right-click

in Windows) and copy all six frames. Then, select frames 8 through 13 and ‘‘paste-frame’’

in your selected frames. While the six frames are still selected, go to the Modify menu, select

‘‘Frame’’, then select ‘‘Reverse’’. Now the front arm should appear to go back and forth across

13 frames!

Figure 1.12 Frames for the second half of the forward swing
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Lock the front arm layer by clicking on the lock icon in the Layer panel. Select the three

remaining layers, ‘‘Connect’’, ‘‘head’’ and ‘‘body’’, and copy the contents of frames 1 through 6.

Then paste the contents into frames 8 through 13. There’s no need to reverse the body movement

within the last six frames because our character will still be moving up and down as he walks

no matter which leg is leading.

We need to animate the back arm. Within the ‘‘Top’’ symbol, unlock the ‘‘Front Arm’’ layer,

select frames 7 through 13, and copy them.

Go to the Insert menu and choose ‘‘Create New Symbol’’. Call it ‘‘Back Arm2’’. Within the Edit

menu, select ‘‘Paste Frames’’. This will drop a copy of frames 7 through 13 from the ‘‘Front Arm’’

symbol into frames 1 through 7 on the ‘‘Back Arm2’’ symbol.

We now need to finish up the other half of the back arm’s movement. Select frames 1 through 6

from the front arm, copy the frames, and then paste the sequence into frames 8 through

13 in the ‘‘Back Arm2’’ symbol. Lastly, select the entire sequence of frames from ‘‘Back Arm2’’,

then go to the Modify menu and choose ‘‘Frame’’. Click on ‘‘Reverse’’ and reverse the

entire arm sequence. Now both of the arms move back and forth in opposition to each other, but

they’re not lined up perfectly just yet.

Figure 1.13 If you switch onion skinning on, you will notice that the arms have a nice arc, this will create a smooth
animation
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Go to the ‘‘Walk’’ symbol and select the original ‘‘Back Arm’’ layer. Go to the properties

window and click on the ‘‘Swap Symbol’’ icon. Select the ‘‘Back Arm2’’ symbol and click OK.

This should replace ‘‘Back Arm’’ with ‘‘Back Arm2’’.

Turn on the layers in outline so it is easier to position your back arm. Reposition the back

arm by placing it in exactly the correct spot. Then reset the visibility for all of your layers.

To see the character walking add frames in the ‘‘Walk’’ symbol and in scene 1. If you don’t

add those frames within the walk symbol, the animation will not show up.

Select the ‘‘Walk’’ symbol on the upper left-hand-side of your Flash window. With the

command key down, (right-click in Windows) highlight all the layers with your mouse and

select every frame, all the way to frame 12. Then add a frame by using the Insert menu.

Perform the same process in ‘‘scene 1’’ with the layer you have. Select the empty frames up

to frame 12, then add a frame using the Insert menu. Be sure to stop at frame 12. The last task

we need to perform on the legs is the reversal of movement from the front leg to the back.

This is very simple, and is the same process we applied to the arms to make them swing in

opposition to each other.

Within the ‘‘Legs’’ object, select the ‘‘Back leg’’ layer. Select frames 2 through 7 and copy the

frames. Go to the ‘‘Front leg’’ layer and paste the frames into frames 8 through 13.

Next go to the ‘‘Front leg’’ layer and copy frames 2 through 7. Choose the ‘‘Back leg’’ layer and

select frames 8 through 13. Paste in the frames you just copied from the front leg. Now you’ll

see the front leg swing back to its starting position at the end of the cycle.

We need to add some rotation to the body. When people walk, their bodies move up and down

and they tend to lean toward the direction they are walking. This has a lot to do with gravity and

forward momentum which is covered in Chapter 3 character animation.

Now that all of the movement for the top of the body is done, let’s finish the leg cycle.

To achieve this forward-leaning effect, let’s use the rotation tool. Within the ‘‘Walk’’ symbol,

select the ‘‘Top’’ layer and add four keyframes at each contact and passing position: frames 4, 7,

10 and 13.

Next, select frame 1, open the Window menu, and make the Info panel active. In the ‘‘Align

& Info’’ panel, choose ‘‘Transform’’. Select ‘‘Rotate’’ and type 4. This provides a slight rotation

forward (clockwise). You could exaggerate wildly or be more subtle, but that’s up to you –

which approach best fits your character’s personality?

Do the same on frame 7 and frame 13. Then motion tween all the keyframes.
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In scene 1 avoid having the same frame play twice. In this case, frame 13 is the same position as

frame 1. Since our walk cycle plays in a loop, we don’t want to see the same frame twice,

otherwise it will appear as a glitch in the animation. Select the four layers within frame 12 and

insert a keyframe on each layer. Then delete frame 13. Go to scene 1 and be sure the time frame

stops on frame 12.

Make your character walk across the screen!

Scale your character down to fit the screen on the left and then insert a keyframe on frame 70.

Move your character to the extreme right side of the screen making sure that you are still in

frame 70. Select frame 1 and build a motion tween for the walk across the screen. Adjust the

number of frames between the left side of the frame and the right side until you achieve the

walking pace. If your character seems to slide while he’s walking, check your foot positioning

and be sure the steps are evenly distributed so that the spacing stays the same during the walk

across screen.

Chapter 3 covers all aspects of the moving character but basically everything stems from

this tutorial. From here onwards all depends on the action of the character, it’s weight and

flexibility and resistance. Playing and manipulating these details is what is going to give life

to your character.

Figure 1.14 Align & Info panel effecting theMovieClip
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Tweening Motion along a Path
Just before we finish this chapter, I think it is useful to be aware that you can move MovieClips

along a path. I have found this method of moving sprites along a Motion guide layer very useful.

It allows you to draw paths along which tweened instances, groups or text blocks can be animated.

You can link multiple layers to a motion guide layer to have multiple objects follow the same

path. A normal layer that is linked to a motion guide layer becomes a guided layer.

Flash animations do not have to move along a straight line; they can take any path. Create

a new file.

Make a new symbol from a circle and then add it to the main layer and call that layer ‘‘ball layer’’.

With the layer active, choose Insert and then Motion Guide.

You’ll notice this created a new guide layer with a loop icon in it.

Click on the guide layer name to make it active. Draw a squiggly line starting at the centre of

the ball and move to the right side of the stage area. Is it not smooth enough? Click on the path

Figure 1.15 Characters walking across screen with onion skinning on
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