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WHERE ARE THE LESSON FILES?
Purchase of this Classroom in a Book in any format gives you access to the lesson 
files you’ll need to complete the exercises in the book.

You’ll find the files you need on your Account page at peachpit.com on the 
Registered Products tab.

1	 Go to www.peachpit.com/register.

2	 Sign in or create a new account.

3	 Enter the ISBN: 9780135298886.

4	 Answer the questions as proof of purchase.

5	 Access the lesson files through the Registered Products tab on your Account page.

6 	 Click the Access Bonus Content link below the title of your product to proceed to 
the download page. Click the lesson file links to download them to your computer.

http://peachpit.com
http://www.peachpit.com/register
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GETTING STARTED
The 2019 release of Adobe Animate CC provides a comprehensive authoring envi-
ronment for creating sophisticated animations and interactive, media-rich appli-
cations that you can publish to a variety of platforms. Animate CC is widely used 
in the creative industry to develop engaging projects that integrate video, sound, 
graphics, and animation. You can create original content in Animate CC or import 
assets from other Adobe applications such as Photoshop CC or Illustrator CC, 
quickly design animation and multimedia, and use code to integrate sophisticated 
interactivity.

Use Animate CC to generate graphics and animation assets, to publish broadcast-
quality animation, to build innovative and immersive websites, to create stand-
alone applications for the desktop, or to create apps to distribute to mobile devices 
running on the Android or iOS system.

With extensive controls for animation, intuitive and flexible drawing tools, and 
output options for HD video, HTML5, WebGL, SVG, mobile apps, desktop appli-
cations, and Flash Player, Adobe Animate CC is a robust multimedia authoring 
environment that enables your imagination to become reality.

About Classroom in a Book
Adobe Animate CC Classroom in a Book (2019 release) is part of the official train-
ing series for Adobe graphics and publishing software developed with the sup-
port of Adobe product experts. The lessons are designed so you can learn at your 
own pace. If you’re new to Animate, you’ll learn the fundamental concepts and 
features you’ll need to use the program. Classroom in a Book also teaches many 
advanced features, including tips and techniques for using the latest version of this 
application.

Although each lesson provides step-by-step instructions for creating a specific 
project, there’s room for exploration and experimentation. You can follow the 
book from start to finish or do only the lessons that correspond to your interests 
and needs. Each lesson concludes with review questions to reinforce what you’ve 
learned.
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What’s new
The 2019 release of Adobe Animate CC provides more expressive tools, powerful 
controls for animation, and robust support for a wider variety of playback platforms.

The lessons in this book provide opportunities to use some of the updated features 
and improvements in Animate CC, including

•	 New layer effects, which allow you to apply filters and color effects to individual 
keyframes on layers

•	 Layer parenting, a powerful new way to establish hierarchies between layers to 
make character animation faster and easier than ever before

•	 AI-driven lip syncing that automatically matches phonemes in graphic symbols 
to dialogue in a soundtrack on the timeline

•	 A new Asset Warp tool that can animate distortions in both vector images and 
bitmap images

•	 Improvements to the Layer Depth panel, which helps create a realistic sense of 
three-dimensional space

•	 New VR 360 and VR Panorama documents to create virtual reality environments 
that are immersive and interactive 

•	 New WebGL glTF Standard and Extended documents that provide greater 
support for WebGL graphics and animation 

Prerequisites
Before you begin using Adobe Animate CC Classroom in a Book (2019 release), 
make sure your system is set up correctly and that you’ve installed the required soft-
ware. You should have a working knowledge of your computer and operating sys-
tem. You should know how to use the mouse and standard menus and commands, 
and also how to open, save, and close files. If you need to review these techniques, 
see the printed or online documentation included with your macOS or Microsoft 
Windows software.

In addition, you need to download the free Adobe AIR runtime, available at  
get.adobe.com/air/, to publish desktop applications in Lesson 12.

http://get.adobe.com/air/
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Installing Animate CC
You must purchase the Adobe Animate CC application as part of Adobe Creative 
Cloud. The following specifications are the minimum required system configurations.

macOS
•	 Multicore Intel® processor

•	 macOS v10.12 (64-bit) or 10.13 (64-bit)

•	 2 GB of RAM (8 GB recommended)

•	 1024x900 display (1280x1024 recommended)

•	 QuickTime 12.x software recommended

•	 4 GB of available hard disk space for installation; more free space required 
during installation (cannot install on a volume that uses a case-sensitive file 
system or on removable flash storage devices)

•	 OpenGL version 3.3 or higher

•	 Internet connection and registration necessary for required software activation, 
validation of subscriptions, and access to online services

•	 QuickTime 10.x software recommended

Windows
•	 Intel® Pentium 4, Intel Centrino®, Intel Xeon®, or Intel Core™ Duo 

(or compatible) processor (2 GHz or faster processor)

•	 Microsoft® Windows® 7 with Service Pack 1 or Windows 10 version 1703

•	 2 GB of RAM (8 GB recommended)

•	 1024x900 display (1280x1024 recommended)

•	 4 GB of available hard disk space for installation; more free space required 
during installation (cannot install on removable flash storage devices)

•	 OpenGL version 3.3 or higher

•	 Internet connection and registration necessary for required software activation, 
validation of subscriptions, and access to online services
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For updates on system requirements and complete instructions on installing the 
software, visit helpx.adobe.com/animate/system-requirements.html.

Install Animate CC from Adobe Creative Cloud at creative.adobe.com and make 
sure that you have your login and password accessible.

Online content
Your purchase of this Classroom in a Book includes online materials provided by 
way of your Account page on peachpit.com. These include the following:

Lesson files
To work through the projects in this book, you will need to download the lesson 
files from peachpit.com. You can download the files for individual lessons, or it may 
be possible to download all of them in a single file.

Web Edition
The Web Edition is an online interactive version of the book providing an enhanced 
learning experience. Your Web Edition can be accessed from any device with a con-
nection to the Internet, and it contains:

•	 The complete text of the book

•	 Hours of instructional video keyed to the text

•	 Interactive quizzes

In addition, the Web Edition may be updated when Adobe adds significant feature 
updates between major Creative Cloud releases. To accommodate the changes,  
sections of the online book may be updated or new sections may be added.

Accessing the lesson files and Web Edition
If you purchased an eBook from peachpit.com or adobepress.com, your Web 
Edition will automatically appear under the Digital Purchases tab on your Account 
page. Click the Launch link to access the product. Continue reading to learn how to 
register your product to get access to the lesson files.

If you purchased an eBook from a different vendor or you bought a print book, you 
must register your purchase on peachpit.com in order to access the online content:

1	 Go to www.peachpit.com/register.

2	 Sign in or create a new account.

http://helpx.adobe.com/animate/system-requirements.html
http://creative.adobe.com
http://peachpit.com
http://peachpit.com
http://peachpit.com
http://adobepress.com
http://peachpit.com
http://www.peachpit.com/register
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3	 Enter the ISBN: 9780135298886.

4	 Answer the questions as proof of purchase.

5	 The Web Edition will appear under the Digital Purchases tab on your Account 
page. Click the Launch link to access the product.

The lesson files can be accessed through the Registered Products tab on your 
Account page. Click the Access Bonus Content link below the title of your 
product to proceed to the download page. Click the lesson file links to download 
them to your computer.

How to use the lessons
Each lesson in this book provides step-by-step instructions for creating one or more 
specific elements of a real-world project. Some lessons build on projects created in 
preceding lessons; most stand alone. All the lessons build on one another in terms 
of concepts and skills, so the best way to learn from this book is to proceed through 
the lessons in sequential order. In this book, some techniques and processes are 
explained and described in detail only the first few times you perform them.

You will create and publish a variety of final project files, such as animated GIFs, 
HTML files, videos, or AIR desktop applications, in the lessons in this book. The 
files in the End folders (01End, 02End, and so on) within the Lesson folders are 
samples of completed projects for each lesson. Use these files for reference if you 
want to compare your work in progress with the project files used to generate the 
sample projects.

The organization of the lessons is also project-oriented rather than feature-oriented. 
That means, for example, that you’ll work with symbols on real-world design proj-
ects over several lessons rather than in just one chapter.

Additional resources
Adobe Animate CC Classroom in a Book (2019 release) is not meant to replace 
documentation that comes with the program or to be a comprehensive reference 
for every feature. Only the commands and options used in the lessons are explained 
in this book. For comprehensive information about program features and tutorials, 
refer to these resources, which you can reach by choosing commands on the Help 
menu or by clicking links in the Start Screen:

Adobe Animate Learn and Support: You’ll find and browse Help and Support 
content at helpx.adobe.com/animate.html. You can also reach that page by choosing 
Help > Animate Help or by pressing F1. On the Learn & Support page, click User 

http://helpx.adobe.com/animate.html
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Guide for documentation on individual features, or visit helpx.adobe.com/animate/
topics.html. Also on the Learn & Support page, click Animate CC manual (PDF) to 
download Help as a printable PDF document.

Animate tutorials: For a range of interactive tutorials on Animate CC features, 
choose Help > Animate Tutorial or visit helpx.adobe.com/animate/tutorials.html. 
A more limited set of tutorials is available within Animate itself by choosing Help > 
Learn or by clicking Learn on the Start screen.

Adobe Creative Cloud tutorials: For inspiration, key techniques, cross-product 
workflows, and updates on new features, go to the Creative Cloud tutorials page, 
helpx.adobe.com/creative-cloud/tutorials.html. Available to all.

Adobe forums: Tap into peer-to-peer discussions, questions, and answers on 
Adobe products at forums.adobe.com. The Adobe Animate CC forum is accessible 
by choosing Help > Adobe Online Forums.

Adobe Create: The online magazine Create offers thoughtful articles on design and 
design issues, a gallery showcasing the work of top-notch designers, tutorials, and 
more. Check it out at create.adobe.com.

Resources for educators: www.adobe.com/education and edex.adobe.com offer 
a treasure trove of information for instructors who teach classes on Adobe soft-
ware. Find solutions for education at all levels, including free curricula that use an 
integrated approach to teaching Adobe software and can be used to prepare for the 
Adobe Certified Associate exams.

Also check out these useful sites:

Adobe Add-ons: creative.adobe.com/addons is a central resource for finding 
tools, services, extensions, code samples, and more to supplement and extend your 
Adobe products.

Adobe Animate CC product home page: www.adobe.com/products/animate.html

Adobe Authorized Training Centers
Adobe Authorized Training Centers offer instructor-led courses and training 
on Adobe products. A directory of AATCs is available at training.adobe.com/
trainingpartners.

http://helpx.adobe.com/animate/topics.html
http://helpx.adobe.com/animate/topics.html
http://helpx.adobe.com/animate/tutorials.html
http://helpx.adobe.com/creative-cloud/tutorials.html
http://forums.adobe.com
http://create.adobe.com
http://www.adobe.com/education
http://edex.adobe.com
http://creative.adobe.com/addons
http://www.adobe.com/products/animate.html
http://training.adobe.com/trainingpartners
http://http://training.adobe.com/trainingpartners
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GETTING ACQUAINTED

Lesson overview
In this lesson, you’ll learn how to do the following:

•	 Create a new file in Adobe Animate CC.

•	 Understand the different Adobe Animate document types.

•	 Adjust Stage settings and document properties.

•	 Add layers using the Timeline panel.

•	 Understand and manage keyframes in the timeline.

•	 Work with imported images in the Library panel.

•	 Move and reposition objects on the Stage.

•	 Add filters and color effects to keyframes.

•	 Open and work with panels.

•	 Select and use tools in the Tools panel.

•	 Preview your animation.

•	 Save your file.

This lesson will take less than 1 hour to complete. Please log in to your 
account on peachpit.com to download the files for this lesson, or go to 
the Getting Started section at the beginning of this book and follow the 
instructions under “Accessing the Lesson Files and Web Edition.” Store 
the files on your computer in a convenient location.

Your Account page is also where you’ll find any updates to the lesson files. 
Look on the Lesson & Update Files tab to access the most current content.

1

http://peachpit.com
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In Animate, the Stage is where you lay out all your 
visual elements, the Timeline panel is where you 
organize frames and layers, and other panels let you 
edit and control your creation.
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Starting Adobe Animate CC 
and opening a file
The first time you start Adobe Animate CC you’ll see the Start workspace, which 
also serves as the New Document dialog box. It displays the categories of project 
you can build along with options for different types and sizes of documents. In this 
lesson, you’ll create a simple slideshow-type animation to showcase a few vacation 
snapshots. You’ll add a background, photos, and some decorative elements, and in 
the process you’ll learn about positioning elements on the Stage and placing them 
along the timeline of the animation so that they appear one at a time, in sequence. 
You’ll begin learning how to use the Stage to organize your visual elements spatially, 
and how to use the Timeline panel to organize your elements temporally.

1	 Start Animate. In Windows, choose Start > Programs > Adobe Animate CC. On 
a Mac, double-click Adobe Animate CC 2019 in the Adobe Animate CC 2019 
folder in the Applications folder.

2	 Choose File > Open. In the Open dialog box, select the 01End.fla file in the 
Lesson01/01End folder and click Open to see the final project.

3	 Choose Control > Test.

Animate exports the project and opens it in a new window.

## Note:  If you 
have not already 
downloaded the project 
files for this lesson to 
your computer from 
your Account page on 
peachpit.com, make 
sure to do so now. See 
“Getting Started” at the 
beginning of the book.

�� Tip:  You can also 
start Animate by 
double-clicking an 
Animate file (*.fla or 
*.xfl), such as the  
01End.fla file that is 
provided to show you 
the completed project.

## Note:  The Output 
panel will display a 
warning saying that the 
bitmaps were packed 
into a sprite sheet and 
that EaselJS is starting 
frame numbers at 0 
instead of 1. You can 
ignore both warnings. 
The first is just a 
notification, and the 
second is irrelevant 
because you are playing 
the timeline straight 
from beginning to end.

http://peachpit.com
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An animation plays. During the animation, several overlapping photos appear 
one by one, with stars appearing at the end. As the new photos appear, the 
previous photos become blurry, receding into the background.

4	 Close the preview window and the FLA file.

Understanding document types 
and creating a new document
Animate is an animation and multimedia authoring tool that creates media for mul-
tiple platforms and playback technologies. Knowing where your final animation will 
play determines what type of document you’ll choose when you create a new file.

Playback environment
The playback, or runtime, environment is the technology that your final, published 
files use to play. Your animation could play in a browser with the Flash Player, or 
they could play in a browser with HTML5 and JavaScript. Perhaps your animation 
will be exported as a video to be uploaded to YouTube. Or your project could play 
as an app on a mobile device or even as a virtual reality immersive experience. You 
should make that decision first so you can choose the appropriate document type.

Document types
Regardless of the playback environment and document type, all documents are 
saved as FLA or XFL (Animate) files. The difference is that each document type is 
configured to export different, final published files.

•	 Choose HTML5 Canvas to create animated assets that play back in a modern 
browser using HTML5 and JavaScript. You can add interactivity by inserting 
JavaScript within Animate or adding it to the final published files.

•	 Choose WebGL-glTF-Extended or Standard for interactive animated assets to 
take advantage of hardware-accelerated support of graphics, or for supported 3D 
graphics.

•	 Choose ActionScript 3.0 to create animation and interactivity that plays in the 
Flash Player in a desktop browser or for creating animation to be exported for 
HD video. ActionScript 3.0 is the latest version of the native scripting language 
in Animate, which is similar to JavaScript. Choosing an ActionScript 3.0 
document doesn’t mean you have to include ActionScript code.

## Note:  Not all 
features are supported 
across all document 
types. For example, 
HTML5 Canvas 
documents don’t 
support the 3D Rotation 
or Translation tool. Tools 
that are not supported 
by the current 
document type are 
dimmed in the Animate 
interface.

## Note:  Animate 
supports only 
ActionScript 3.0. If you 
need ActionScript 1.0 or 
2.0, you must work with 
Flash Professional CS6 
or earlier.

## Note:  The 
ActionScript 3.0 
document also supports 
publishing content as 
a projector for either 
Windows or macOS. 
A projector plays as a 
stand-alone application 
on the desktop, without 
needing a browser.
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Be aware that Adobe will no longer support the Flash Player in browsers beyond 
2020. Despite this impending end-of-life date for the Flash Player, it’s best to 
think of an ActionScript 3.0 document as one that supports the widest range 
of drawing and animation features in Animate from which you can ultimately 
export animation assets, such as sprite sheets or PNG sequences, or finished 
high-definition video.

•	 Choose AIR for Desktop to create animation and interactivity that plays as an 
application on Windows or macOS desktops, without needing a browser. You 
can add interactivity in an AIR document using ActionScript 3.0.

•	 Choose AIR for Android or AIR for iOS to publish an app for an Android or 
an Apple mobile device. You can add interactivity for your mobile app using 
ActionScript 3.0.

•	 Choose VR Panorama or VR 360 to publish a virtual reality project for the web 
browser that lets your audience look in all directions. You can add animation or 
interactivity to your immersive environments.

Creating a new document
You’ll create the simple animation that you previewed earlier by starting a new 
document. Animate offers two interfaces for creating new documents: the standard 
New Document dialog box and the slightly more elaborate Start screen (which is 
always displayed if no document is open). Both interfaces contain the same controls 
for defining the parameters of new documents, whether by selecting a preset for the 
most common types of intended projects or by choosing your own document type 
with specific values for its width and height.

The presets are grouped in six categories of intended uses (listed across the top of 
the dialog box); click a category to display the presets it contains in the center of the 
dialog box. You can either use the presets as given or fine-tune their settings using 
the Details section on the right side of the dialog box. Type the document’s dimen-
sions (in pixels) into the Width and Height boxes and choose a document type from 
the Platform Type menu, which lists the platforms on which Animate can play back 
content.

If you would prefer to customize the document settings from scratch, then select 
the Advanced category at the far right. The center of the dialog box will now 
display all the available platforms. You can select a document type, and type your 
document’s dimensions into the Width and Height boxes.

�� Tip:  You can easily 
switch from one 
document type to 
another. For example, 
you can convert 
an ActionScript 
3.0 document into 
an HTML5 Canvas 
document if you have 
an old Flash banner 
ad animation that you 
want to update. Choose 
File > Convert To > 
[new document type]. 
Some functionality 
and features may be 
lost in the conversion, 
however. For example, 
conversion to an HTML5 
Canvas document 
will comment out 
ActionScript code.

## Note:  The Start 
screen adds an extra 
column to the left side 
of the same content 
displayed in the New 
Document dialog 
box. At the top of the 
column are buttons 
that you click to toggle 
between displaying 
Home content (the 
default view) and Learn 
content (video tutorials 
to help you start using 
Animate quickly). Below 
those buttons are the 
Open button (to find 
and open existing files) 
and a list of recently 
opened files (click a 
filename to open it).
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1	 From the Home screen in Animate, select the Advanced category.

2	 In the Platforms area in the center of the dialog box, select ActionScript 3.0. In 
the Details area on the right side of the dialog box, choose the dimensions of 
the Stage by entering new pixel values for the Width and Height. Enter 800 for 
Width and 600 for Height. 
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3	 Click Create.

Animate creates a new ActionScript 3.0 document with the specified Stage 
dimensions.

4	 Choose File > Save. Name the file 01_workingcopy.fla, and from the File 
Format/Save As Type menu, choose Animate Document (*.fla). Although the 
software application is called Animate, be aware that the file extension is .fla or 
.xfl, which both preserve echoes of the name of the ancestor of Animate: “Flash.” 
Navigate to the 01Start folder and click Save.

Saving your file right away is a good working habit that ensures your work  
won’t be lost if the application or your computer crashes. You should always 
save your Animate file with the extension .fla (or .xfl if you save it as an Animate 
Uncompressed Document) to identify it as the Animate source file.

Getting to know the workspace
The Animate work area includes the command menus at the top of the screen and 
a variety of tools and panels for editing and adding elements to your movie. You 
can create all the objects for your animation in Animate, or you can import ele-
ments you’ve created in Adobe Illustrator CC, Adobe Photoshop CC, Adobe After 
Effects CC, or other compatible applications.

By default, Animate displays the menu bar, Timeline panel, Stage, Tools panel, 
Properties panel, Edit bar, and a few other panels. As you work in Animate, you can 
open, close, group, ungroup, dock, undock, and move panels around the screen to 
fit your work style or your screen resolution.

## Note:  If you 
save your Animate 
document as an 
Animate Uncompressed 
Document (.xfl), your 
document is saved as 
a collection of files in 
folders and not as a 
single document. This 
exposes the contents of 
your document to you 
and to other developers 
to swap assets easily. 
The XFL format is a 
more advanced saved 
document that you 
won’t be using in this 
book.
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Layers Timeline

Edit bar Application bar Properties

Stage

Workspace switcher

Tools panel

Choosing a new workspace
Animate also provides a few preset panel arrangements (“workspaces”) that may 
better suit the needs of particular users. Use the Window > Workspaces submenu 
to choose a different workspace or to save a new one. The same functionality is pro-
vided by the workspace switcher at the right end of the Application bar.

1	 Click the workspace switcher and choose a new workspace.

The various panels are rearranged and resized according to their importance in 
the chosen workspace. For example, the Animator and Designer workspaces put 
the Timeline panel at the top of the work area for easy and frequent access.

2	 If you have moved some of the panels around and want to return to one of the 
prearranged workspaces, choose Window > Workspaces > Reset [preset name] 
and click OK in the confirmation dialog box.
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3	 To return to the default workspace, choose Window > Workspaces > Essentials. 
In this Classroom in a Book, we’ll be using the Essentials workspace.

Saving your workspace
If you find an arrangement of panels that suits your style of work, you can save it as 
a custom workspace and return to it at a later date.

1	 Open the workspace switcher and choose New Workspace.

The New Workspace dialog box appears.

2	 Enter a name for your new workspace. Click OK.

Animate saves the current arrangement of panels and adds it to the options in 
the Workspace menu, which you can access at any time.

About the Stage
The big white rectangle in the middle of your screen is called the Stage. As with 
a theater stage, the Stage in Animate is the area that viewers see when a movie is 
playing. It contains the text, images, and video that appear on the screen. Move ele-
ments on and off the Stage to place them in and out of view. You can use the rulers 
(View > Rulers) or grids (View > Grid > Show Grid) to help you position items on 
the Stage. Other positioning aids include guides (pulled from the top or side rulers; 
View > Guides) or the Align panel and other tools you’ll learn about in later lessons 
in this book.

By default, you’ll see the gray area off the Stage where you can place elements that 
won’t be visible to your audience. The gray area is called the pasteboard. To see 
only the Stage, choose View > Magnification > Clip To Stage to select the option. 
For now, leave Clip To Stage deselected, allowing the pasteboard to remain in view.

�� Tip:  By default, the 
Animate interface is 
rather dark. However, 
you can change the 
interface to a lighter 
gray if you prefer. 
Choose Animate CC > 
Preferences (macOS) 
or Edit > Preferences 
(Windows), and in the 
General preferences 
category, choose Light 
from the User Interface 
menu. On the other 
hand, if you don’t find 
it dark enough, you can 
choose Darkest from 
the menu to make the 
interface almost black.
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You can also click the Clip Content Outside The Stage button to crop the graphic 
elements that fall beyond the Stage area to see how your audience will view your 
final project.

Default Stage

Stage with Clip Content Outside The Stage selected

To scale the Stage so that it fits completely in the application window, choose 
View > Magnification > Fit In Window. You can also choose different magnification 
view options from the menu just above the Stage.

�� Tip:  You can view 
the Stage in full-
screen mode without 
the distraction of 
the various panels 
by choosing View > 
Screen Mode > Full 
Screen Mode. Press F4 
to toggle the panels, 
and press the Esc key 
to return to Standard 
Screen Mode.
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Changing the Stage properties
Now you’ll change the color of the Stage. The Stage color, along with document 
properties such as the Stage dimensions and frame rate, is available in the Properties 
panel, which is the vertical panel just to the right of the Stage.

1	 In the Properties pane of the Properties panel, note that the dimensions of the 
current Stage (the Size parameters) are set at 800x600 pixels, which you chose 
when you created the new document.

2	 Also in the Properties pane, click the Background Color box next to Stage: and 
choose a new color from the color palette. Choose dark gray (#333333).

Your Stage is now a different color. You can change the Stage properties at any 
time.
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Working with the Library panel
The Library panel is accessible from a tab just to the right of the Properties 
panel. The Library panel displays the contents of your document’s library, which 
is where you store and organize symbols created in Animate, as well as imported 
files, including bitmaps, graphics, sound files, and certain video clips. Symbols are 
graphics used frequently for animation and for interactivity.

About the Library panel
The Library panel lets you organize library items in folders, see how often an item 
is used in a document, and sort items by type. You can also create folders in your 
Library panel to help group items. When you import items into Animate, you can 
import them directly onto the Stage or into the library. However, any item you 
import onto the Stage is also added to the library, as are any symbols you create. You 
can then easily access the items to add them to the Stage again, edit them, or see 
their properties.

To display the Library panel, choose Window > Library, or press Command+L (macOS)/ 
Ctrl+L (Windows).

Importing an item to the Library panel
Often, you’ll create graphics directly with the drawing tools in Animate and save 
them as symbols, which are stored in the library. Other times you’ll import media 
such as JPEG images or MP3 sound files, which are also stored in the library. In this 
lesson, you’ll import several images into the library to be used in the animation.

1	 Choose File > Import > Import To Library. In the Import To Library dialog box, 
select the background.png file in the Lesson01/01Start folder and click Open. 
Choose All Files (*.*) from the Enable menu if the image files are dimmed.

Animate imports the selected PNG image and places it in the Library panel.

2	 Continue importing photo1.jpg, photo2.jpg, and photo3.jpg from the 01Start 
folder.

You can also hold down the Shift key to select multiple files and import all of the 
images at once.

The Library panel lists the filenames of all the imported images and provides a 
thumbnail preview of any selected file. These images are now available to be used 
in your Animate document.

## Note:  You’ll learn 
much more about 
symbols in Lesson 2.

�� Tip:  You can also 
access the assets 
that you’ve stored in 
your Creative Cloud 
account by clicking 
the CC Libraries 
icon (Window >  
CC Libraries).

�� Tip:  If the Enable 
menu isn’t visible, click 
the Options button to 
activate it.
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Adding an item from the Library panel to the Stage
To use an imported image, simply drag it from the Library panel onto the Stage.

1	 Choose Window > Library to open the Library panel if it isn’t already open.

2	 Drag the background.png item onto the Stage and place it approximately in the 
center of the Stage.

Understanding the Timeline panel
In the default Essentials workspace, the Timeline panel is located below the Stage. 
The Timeline panel contains playback controls for your animation as well as the 
timeline itself, which displays the sequence of events in the animation in linear form 
through time. An Animate movie measures time in frames, just as in a filmstrip. As 

�� Tip:  You can also 
choose File > Import > 
Import To Stage, or 
press Command+R 
(macOS) or Ctrl+R 
(Windows), to import an 
image file to the library 
and put it on the Stage 
all in one step.
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the movie plays, the playhead, shown as a red vertical line, advances through the 
frames shown in the timeline. You can change the content on the Stage for different 
frames. To display a frame’s content on the Stage for any particular time, move the 
playhead to that frame in the timeline. 

At the top of the Timeline panel, Animate indicates the selected frame number, 
the current frame rate (how many frames play per second), and the time that has 
elapsed so far in the movie.

Frame rate

Elapsed time (seconds)

Current frame

The timeline portion of the Timeline panel also displays layers, which help you 
organize the artwork in your document. At the moment, your project has only 
one layer, which is called Layer_1. Think of layers as multiple filmstrips stacked on 
top of one another. Each layer can contain a different image that appears on the 
Stage, and you can draw and edit objects on one layer without affecting objects 
on another layer. The layers are stacked in the order in which they overlap each 
other so that objects on the bottom layer in the timeline are on the bottom of the 
stack on the Stage. You can hide, lock, or show the contents of layers as outlines by 
clicking the dots or square in the layer under the layer option icons.

Show Layer As Outlines

Layer 
Name

Show/Hide Layer

Lock/
Unlock Layer
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Changing the appearance of  
the timeline
You can adjust the timeline’s appearance to accommodate your workflow. When you 
want to see more layers, choose Short from the Frame View menu in the upper-right 
corner of the Timeline panel. The Short option decreases the height of frame cell 
rows. The Preview and Preview In Context options display thumbnail versions of the 
contents of your keyframes in the timeline.

You can also change the width of the frame cells by choosing Tiny, Small, Normal, 
Medium, or Large. In this book, we show the timeline frames in their default size of 
Normal.

Reset Timeline Zoom

Resize Timeline Zoom

For finer control over the timeline frame sizes, drag the Resize Timeline View slider. 
The slider adjusts the size of the frames so you can see more or less of the timeline. 
Click the Reset Timeline Zoom To The Default Level button to revert the Timeline 
view to its Normal size.

Renaming a layer
It’s a good idea to separate your content on different layers and name each layer to 
indicate its contents so that you can easily find the layer you need later.

1	 Double-click the name of the existing layer, Layer_1, to rename it, and type 
background.
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2	 Click outside the name box to apply the new name.

3	 Click the dot below the lock icon to lock the layer. Locking a layer prevents you 
from accidentally moving or making changes to whatever is inside that layer.

A lock icon appears in the layer. The lock icon indicates that you can’t make 
edits to the layer because it is locked.

Adding a layer
A new Animate document contains only one layer, but you can add as many layers 
as you need. Objects in the top layers will overlap objects in the bottom layers.

1	 Select the background layer in the timeline.

2	 Choose Insert > Timeline > Layer. You can also click the New Layer button  
above the timeline. A new layer appears above the background layer.

3	 Double-click the new layer to rename it, and type photo1. Click outside the 
name box to apply the new name.

Your timeline now has two layers. The background layer contains the 
background photo, and the newly created photo1 layer above it is empty.
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4	 Select the top layer, called photo1.

5	 Choose Window > Library to open the Library panel if it isn’t already open.

6	 Drag the library item called photo1.jpg from the library onto the Stage.

The photo1 JPEG appears on the Stage and overlaps the background image.

7	 Choose Insert > Timeline > Layer, or click the New Layer button above the 
timeline, to add a third layer.

8	 Rename the third layer photo2.

Working with layers
If you don’t want a layer, you can easily delete it by selecting it and then clicking the 
Delete button above the timeline.

If you want to rearrange your layers and change how your graphics overlap each 
other, simply drag any layer up or down to move it to a new position in the layer stack.

## Note:  As you 
add more layers and 
your overlapping 
graphics become more 
complicated, click the 
dot below the eye icon 
in any layer to hide its 
contents. Alternatively, 
hold Shift and click 
the dot below the eye 
icon to make the layer 
partially transparent 
so that you can see 
what’s below it. Hiding 
or making a layer 
transparent affects 
only how you see your 
project in Animate—it 
doesn’t affect your 
final exported project. 
Double-click the Layer 
icon to modify the 
level of transparency 
in the Layer Properties 
dialog box.
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Inserting frames
So far, you have a background photo and another overlapping photo on the Stage, 
but your entire animation exists for only a single frame, which is only a fraction of 
a second. To create more time on the timeline and make this animation run for a 
longer duration, you must add additional frames.

1	 Select frame 48 in the background layer. Use the Resize Timeline View slider at 
the upper-right corner of the Timeline panel to expand the timeline frames to 
make it easier to identify frame 48.

2	 Choose Insert > Timeline > Frame (F5). You can also right-click and choose 
Insert Frame from the context menu that appears.

Animate adds frames in the background layer up to the selected frame, frame 48.

3	 Select frame 48 in the photo1 layer.

4	 Choose Insert > Timeline > Frame (F5) or right-click and choose Insert Frame to 
add frames in the photo1 layer up to frame 48.

5	 Select frame 48 in the photo2 layer and insert frames on this layer.

You now have three layers, all with 48 frames on the timeline. Since the frame 
rate of your Animate document is 24 frames per second, your current animation 
lasts 2 seconds.

Selecting multiple frames
Just as you can hold down the Shift key to select multiple files on your desktop, you 
can hold down Shift to select multiple frames on the Animate timeline. If you have 
several layers and want to insert frames into all of them, hold down Shift and drag 
where you want to add frames. Then choose Insert > Timeline > Frame.
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Creating a keyframe
A keyframe indicates a change in content on the Stage. Keyframes are indicated on 
the timeline as a circle. An empty circle means there is nothing in that particular 
layer at that particular time. A filled-in black circle means there is something in that 
layer at that time. The background layer, for example, contains a filled keyframe 
(black circle) in the first frame. The photo1 layer also contains a filled keyframe in 
its first frame. Both layers contain photos. The photo2 layer, however, contains an 
empty keyframe in the first frame, indicating that it is currently empty.

Filled keyframe

Empty keyframe

You’ll insert a keyframe in the photo2 layer at the point in time when you want the 
next photo to appear.

1	 Select frame 24 on the photo2 layer. The frame number of a selected frame is 
displayed above the left end of the timeline.

2	 Choose Insert > Timeline > Keyframe (F6).

A new keyframe, indicated by an empty circle, appears in the photo2 layer in 
frame 24.

3	 Select the new keyframe at frame 24 in the photo2 layer.

4	 Drag photo2.jpg from your library onto the Stage.
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The empty circle at frame 24 becomes filled, indicating that there is now content 
in the photo2 layer. When your animation plays, your photo appears on the 
Stage at frame 24. You can drag the red playhead along the top of the timeline 
to “scrub,” or show what’s happening on the Stage, at any point along the 
timeline. You’ll see that the background photo and photo1 remain on the Stage 
throughout the timeline but that photo2 appears only at frame 24.

Understanding frames and keyframes is essential for mastering Animate. Be sure 
you understand how the photo2 layer contains 48 frames with two keyframes—an 
empty keyframe at frame 1 and a filled keyframe at frame 24.

photo2 layer contains 
content in frames 24–48

photo2 layer is empty 
in frames 1–23

Moving a keyframe
If you want photo2.jpg to appear later or earlier in time, you need to move the key-
frame in which it appears closer to or farther from the right on the timeline. You 
can easily move any keyframe by simply dragging it to a new position.



20  LESSON 1  GETTING ACQUAINTED

1	 Select the keyframe in frame 24 on the photo2 layer.

2	 Move your mouse cursor slightly, and you’ll see a box icon appear near your 
cursor indicating that you can reposition the keyframe.

3	 Drag the keyframe to frame 12 in the photo2 layer.

The photo2.jpg file now appears on the Stage much earlier in the animation.

Removing keyframes
If you want to remove a keyframe, do not press the Delete/Backspace key! Doing 
so will delete the contents of that keyframe on the Stage, leaving you with an 
empty keyframe. Instead, select the keyframe and choose Modify > Timeline > Clear 
Keyframe (Shift+F6). Your keyframe (and its contents) will be removed from the 
timeline.

Organizing layers in a timeline
At this point, your working Animate file has only three layers: a background layer, 
a photo1 layer, and a photo2 layer. You’ll be adding more layers for this project, and 
as in most other projects, you’ll end up having to manage multiple layers. Layer 
folders help you group related layers to keep your timeline organized and manage-
able, just as you make folders for related documents on your desktop. Although it 
may take some time to create the folders, you’ll save time later because you’ll know 
exactly where to look for a specific layer.



ANIMATE CC CLASSROOM IN A BOOK (2019 RELEASE)  21

Creating layer folders
For this project, you’ll continue to add layers for additional photos, and you’ll place 
those layers in a layer folder.

1	 Select the photo2 layer and click the New Layer button above the timeline.

2	 Name the layer photo3.

3	 Insert a keyframe at frame 24.

4	 Drag photo3.jpg from the library onto the Stage.

You now have four layers. The top three contain photos of scenes from Coney 
Island that appear at different keyframes.
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5	 Select the photo3 layer and click the New Folder icon  at the top of the 
Timeline panel.

A new layer folder appears above the photo3 layer.

6	 Name the folder photos.

Adding layers to layer folders
Now you’ll add the photo layers to the photos folder. As you arrange layers, remem-
ber that Animate displays the content in the layers in the order in which they appear 
in the timeline, with the top layer’s content at the front and the bottom layer’s 
content at the back.

1	 Drag the photo1 layer into the photos folder.

Notice how the bold line indicates the destination of your layer. When you place 
a layer inside a folder, Animate indents the layer name.

2	 Drag the layers photo2 and photo3 into the photos folder.

All three photo layers should be in the photos folder, in the same stacking order 
as they were in outside the folder.
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You can collapse the folder by clicking the arrow just to the left of the folder name. 
Expand the folder by clicking the arrow again. Be aware that if you delete a layer 
folder, you delete all the layers inside that folder as well.

Cut, copy, paste, and duplicate layers
When managing multiple layers and layer folders, you can rely on cut, copy, paste, 
and duplicate layer commands to make your workflow easier and more efficient. All 
the properties of the selected layer are copied and pasted, including its frames, its 
keyframes, any animation, and even the layer name and type. You can also copy and 
paste layer folders and their contents.

To cut or copy any layer or layer folder, simply select the layer, right-click the layer 
name, and choose Cut Layers or Copy Layers.

Right-click the timeline again and choose Paste Layers. The layer or layers that you 
cut or copied are pasted into the timeline. Use Duplicate Layers to copy and paste in 
one operation.

You can also cut, copy, paste, or duplicate layers from the application menu bar. 
Choose Edit > Timeline, and then choose Cut Layers, Copy Layers, Paste Layers, or 
Duplicate Layers.
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Using the Properties panel
The Properties panel gives you quick access to the attributes you’re most likely to 
need. What appears in the Properties panel depends on what you’ve selected. For 
example, if nothing is selected, the Properties panel includes options for the general 
Animate document, including changing the Stage color or dimensions. If you’ve 
selected an object on the Stage, the Properties panel shows its x and y coordinates 
and its width and height, among other information. You’ll use the Properties panel 
to move your photos on the Stage.

Positioning an object on the Stage
You’ll begin by using the Properties panel to move the photos. You’ll also use the 
Transform panel to rotate the photos.

1	 Move the playhead to frame 1 of the timeline, select the photo1.jpg image that 
you dragged onto the Stage in the photo1 layer. A very narrow blue outline 
indicates that the object is selected.

2	 In the Properties panel, type 50 for the X value and 50 for the Y value. Press 
Return (macOS)/ Enter (Windows) to apply the values. You can also drag over 
the X and Y values to change their values. The photo moves to the left side of 
the Stage.

The X and Y values are measured on the Stage from the upper-left corner. 
X begins at 0 and increases to the right, and Y begins at 0 and increases 
downward. The registration point (the point from which Animate makes 
measurements) for imported photos is at the upper-left corner.

3	 Choose Window > Transform to open the Transform panel.

4	 In the Transform panel, select Rotate and type –12 in the Rotate box, or drag 
over the value to change the rotation. Press Return/Enter to apply the value.

�� Tip:  If the Properties 
panel is not open, 
choose Window > 
Properties, or press 
Command+F3 (macOS) 
or Ctrl+F3 (Windows).
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The selected photo on the Stage rotates 12 degrees counterclockwise.

5	 Select frame 12 of the photo2 layer. Now click photo2.jpg on the Stage to select it.

6	 Use the Properties panel and Transform panel to position and rotate the second 
photo in an interesting way. Use X=200, Y=40, and a Rotate value of 6 to give it 
some contrast with the first photo.
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7	 Select frame 24 in the photo3 layer. Now click photo3.jpg on the Stage to select it.

8	 Use the Properties panel and Transform panel to position and rotate the third 
photo in an interesting way. Use X=360, Y=65, and a Rotate of –2 so that all 
your photos have visual variety.

Working with panels
Just about everything you do in Animate involves a panel. In this lesson, you use 
the Library panel, Tools panel, Properties panel, Transform panel, History panel, and 
Timeline panel. In later lessons, you’ll learn to use other panels to control various 
aspects of your project. Because panels are such an integral part of the Animate 
workspace, it pays to know how to manage them.

## Note:  When images 
are scaled or rotated 
in Animate, they may 
appear jagged. You 
can use the Bitmap 
Properties dialog box 
to smooth each image. 
Double-click the bitmap 
icon or the image 
thumbnail in the Library 
panel to open the 
dialog box and select 
the Allow Smoothing 
option.
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To open any panel in Animate, choose its name from the Window menu.

Panel groups

Expand Icon
Collapse Panels 

To Icons

Dock containing 
panels collapsed 
to icons

Dock containing 
only the Tools 
panel

Panel docks

Individual panels float freely, and they can be combined in docks, groups, or stacks.

•	 A dock is a collection of panels or panel groups in a vertical column. Docks stick 
to the left or right edges of the user interface.

•	 A group is a collection of panels that can be placed within a dock or that can 
float freely.

•	 A stack is similar to a dock but can be placed anywhere in the interface.

In the default Essentials workspace, most of the panels are organized in three docks 
on the right side of the screen. The Timeline and Output panels are grouped at the 
bottom, and the Stage is on the top. However, you can move a panel to any position 
that is convenient for you.

•	 To move a panel, drag it by its tab to a new location.

•	 To move a panel group or stack, drag it by the area next to the tabs.
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As the panel, group, or stack passes over other panels, groups, docks, or stacks, a 
blue highlighted drop zone will appear. If you release the mouse button while a 
drop zone is visible, the panel will be added to the group, dock, or stack.

•	 To dock a panel, drag it by its tab into a new position at the left or right edge of 
the screen. If you drag it over the top or bottom of an existing dock, a horizontal 
drop zone will show you the panel’s new location. If a vertical drop zone 
appears, dropping the panel will create a new dock.

•	 To group a panel, drag its tab onto the tab of another panel or the drop zone at 
the top of an existing group.

•	 To create a stack, drag a group out of a dock or an existing stack so it floats 
freely. Alternatively, drag one free-floating panel onto the tab of another 
floating panel.

You also have the option of displaying most of the panels as icons to save space but 
still maintain quick access. Click the double arrowheads in the upper-right corner of 
a dock or stack to collapse the panels to icons. Click the double arrowheads again to 
expand the icons into panels.

Using the Tools panel
The Tools panel—the long, narrow panel on the far right side of the work area—
contains selection tools, drawing and type tools, painting and editing tools, naviga-
tion tools, and tool options. You’ll use the Tools panel frequently to switch to tools 
designed for the task at hand. Most often, you’ll use the Selection tool, which is the 
black arrow tool at the top of the Tools panel, for selecting and clicking items on the 
Stage or the Timeline. When you select a tool, check the options area at the bottom 
of the panel for more options and other settings appropriate for your task.

Selecting and using a tool
When you select a tool, the options available at the bottom of the Tools panel and 
the Properties panel change. For example, when you select the Rectangle tool, the 
Object Drawing Mode and Snap To Objects options appear. When you select the 
Zoom tool, the Enlarge and Reduce options appear.

The Tools panel contains too many tools to display all at once. Some tools are 
arranged in hidden groups in the Tools panel; only the tool you last selected from 
a group is displayed. A small triangle in the lower-right corner of the tool’s button 
indicates that there are other tools in the group. Press and hold the icon for the vis-
ible tool to see the other tools available, and then select one from the menu.

Selection and 
transformation 
tools

Drawing tools

Editing tools

Options


