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WHERE ARE THE LESSON FILES?
Purchase of this Classroom in a Book in any format gives you access to the lesson files you’ll 
need to complete the exercises in the book. 

You’ll find the files you need on your Account page at peachpit.com on the Registered 
Products tab.

1	 Go to www.peachpit.com/register.

2	 Sign in or create a new account.

3	 Enter the ISBN: 9780135262146

4	 Answer the questions as proof of purchase.

5	 The lesson files can be accessed through the Registered Products tab on your Account page.

6 	 Click the Access Bonus Content link below the title of your product to proceed to the 
download page. Click the lesson file links to download them to your computer.

http://peachpit.com
http://www.peachpit.com/register
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Adobe® Dreamweaver CC is one of the leading web-authoring programs 
available. Whether you create websites for others for a living or plan to create 
one for your own business, Dreamweaver offers all the tools you need to get 
professional-quality results.

About Classroom in a Book
Adobe Dreamweaver CC Classroom in a Book® (2019 release) is part of the 
official training series for graphics and publishing software developed with the 
support of Adobe product experts.

The lessons are designed so that you can learn at your own pace. If you’re new 
to Dreamweaver, you’ll learn the fundamentals of putting the program to work. 
If you are an experienced user, you’ll find that Classroom in a Book teaches 
many advanced features, including tips and techniques for using the latest 
version of Dreamweaver.

Although each lesson includes step-by-step instructions for creating a specific 
project, you’ll have room for exploration and experimentation. You can follow 
the book from start to finish or complete only those lessons that correspond to 
your interests and needs. Each lesson concludes with a review section contain-
ing questions and answers on the subjects you’ve covered.

TinyURLs
At several points in the book, I reference external information available on the 
Internet. The uniform resource locators (URLs) for this information are often 
long and unwieldy, so I have provided custom TinyURLs in many places for 
your convenience. Unfortunately, the TinyURLs sometimes expire over time 
and no longer function. If you find that a TinyURL doesn’t work, look up the 
actual URL provided in the appendix.

GETTING STARTED



2  Getting Started

Prerequisites
Before using Adobe Dreamweaver CC Classroom in a Book (2019 release), you 
should have a working knowledge of your computer and its operating system.  
Be sure you know how to use the mouse, standard menus, and commands, as 
well as how to open, save, and close files. If you need to review these techniques, 
see the printed or online documentation included with your Windows or macOS 
operating system.

Conventions used in this book
Working in Dreamweaver means you’ll be working with code. We have used several 
conventions in the following lessons and exercises to make working with the code 
in this book easier to follow and understand.

Bolded text
Certain names, words, and phrases will be bolded from time to time, usually when 
first cited in an instruction. This styling will include text, other than HTML or CSS 
code, that needs to be entered into program dialogs or into the body of a webpage, 
like this:

Type Insert main heading here

Filenames, like mygreen-styles.css, will also be bolded as needed to identify 
crucial resources or targets of a specific step or exercise. Be aware that these same 
names may not be bolded in introductory descriptions or general discussion. Be 
sure to identify all resources required in a specific exercise prior to commencing it.

Code font
In many instructions, you will be required to enter HTML code, CSS rules and 
properties, and other code-based markup. To distinguish the markup from the 
instructional text, the entries will be styled with a code font, like this:

Examine the following code: <h1>Heading goes here</h1>

In instances where you must enter the markup yourself, the entry will be formatted 
in color, like this:

Insert the following code: <h1>Heading goes here</h1>

Enter the code exactly as depicted, being careful to include all punctuation marks 
and special characters.
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Strikethrough
In several exercises, you will be instructed to delete markup that already exists 
within the webpage or style sheet. In those instances, the targeted references will be 
identified with strikethrough formatting, like this:

Delete the following values:

margin: 10px 20px 10px 20px;
background-image: url(images/fern.png), url(images/stripe.png);

Be careful to delete only the identified markup so that you achieve the following 
result:

margin: 10px 10px;
background-image: url(images/fern.png);

In most cases, white space differences will not affect the resulting display or opera-
tion of the code, but you should always attempt to match the depicted code exactly.

Missing punctuation
HTML code, CSS markup, and JavaScript often require the use of various punctua-
tion, such as periods (.), commas (,), and semicolons (;), and can be damaged by 
their incorrect usage or placement. Consequently, I have omitted periods and other 
punctuation expected in a sentence or paragraph from an instruction or hyper-
link whenever it may cause confusion or a possible error, as in the following two 
instructions:

Enter the following code: <h1>Heading goes here</h1>

Type the following link: https://adobe.com

Element references
Within the body of descriptions and exercise instructions, elements may be refer-
enced by name or by class or id attribute. When an element is identified by its tag 
name, it will appear as <section> or section. When referenced by its class attri-
bute, the name will appear with a leading period (.) in a code-like font, like this: 
.content or .sidebar1. References to elements by their id attribute will appear 
with a leading hash (#) and in a code font, like this: #top. This practice matches the 
way these elements appear in Dreamweaver’s tag selector interface.

Windows vs. macOS instructions
In most cases, Dreamweaver performs identically in both Windows and macOS. 
Minor differences exist between the two systems, mostly because of platform-
specific issues out of the control of the program. Most of these are simply 

https://adobe.com
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differences in keyboard shortcuts, how dialogs are displayed, and how buttons 
are named. In most cases, screen shots were made in the macOS version of 
Dreamweaver and may appear different from your own screen.

Where specific commands differ, they are noted within the text. Windows com-
mands are listed first, followed by the macOS equivalent, such as Ctrl+C/Cmd+C. 
Common abbreviations are used for all commands whenever possible, as follows:

Windows	 macOS
Control = Ctrl	 Command = Cmd
Alternate = Alt	 Option = Opt

As lessons proceed, instructions may be truncated or shortened to save space, with 
the assumption that you picked up the essential concepts earlier in the lesson. For 
example, at the beginning of a lesson you may be instructed to select Edit > Copy 
or “press Ctrl+C/Cmd+C.” Later, you may be told to “copy” text or a code element. 
These should be considered identical instructions.

If you find you have difficulties in any particular task, review earlier steps or 
exercises in that lesson. In some cases, if an exercise is based on concepts covered 
earlier you will be referred to the specific lesson.

Installing the program
Before you perform any exercises in this book, verify that your computer system 
meets the hardware requirements for Dreamweaver, that it’s correctly configured, 
and that all required software is installed.
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If you do not have Dreamweaver, you will first have to install it from Creative 
Cloud. Adobe Dreamweaver must be purchased separately; it is not included with 
the lesson files that accompany this book. Go to helpx.adobe.com/dreamweaver/
system-requirements.html to obtain the system requirements.

Go to www.adobe.com/creativecloud/plans.html to sign up for Adobe Creative 
Cloud. Dreamweaver may be purchased with the entire Creative Cloud family or as 
a standalone app. Adobe also allows you to try Creative Cloud and the individual 
applications for seven days for free.

Check out www.adobe.com/products/dreamweaver.html to learn more about the 
different options for obtaining Dreamweaver.

Updating Dreamweaver to the latest version
Although Dreamweaver is downloaded and installed on your computer hard drive, 
periodic updates are provided via Creative Cloud. Some updates provide bug fixes 
and security patches, while others supply amazing new features and capabilities.

The lessons in this book are based on Dreamweaver CC (2019 release) and may 
not work properly in earlier versions of the program. To check which version is 
installed on your computer, choose Help > About Dreamweaver in Windows or 
Dreamweaver > About Dreamweaver on macOS. A window will display the version 
number of the application and other pertinent information.

If you have an earlier version of the program installed, you will have to update 
Dreamweaver to the latest version. You can check the status of your installation by 
opening the Creative Cloud manager and logging in to your account.

http://helpx.adobe.com/dreamweaver/system-requirements.html
http://helpx.adobe.com/dreamweaver/system-requirements.html
http://www.adobe.com/creativecloud/plans.html
http://www.adobe.com/products/dreamweaver.html
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Windows	 macOS

Check out helpx.adobe.com/creative-cloud/help/download-install-trial.html to 
learn how to download and install a limited-period trial of Creative Cloud to your 
computer or laptop.

Online content
Your purchase of this Classroom in a Book includes online materials provided by 
way of your Account page on peachpit.com.

Lesson files
To work through the projects in this book, you will need to download the lesson 
files from peachpit.com. You can download the files for individual lessons, or it may 
be possible to download them all in a single file.

Web Edition
The Web Edition is an online interactive version of the book providing an enhanced 
learning experience. Your Web Edition can be accessed from any device with a con-
nection to the Internet; it contains the following:

•	 The complete text of the book

•	 Hours of instructional video keyed to the text

•	 Interactive quizzes

In addition, the Web Edition may be updated when Adobe adds significant feature 
updates between major Creative Cloud releases. To accommodate the changes, 
sections of the online book may be updated or new sections may be added.

Accessing the lesson files and Web Edition

If you purchased an ebook from peachpit.com or adobepress.com, your Web 
Edition will automatically appear under the Digital Purchases tab on your Account 
page. Click the Launch link to access the product. Continue reading to learn how to 
register your product to get access to the lesson files.

	Warning:  Do not 
copy one lesson folder 
into any other lesson 
folder. The files and 
folders for each les-
son cannot be used 
interchangeably.

http://helpx.adobe.com/creative-cloud/help/download-install-trial.html
http://peachpit.com
http://peachpit.com
http://peachpit.com
http://adobepress.com
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If you purchased an ebook from a different vendor or you bought a print book, you 
must register your purchase on peachpit.com to access the online content:

1	 Go to www.peachpit.com/register.

2	 Sign in or create a new account.

3	 Enter the ISBN: 9780135262146.

4	 Answer the questions as proof of purchase.

5	 The Web Edition will appear on the Digital Purchases tab on your Account page. 
Click the Launch link to access the product.

The lesson files can be accessed through the Registered Products tab on your 
Account page. Click the Access Bonus Content link below the title of your prod-
uct to proceed to the download page. Click the lesson file links to download 
them to your computer.

The files are compressed into ZIP archives to speed up download time and to 
protect the contents from damage during transfer. You must uncompress (or 
“unzip”) the files to restore them to their original size and format before you use 
them with the book. Modern Mac and Windows systems are set up to open ZIP 
archives by simply double-clicking.

6	 Do one of the following:

•	 If you downloaded DWCC2019_lesson_files.zip, unzipping the archive will 
produce a folder named DWCC2019_Lesson_Files containing all the lesson 
files used by the book.

•	 If you downloaded the lessons individually, create a new folder on your 
hard drive and name it DWCC2019. Unzip the individual lesson files to this 
folder. That way, all the lesson files will be stored in one location. Do not 
share or copy files between lessons.

P	Note:  Windows may 
treat Zip archives like a 
file folder, allowing you 
to access the contents 
without decompressing 
it first. To use the files 
in Dreamweaver, you 
must decompress each 
archive first.

P	Note:  The files are 
updated from time 
to time, so the dates 
depicted in screen shots 
may be different from 
the ones shown.

http://peachpit.com
http://www.peachpit.com/register
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Recommended lesson order
The training in this book is designed to take you from A to Z in basic to inter
mediate website design, development, and production. Each new lesson builds on 
previous exercises, using supplied files and assets to create an entire website. We 
recommend you download all lesson files at once.

Start with Lesson 1 and proceed through the entire book to Lesson 12. Continue 
with the online Lessons 13 through 16 (refer to the “Bonus material” section for 
more information about the online material).

I recommend that you do not skip any lessons, or even individual exercises. 
Although ideal, this method may not be a practicable scenario for every user. So 
each lesson folder contains all the files needed to complete every exercise within 
it using partially completed or staged assets, allowing you to complete individual 
lessons out of order, if desired.

However, don’t assume that the staged files and customized templates in each 
lesson represent a complete set of assets. It may seem that these folders contain 
duplicative materials, but these “duplicate” files and assets, in most cases, cannot be 
used interchangeably in other lessons and exercises. Doing so will probably cause 
you to fail to achieve the goal or desired results of the exercise.

For that reason, you should treat each folder as a standalone website. Copy the 
lesson folder to your hard drive, and create a new site for that lesson using the Site 
Setup dialog. Do not define sites using subfolders of existing sites. Keep your sites 
and assets in their original folders to avoid conflicts.

One suggestion is to organize the lesson folders in a single web or sites master 
folder near the root of your hard drive. But avoid using the Dreamweaver appli-
cation folder. In most cases, you’ll want to use a local web server as your testing 
server, which is described in Lesson 11, “Publishing to the Web.”

Bonus material
We’ve provided additional material for Lessons 2, 3, and 4 on the Peachpit website. 
This book has so much great material that we couldn’t fit it all in the printed pages, 
so we placed Lessons 14 through 16 on the Peachpit website as well:

Lesson 2, “HTML Basics Bonus”

Lesson 3, “CSS Basics Bonus”

Lesson 4, “Creating Web Assets Using Photoshop Generator Bonus”
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Lesson 14, “Working with a Web Framework”

Lesson 15, “Adapting Content to Responsive Design”

Lesson 16, “Working with Web Animation and Video”

You will find these on your account page (Lessons & Update Files tab) once you 
register your book, as described earlier in “Accessing the lesson files and Web 
Edition.”

On first launch
Right after installation or upon first launch, Dreamweaver CC will display several 
introduction screens. First, the Sync Settings dialog will appear. If you are a user of 
previous versions of Dreamweaver, select Import Sync Settings to download your 
existing program preferences. If this is the first time you’ve used Dreamweaver, select 
Upload Sync Settings to sync your preferences to your Creative Cloud account.

In the book, I use the lightest interface themes for the screen shots. This was done 
both to save ink in printing and to place less stress on the environment. Feel free to 
pick the color themes you prefer.

Choosing the program color theme
If you purchased the book after you installed and launched Dreamweaver, you may 
be using a different color theme than the one pictured in most screen shots in the 
book. All exercises will function properly using any color theme, but if you want to 
configure your interface to match the one shown, complete the following steps.

1	 Select Edit > Preferences in Windows or Dreamweaver CC > Preferences in 
macOS. The Preferences dialog appears.

2	 Select the Interface category.



10  Getting Started

3	 Select the lightest App Theme color.  
Select Solarized Light from the Code Theme menu.

The interface changes to the new theme. Depending on which app theme you 
select, the code theme may change automatically. The changes are not perma-
nent yet. If you close the dialog, the theme will revert to the original colors.

4	 Click the Apply button.

The theme changes are now permanent.

5	 Click the Close button.

Feel free to change the color theme at any time. Often users select the theme that 
works best in their normal working environment. The lighter themes work best in 
well-lighted rooms, while the darker themes work best in indirect or controlled 
lighting environments used in some design offices. All exercises will work properly 
in any theme color.

Setting up the workspace
Dreamweaver CC (2019 release) includes two main workspaces to accommodate 
various computer configurations and individual workflows. For this book, the 
Standard workspace is recommended.

1	 If the Standard workspace is not displayed by default, you can select it from the 
Window > Workspace menu.
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2	 If the default Standard workspace has been modified—where certain toolbars 
and panels are not visible (as they appear in the figures in the book)—you can 
restore the factory settings by choosing Reset ‘Standard’ from the Workspace 
drop-down menu.

These same options can be accessed from the Window > Workspace Layout menu.

Most of the figures in this book show the Standard workspace. When you finish 
the lessons in this book, experiment with each workspace to find the one that you 
prefer, or build your own configuration and save the layout under a custom name.

For a more complete description of the Dreamweaver workspaces, see Lesson 1, 
“Customizing Your Workspace.”

Defining a Dreamweaver site
In the course of completing the following lessons, you will create webpages from 
scratch and use existing files and resources that are stored on your hard drive. The 
resulting webpages and assets make up what’s called your local site. When you are 
ready to upload your site to the Internet (see Lesson 11, “Publishing to the Web”), 
you publish your completed files to a web-host server, which then becomes your 
remote site. The folder structures and files of the local and remote sites are usually 
mirror images of one another.

The first step is to define your local site.

	Warning:  You must unzip the lesson files before you create your site definition.
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1	 Launch Adobe Dreamweaver CC (2019 release) or later.

2	 Open the Site menu.

The Site menu provides options for creating and managing standard 
Dreamweaver sites.

3	 Choose New Site.

The Site Setup dialog appears.

To create a standard website in Dreamweaver, you need only name it and select 
the local site folder. The site name should relate to a specific project or client 
and will appear in the Files panel Site drop-down menu. This name is intended 
for your own purposes only; it will not be seen by the public, so there are no 
limitations to the name you can create. Use a name that clearly describes the 
purpose of the website. For the purposes of this book, use the name of the les-
son you intend to complete, such as lesson01, lesson02, lesson03, and so on.

4	 Type lesson01 or another name, as appropriate, in the Site Name field.

P	Note:  The main 
folder that contains the 
site will be referred to 
throughout the book as 
the site root folder.
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5	 Next to the Local Site Folder field, click the Browse For Folder icon.

6	 Navigate to the appropriate folder containing the lesson files you downloaded 
from peachpit.com (as described earlier), and click Select/Choose.

You could click Save at this time and begin working on your new website, but 
you’ll add one more piece of handy information.

7	 Click the arrow next to the Advanced Settings category to reveal the categories 
listed there. Select Local Info.

Although it’s not required, a good policy for site management is to store differ-
ent file types in separate folders. For example, many websites provide indi-
vidual folders for images, PDFs, videos, and so on. Dreamweaver assists in this 
endeavor by including an option for a default images folder.

Later, as you insert images from other locations on your computer, Dream-
weaver will use this setting to automatically move the images into the site 
structure.

P	Note:  Lesson files 
must be decompressed 
prior to defining 
the site.

P	Note:  The folder 
that contains the image 
assets will be referred to 
throughout the book as 
the site default images 
folder or the default 
images folder.

http://peachpit.com
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8	 Next to the Default Images Folder field, click the Browse For Folder icon. When 
the dialog opens, navigate to the appropriate images folder for that lesson or site 
and click Select/Choose.

The path to the images folder appears in the Default Images Folder field. The 
next step would be to enter your site domain name in the Web URL field.

9	 Enter http://green-start.org for the lessons in this book, or enter your own 
website URL, in the Web URL field.

You’ve entered all the information required to begin your new site. In subse-
quent lessons, you’ll add information that will enable you to upload files to your 
remote and testing servers.

10	 In the Site Setup dialog, click Save.

The Site Setup dialog closes.

Whenever a site is selected or modified, Dreamweaver will build, or rebuild, 
a cache of every file in the folder. The cache identifies relationships between 
the webpages and the assets within sites and will assist you whenever a file is 
moved, renamed, or deleted to update links or other referenced information.

P	Note:  Resource fold-
ers for images and other 
assets should always be 
contained within the 
main site root folder.

P	Note:  The Web URL 
is not needed for most 
static HTML sites, but 
it’s required for work-
ing with sites using 
dynamic applications or 
to connect to databases 
and a testing server.

http://green-start.org
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11	Click OK to build the cache, if necessary.

In the Files panel, the new site name appears in the site list drop-down menu. As 
you add more site definitions, you can switch between the sites by selecting the 
appropriate name from this menu.

Setting up a site is a crucial first step in beginning any project in Dreamweaver. 
Knowing where the site root folder is located helps Dreamweaver determine link 
pathways and enables many sitewide options, such as orphaned-file checking and 
Find and Replace.

Checking for updates
Adobe periodically provides software updates. To check for updates in the pro-
gram, choose Help > Updates in Dreamweaver. An update notice may also appear 
in the Creative Cloud update desktop manager.

For book updates and bonus material, visit your Account page on peachpit.com 
and select the Lesson & Update Files tab.

http://peachpit.com
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Additional resources
Adobe Dreamweaver CC Classroom in a Book (2019 release) is not meant to replace 
documentation that comes with the program or to be a comprehensive reference 
for every feature. Only the commands and options used in the lessons are explained 
in this book. For comprehensive information about program features and tutorials, 
refer to these resources:

Adobe Dreamweaver Learn & Support: https://helpx.adobe.com/dreamweaver/
tutorials.html (accessible in Dreamweaver by choosing Help > Dreamweaver 
Tutorial) is where you can find and browse tutorials, help, and support on 
Adobe.com.

Dreamweaver Help: helpx.adobe.com/support/dreamweaver.html is a refer-
ence for application features, commands, and tools (press F1 or choose Help > 
Dreamweaver Help).

Adobe Forums: forums.adobe.com lets you tap into peer-to-peer discussions and 
questions and answers on Adobe products.

Resources for educators: adobe.com/education and edex.adobe.com offer a 
treasure trove of information for instructors who teach classes on Adobe software. 
You’ll find solutions for education at all levels, including free curricula that use an 
integrated approach to teaching Adobe software and that can be used to prepare 
for the Adobe Certified Associate exams.

Also check out these useful links:

Adobe Add-ons: exchange.adobe.com/addons is a central resource for finding 
tools, services, extensions, code samples, and more to supplement and extend  
your Adobe products.

Adobe Dreamweaver CC product home page: adobe.com/products/ 
dreamweaver.html has more information about the product.

Adobe Authorized Training Centers
Adobe Authorized Training Centers offer instructor-led courses and training on 
Adobe products. Go to training.adobe.com/training/partner-finder.html to find a 
directory of AATCs.

https://helpx.adobe.com/dreamweaver/tutorials.html
https://helpx.adobe.com/dreamweaver/tutorials.html
http://Adobe.com
http://helpx.adobe.com/support/dreamweaver.html
http://forums.adobe.com
http://adobe.com/education
http://edex.adobe.com
http://exchange.adobe.com/addons
http://adobe.com/products/
http://dreamweaver.html
http://training.adobe.com/training/partner-finder.html
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CUSTOMIZING YOUR 
WORKSPACE

Lesson overview
In this lesson, you’ll familiarize yourself with the Dreamweaver CC 
(2019 release) program interface and learn how to do the following:

•	 Use the program Welcome screen

•	 Switch document views

•	 Work with panels

•	 Select a workspace layout

•	 Adjust toolbars

•	 Personalize preferences

•	 Create custom keyboard shortcuts

•	 Use the Property inspector

•	 Use the Extract workflow

This lesson will take about 1 hour to complete. Please log in to your 
account on peachpit.com to download the files for this lesson, or go to 
the “Getting Started” section at the beginning of this book and follow the 
instructions under “Accessing the Lesson Files and Web Edition.” Store 
the files on your computer in a convenient location. Define a site based on 
the lesson01 folder.

Your Account page is also where you’ll find any updates to the lesson 
files. Look on the Lesson & Update Files tab to access the most current 
content.

1

http://peachpit.com
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You’d probably need a dozen programs to perform 
all the tasks that Dreamweaver can do—and none of 
them would be as fun to use.
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Touring the workspace
Dreamweaver is the industry-leading Hypertext Markup Language (HTML) editor, 
with good reasons for its popularity. The program offers an incredible array of 
design and code-editing tools. Dreamweaver offers something for everyone.

Coders love the range of enhancements built into the Code view environment, and 
developers enjoy the program’s support for a variety of programming languages 
and code hinting. Designers marvel at seeing their text and graphics appear in an 
accurate What You See Is What You Get (WYSIWYG) depiction as they work, 
saving hours of time previewing their designs in browsers. Novices certainly appre-
ciate the program’s simple-to-use and power-packed interface. No matter what 
type of user you are, if you use Dreamweaver, you don’t have to compromise.

P	Note:  Before you 
begin this lesson, down-
load the lesson files and 
create a new website for 
lesson01 as described 
in the “Getting Started” 
section at the begin-
ning of the book.

A	 Menu bar

B	 Document tab

C	 Related files interface

D	 Common toolbar 

E	 New Features

F	 Document toolbar 

G	 Visual Media Query 
(VMQ) interface

H	 Live/Design views

I	 Files panel 

J	 Workspace menu

K	 CSS Designer 

L	 Scrubber 

M	 CC Libraries panel 

N	 Insert panel

O	 DOM panel

P	 Assets panel 

Q	 Behaviors panel 

R	 Code view

S	 Tag selectors

T	 Property inspector

The Dreamweaver interface features a vast array of user-configurable panels and toolbars. Take a 
moment to familiarize yourself with the names of these components.
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You’d think a program with this much to offer would be dense, slow, and unwieldy, 
but you’d be wrong. Dreamweaver provides much of its power via dockable panels 
and toolbars that you can display or hide and arrange in innumerable combinations 
to create your ideal workspace. In most cases, if you don’t see a desired tool or 
panel, you’ll find it in the Window menu.

This lesson introduces you to the Dreamweaver interface and gets you in touch 
with some of the power hiding under the hood. We don’t spend a lot of time in the 
upcoming lessons teaching you how to perform basic activities within the interface; 
that’s the intention of this lesson. So take some time to go through the following 
descriptions and exercises to familiarize yourself with the basic operations of the 
program interface. Feel free to refer to this lesson anytime you need a refresher on 
the program’s many dialogs and panels and how they function.

Using the Start Screen
Once the program is installed and the initial setup is completed, you’ll see the new 
Dreamweaver Start Screen. This screen provides quick access to recent pages, easy 
creation of a variety of page types, and a direct connection to several key Help 
resources. The Start Screen appears when you first start the program or when no 
other documents are open. The Start Screen has gotten a facelift in this version of 
Dreamweaver and deserves a quick review to check out what it offers. For example, 
it now has two main options: Quick Start and Starter Templates and two buttons 
for creating new files and opening existing ones. If you have never used the pro-
gram before the center of the Start Screen may prompt you “Build a Website.”
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Once you create or open your first file, Dreamweaver will provide a list of the files 
you last worked on. The list is dynamic, and the last file you worked on will be at 
the top of the list. To reopen a file, simply click its name.

Quick Start
If the Quick Start tab looks familiar, it’s because it has been around in one form 
or another for many versions of Dreamweaver. As it has always done, it provides 
instant access to a list of basic web-compatible file types, such as HTML, CSS, JS, 
PHP, and so on. Just click the file type to start a new document.
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Starter Templates
The Starter Templates option enables you to access predefined starter templates 
that provide responsive styling to support smartphones and mobile devices, as well 
as the popular Bootstrap framework. The templates can be used to quickly create 
from scratch a variety of webpages that are already compatible with smartphones 
and tablets. 

Create New and Open
The Create New and Open buttons access the New Document and Open dialogs, 
respectively. Previous users of Dreamweaver may be more comfortable using these 
options, which open familiar interfaces for creating new documents or opening 
existing ones.
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If you do not want to see the Start Screen anymore, you can disable it by access-
ing the option in General settings in Dreamweaver Preferences and deselecting the 
checkbox.

Exploring New Feature guides
In Dreamweaver CC, the New Feature guides pop up from time to time as you 
access various tools, features, or interface options. The pop-ups call your attention 
to new features or workflows that have been added to the program and provide 
handy tips to help you get the most out of them.

When a tip appears, it may provide more extensive information or a tutorial you 
can access by following the prompts in the pop-up window. When you are finished, 
you can close the pop-up by clicking the Close icon in the upper-right corner of 
each tip. When you close the tip, it will not appear again. You can display the tips 
again by selecting Help > Reset Contextual Feature Tips.
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Setting interface preferences
Dreamweaver provides users with extensive controls over the basic program inter-
face. You can set up, arrange, and customize the various panels and menus to your 
own liking. One of the first places you should visit before you begin the lessons in 
this book is the Dreamweaver Preferences dialog.

As with other Adobe applications, the Preferences dialog provides specific settings 
and specifications that dictate how the program looks and functions. Preference 
settings are normally persistent, meaning that they remain in effect even after the 
program is shut down and relaunched. There are far too many options in this dialog 
to cover in one lesson, but let’s make a couple of changes to give you a taste of what 
you can do. Some features of the program are not visible until you create or open a 
file for editing.

1	 Define a new site based on the lesson01 folder as described in the “Getting 
Started” section at the beginning of the book.

2	 Select Window > Files or press F8 to display the Files panel.

3	 In the File panel, select lesson01 from the drop-down menu and reveal the site 
file list in the panel, if necessary.

4	 Right-click the file index.html from the lesson01 folder and choose Open from 
the context menu. You can also double-click a file in the list to open it.

http://index.html
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The file opens in the document window. If the program has not been used 
previously, the file may open in Live view. To get the full appreciation of the 
upcoming changes, let’s also display the code-editing interface at the same time.

5	 Select Split view at the top of the document window, if necessary.

If you did not complete the “Getting Started” section at the beginning of the 
book, you will see that Dreamweaver is sporting a new dark color scheme in Code 
view. Some users love it; some hate it. You can change it completely or merely 
tweak it in Preferences. If you have already changed your interface theme, skip to 
the next exercise.

6	 In Windows, select Edit > Preferences.  
In macOS, select Dreamweaver CC > Preferences.

The Preferences dialog appears.

7	 Select the Interface category.

As you see in the dialog, Dreamweaver gives you control over the overall color 
theme as well as the code-editing window. You may change one or both.

Many designers work in controlled lighting environments and prefer the dark 
interface themes that are now the default in most Adobe applications. For the 
purposes of this book, all screen shots from this point forward are taken in the 
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lightest theme. This saves ink during printing, for less impact on the environ-
ment. You may continue to use the dark theme if you prefer, or switch now so 
that your screen will match the illustrations in the book.

8	 In the App Theme window, select the lightest theme.

The theme of the entire interface changes to light gray. You will notice that the 
Code Theme setting changes to Light at the same time. If you prefer, you can 
switch the code theme back to Dark or choose another. The screen shots for 
code editing in the book use the Solarized Light theme.

9	 Select Solarized Light in the Code Theme window.

At the moment, the changes are not permanent. If you click the Close button in 
the dialog, the theme would revert to dark.

10	Click Apply in the lower-right corner of the dialog.

The changes have now been applied permanently.

11	Click Close.

Saved preferences persist from session to session and through each workspace.

Switching and splitting views
Dreamweaver offers dedicated environments for coders and designers.

Code view
Code view focuses the Dreamweaver workspace exclusively on the HTML code and 
a variety of code-editing productivity tools. To access Code view, click the Code 
view button in the Document toolbar.
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Code view

Design view
Design view shares the document window with Live view and focuses the 
Dreamweaver workspace on its classic WYSIWYG editor. In the past, Design view 
provided a reasonable facsimile of the webpage as it would appear in a browser, but 
with the advancements in CSS and HTML, it is no longer as WYSIWYG as it once 
was. Although it can be difficult to use in some situations, you’ll find that it does 
offer an interface that speeds up the creation and editing of your content. And at 
the moment, it’s also the only way to access certain Dreamweaver tools or work-
flows, as you will see in the upcoming lessons.

To activate Design view, choose it from the Design/Live view drop-down menu 
in the Document toolbar. Most HTML elements and basic cascading style sheets 
(CSS) formatting will be rendered properly within Design view, with the major 
exceptions being CSS3 properties; dynamic content; interactivity, such as link 
behaviors, video, audio, and jQuery widgets; and some form elements. In previous 
versions of Dreamweaver, you spent most of your time in Design view. That will no 
longer be the case.

Design view
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Live view
Live view is the default workspace of Dreamweaver CC. It speeds up the process of 
developing modern websites by allowing you to visually create and edit webpages 
and web content in a browser-like environment, and it supports and previews most 
dynamic effects and interactivity.

To use Live view, choose it from the Design/Live view drop-down menu in the 
Document toolbar. When Live view is activated, most HTML content will function 
as it would in an actual browser, allowing you to preview and test most dynamic 
applications and behaviors.

In previous versions of Dreamweaver, the content in Live view was not editable. 
That has changed. You can edit text, add and delete elements, create classes and 
IDs, and even style elements, all in the same window. It’s like working on a live 
webpage right inside Dreamweaver.

Live view is integrally connected to the CSS Designer, allowing you to create and 
edit advanced CSS styling and build fully responsive webpages without having to 
switch views or waste time previewing the page in a browser.

Live view

Split view
Split view provides a composite workspace that gives you access to both the design 
and the code simultaneously. Changes made in either window update in the other 
in real time.

P	Note:  Split view can 
pair Code view with 
either Design view or 
Live view.
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To access Split view, click the Split view button in the Document toolbar. Dream-
weaver splits the workspace horizontally by default. When using Split view, you can 
display Code view with either Live view or Design view.

Split view (horizontal)

You can split the screen vertically by selecting the Split Vertically option on the 
View menu. When the window is split, Dreamweaver also gives you options for 
how the two windows display. You can put the code window on the top, bottom, 
left, or right. You can find all these options in the View menu. Most screen shots in 
the book that show Split view show Design or Live view at top or right.

Split view (vertical)
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Live Source Code
Live Source Code is an HTML code-troubleshooting display mode available when-
ever Live view is activated. To access Live Source Code, activate Live view and then 
click the Live Source Code icon  in the toolbox at the left side of the document 
window. While active, Live Source Code displays the HTML code as it would 
appear in a live browser on the Internet and gives you a peek at how the code 
changes when the visitor interacts with various parts of the page.

You can see this interaction firsthand by clicking the Green Events menu item to 
open the drop-down menu. In Code view, you will see that the menu item starts 
with the class dropdown and that the class open is then added to the code inter-
actively. The open class is then removed when you close the menu. Without Live 
Source Code, you would not be able to see this interaction and behavior.

Live Source Code mode

Be aware that while Live Source Code is active, you will not be able to edit the 
HTML code, although you can still modify external files, such as linked style 
sheets. To disable Live Source Code, click the Live Source Code icon again to toggle 
the mode off.

Inspect mode
Inspect mode is a CSS troubleshooting display mode that is available whenever 
Live view is activated. It is integrated with the CSS Designer and allows you to 
rapidly identify CSS styles applied to content within the page by moving the mouse 
cursor over elements in the webpage. Clicking an element freezes the focus on 
that item.

P	Note:  The Live 
Source Code icon may 
not appear on the 
Common toolbar by 
default. You may need 
to activate it using the 
Customize Toolbar icon.
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The Live view window highlights the targeted element and displays the pertinent 
CSS rules applied or inherited by that element. You can access Inspect mode at any 
time by clicking the Live view icon whenever an HTML file is open and then click-
ing the Inspect icon in the Common toolbar.

Inspect mode

Selecting a workspace layout
A quick way to customize the program environment is to use one of the prebuilt 
workspaces in Dreamweaver. Experts have optimized these workspaces to put the 
tools you need at your fingertips.

Dreamweaver CC (2019 release) includes two prebuilt workspaces: Standard and 
Developer. To access these workspaces, choose them from the Workspace menu, 
located at the upper-right side of the program window.

Standard workspace
The Standard workspace focuses the available screen real estate on the Design and 
Live view window. Standard is the default workspace for screen shots in this book.

Standard workspace
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Developer workspace
The Developer workspace provides a code-centric layout of tools and panels ideal 
for coders and programmers. The workspace is focused on Code view.

Developer workspace

Working with panels
Although you can access most commands from the menus, Dreamweaver scatters 
much of its power in user-selectable panels and toolbars. You can display, hide, 
arrange, and dock panels at will around the screen. You can even move them to a 
second or third computer display if you desire.

Standard panel grouping

The Window menu lists all the panels available in the program. If you do not see 
a desired panel on the screen, choose it from the Window menu. A check mark 
appears next to its name in the menu to indicate that the panel is open and visible. 
Occasionally, one panel may lie behind another on the screen and be difficult to 
locate. In such situations, simply choose the desired panel from the Window menu 
and the panel will rise to the top of the stack.
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Minimizing panels
To create room for other panels or to access obscured areas of the workspace, 
you can minimize or expand individual panels in place. To minimize a standalone 
panel, double-click the tab containing the panel name. To expand the panel, click 
the tab once.

To recover more screen real estate, you can minimize panel groups or stacks down 
to icons by double-clicking the title bar. You can also minimize the panels to icons 
by clicking the double-arrow icon in the panel title bar. When panels are minimized 
to icons, you access an individual panel by clicking its icon. The selected panel will 
appear on the left or right of the icon, wherever room permits.

Minimizing a panel by 
double-clicking its tab

Minimizing one panel in 
a stack using its tab

Collapsing a panel  
to icons
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Closing panels and panel groups
Each panel or panel group may be closed at any time. You can close a panel or 
panel group in several ways; the method often depends on whether the panel is 
floating, docked, or grouped with another panel.

To close an individual panel that is docked, right-click in the panel tab and choose 
Close from the context menu. To close an entire group of panels, right-click any tab 
in the group and choose Close Tab Group.

To close a floating panel or panel group, click the Close  icon that appears in 
the upper-right corner of the panel in Windows or in the left corner of the title bar 
of the panel or panel group in macOS. To reopen a panel, choose the panel name 
from the Window menu. Reopened panels will sometimes appear floating in the 
interface. You may use them this way or attach, or dock, them to the sides, top, or 
bottom of the interface. You will learn how to dock panels later.

Dragging
You can reorder a panel tab by dragging it to the desired position within the group.

Dragging a tab to change its position
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Floating
A panel that is grouped with other panels can be floated separately. To float a panel, 
drag it from the group by its tab.

Pulling a panel out by its tab

To reposition panels, groups, and stacks in the workspace, simply drag them by the 
title bar. To pull out a single panel group when it’s docked, grab it by the tab bar.

Dragging a whole docked panel group to a new position

Grouping, stacking, and docking
You can create custom groups by dragging one panel into another. When you’ve 
moved the panel to the correct position, Dreamweaver highlights the area, called 
the drop zone, in blue. Release the mouse button to create the new group.

Creating new groups
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In some cases, you may want to keep both panels visible simultaneously. To stack 
panels, drag the desired tab to the top or bottom of another panel. When you see 
the blue drop zone appear, release the mouse button.

Creating panel stacks

Floating panels can be docked to the right, left, or bottom of the Dreamweaver 
workspace. To dock a panel, group, or stack, drag its title bar to the edge of the 
window on which you wish to dock it. When you see the blue drop zone appear, 
release the mouse button.

Personalizing Dreamweaver
As you continue to work with Dreamweaver, you’ll devise your own optimal work-
space of panels and toolbars for each activity. You can store these configurations in 
a custom workspace of your own naming.

Docking panels
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Saving a custom workspace
To save a custom workspace, create your desired configuration of panels, choose 
New Workspace from the Workspace menu, and then give it a custom name.

Working with Extract
Extract is a newer workflow that allows you to create CSS styles and image assets 
from a Photoshop-based mockup. You can create your webpage design using text 
and linked or embedded image layers and post the file to Creative Cloud, where 
Dreamweaver can access the styles, colors, and images to help you build your basic 
site design.

Saving a custom 
workspace

Build your design in 
Photoshop using text, 
images, and effects 
stored in layers.

Post your file to your 
Creative Cloud online 
folder right inside 
Dreamweaver.
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Access the various layers from the Extract panel inside Dreamweaver, copy styles and text, and even 
download image assets.

Try these features yourself by uploading GreenStart_mockup.psd, in the 
lesson01 resources folder, to your Creative Cloud account online folder. Go to 
helpx.adobe.com/creative-cloud/help/sync-files.html to learn how to upload files to 
your Creative Cloud account. In Lesson 5, “Creating a Page Layout,” you will learn 
how to extract CSS styling and image assets from a Photoshop mockup to build a 
layout for your site template.

Working with toolbars
Some program features are so handy you may want them to be available all the time 
in toolbar form. Two of the toolbars—Document and Standard—appear horizon-
tally at the top of the document window. The Common toolbar, however, appears 
vertically on the left side of the screen. You can display the desired toolbar by 
choosing it from the Window menu.

Document toolbar
The document toolbar appears at the very top of the program interface and 
provides onscreen commands for switching views from Live, Design, Code, 
and Split views. You can enable this toolbar by selecting Window > Toolbars > 
Document when a document is open.

Standard toolbar
The Standard toolbar is an optional toolbar that appears between the Related Files 
interface and the document window and provides handy commands for various 
document and editing tasks, such as creating, saving, or opening documents; copy-
ing, cutting, and pasting content; and so on. You can enable this toolbar by select-
ing Window > Toolbars > Standard when a document is open.

Document toolbar

Standard toolbar

http://helpx.adobe.com/creative-cloud/help/sync-files.html
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Common toolbar
The Common toolbar appears on the left side of the program window and provides 
a variety of commands for working with code and HTML elements. The toolbar 
displays six tools by default in Live and Design view. But insert the cursor in the 
code window and you may see several more.

The Common toolbar was named the Coding toolbar in a previous version of 
Dreamweaver, and it is now user customizable. You can add and remove tools by 
selecting the Customize Toolbar icon. Be aware that some tools will be displayed 
and active only when using the Code view window.

Creating custom keyboard shortcuts
Another powerful feature of Dreamweaver is the ability to create your own key-
board shortcuts as well as edit existing ones. Keyboard shortcuts are loaded and 
preserved independently of workspaces.

Is there a command you can’t live without that doesn’t have a keyboard shortcut or 
uses one that’s inconvenient? Create one of your own.

1	 Choose Edit > Keyboard Shortcuts (Windows) or Dreamweaver CC > Keyboard 
Shortcuts (macOS).

You cannot modify the default shortcuts, so you have to create a list of 
your own.

P	 Note:  The default keyboard shortcuts are locked and cannot be edited. But you can dupli-
cate the set, save it under a new name, and modify any shortcut within that custom set.

2	 Click the Duplicate Set  icon to create a new set of shortcuts.

Common toolbar 
and dialog
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3	 Enter a name in the Name Of Duplicate Set field. Click OK.

4	 Choose Menu Commands from the Commands pop-up menu.

5	 In the Commands window, choose File > Save All.

Note that the Save All command does not have an existing shortcut, although 
you’ll use this command frequently in Dreamweaver.

6	 Insert the cursor in the Press Key field.  
Press Ctrl+Alt+S (Windows) or Cmd+Opt+S (macOS).

Note the error message indicating that the keyboard combination you chose is 
already assigned to a command. Although we could reassign the combination, 
let’s choose a different one.

7	 Press Ctrl+Alt+Shift+S (Windows) or Ctrl+Cmd+S (macOS).

This combination is not currently being used, so let’s assign it to the Save All 
command.
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8	 Click the Change button.

The new shortcut is now assigned to the Save All command.

9	 Click OK to save the change.

You have created your own keyboard shortcut—one you can use in upcoming 
lessons. Whenever an instruction in one of the lessons says “save all files,” use this 
keyboard shortcut.

Using the Property inspector
One tool vital to your workflow is the Property inspector. In the predefined Dream-
weaver workspaces, the Property inspector is no longer a default component. If it 
is not visible in your program interface, you can display it by selecting Window > 
Properties and then dock it to the bottom of the document window, as described 
earlier. The Property inspector is context-driven and adapts to the type of element 
you select.

Using the HTML tab
Insert the cursor into any text content on your page and the Property inspector 
provides a means to quickly assign some basic HTML codes and formatting. When 
the HTML button is selected, you can apply heading or paragraph tags as well as 
bold, italics, bullets, numbers, and indenting, among other formatting and attri-
butes. The Document Title metadata field is also available in the bottom half of 
the Property inspector. Enter your desired document title in this field, and Dream-
weaver adds it automatically to the document <head> section. If you don’t see the 
full Property inspector, click the triangle icon in the lower-right corner of the panel 
to expand its display.

HTML Property inspector
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Using the CSS tab
Click the CSS button to quickly access commands to assign or edit CSS formatting.

CSS Property inspector

Accessing image properties
Select an image in a webpage to access the image-based attributes and formatting 
controls of the Property inspector.

Image Property inspector

Accessing table properties
To access table properties, insert your cursor in a table and then click the table tag 
selector at the bottom of the document window.

Table Property inspector

Using the Related Files interface
Webpages are often built with multiple external files that provide styling and 
programming assistance. Dreamweaver enables you to see all the files linked to, 
or referenced by, the current document by displaying the filenames in the Related 
Files interface at the top of the document window. This interface displays the name 
of any external file and will actually display the contents of each file—if the contents 
are available—when you simply select the filename in the display.

The Related Files interface lists all external files linked to a document.
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To view the contents of the referenced file, click the name. Dreamweaver splits the 
document window and shows the contents of the selected file in the Code view 
window. If the file is stored locally, you’ll even be able to edit the contents of the file 
when it’s selected.

Use the Related Files interface to edit locally stored files linked to the webpage.

To view the HTML code contained within the main document, click the Source 
Code option in the interface.

Choose the Source Code option to see the contents of the main document.
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Using tag selectors
One of the most important features of Dreamweaver is the tag selector interface 
that appears at the bottom of the document window. This interface displays the 
tags and element structure in any HTML file pertinent to the insertion point of, 
or that is selected by, the cursor. The display of tags is hierarchical, starting at the 
document root at the left of the display and listing each tag or element in order 
based on the structure of the page and the selected element.

The tag selectors also enable you to select any of the elements displayed by simply 
clicking a tag. When a tag is selected, all the content and child elements contained 
within that tag are also selected.

Use the tag selectors to select elements.

The tag selector interface is closely integrated with the CSS Designer panel. You 
may use the tag selectors to help you style content or to cut, copy, paste, and delete 
elements.

The tag selector is closely integrated with the styling and editing of elements.

The display in the tag 
selector interface mim-
ics the structure of the 
HTML code based on 
your selection.
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Using the CSS Designer
The CSS Designer is a powerful tool for visually inspecting, creating, editing, and 
troubleshooting CSS styling. The panel adapts to the size of the available workspace 
and displays in either a one- or two-column layout. 

The CSS Designer can be displayed in one or two columns. Simply drag the edge of the document 
window to the left or right until the panel displays the desired number of columns.

CSS Designer allows you to copy and paste CSS styles from one rule to another. 
You can also decrease or increase the specificity of new selector names by pressing 
the up or down arrow keys, respectively.

Copy and paste styles from one rule to another (left). Make selectors more or less specific by using 
the arrow keys (right).

The CSS Designer panel consists of four windows: Sources, @Media, Selectors, and 
Properties.
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Sources
The Sources window allows you to create, attach, define, and remove internal 
embedded and external, linked style sheets.

@Media
The @Media window is used to define media queries to support various types of 
media and devices.

Selectors
The Selectors window is used to create and edit the CSS rules that format the com-
ponents and content of your page. Once a selector, or rule, is created, you define 
the formatting you wish to apply in the Properties window.
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In addition to allowing you to create and edit CSS styling, the CSS Designer can 
also be used to identify styles already defined and applied, and to troubleshoot 
issues or conflicts with these styles.

Properties
The Properties window features two basic modes. By default, the Properties 
window displays all available CSS properties in a list, organized in five catego-
ries: Layout, Text, Borders, Background, and More. You can scroll down the 
list and apply styling as desired or click the icon to jump to that category of the 
Properties panel.

P	Note:  Deselect the 
Show Set option to see 
all the CSS Designer 
categories.
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The second mode can be accessed by selecting Show Set at the upper-right edge 
of the window. In this mode, the Properties panel will filter the list down to 
only the properties actually applied to the rule chosen in the Selectors window. 
In either mode, you can add, edit, or remove style sheets, media queries, rules, 
and properties.

The Properties panel also features a COMPUTED option that displays the aggre-
gated list of styles applied to the selected element when the Current button in CSS 
Designer is selected. The COMPUTED option will then appear anytime you select 
an element or component on the page. When you’re creating any type of styling, the 
code created by Dreamweaver complies with industry standards and best practices.

Selecting the Show 
Set option limits the 
property display to only 
the properties that are 
styled.

The COMPUTED option 
collects in one place 
all styles applied to the 
selection.
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All and Current modes
The CSS Designer has two buttons at the top of the panel, All and Current, that 
enable specific functions and workflows within the panel.

When the All button is selected, the panel allows you to create and edit CSS style 
sheets, media queries, rules, and properties. When the Current button is selected, 
the CSS troubleshooting functions are enabled, allowing you to inspect individual 
elements in a webpage and assess existing styling properties applied to a selected 
element. In this mode, however, you will notice that some of the normal features 
in the CSS Designer are disabled. For example, when in Current mode you are 
able to edit existing properties and add new style sheets, media queries, and rules 
that apply to the selected element, but you cannot delete existing style sheets, 
media queries, or rules. This interaction works the same way in all document 
views modes.

When the Current button is selected, the CSS Designer displays all styling associated with a selected 
element.

In addition to using the CSS Designer, you may also create and edit CSS styling 
manually within Code view while taking advantage of many productivity enhance-
ments, such as code hinting and auto-completion.

Using the Visual Media Query (VMQ) interface
The Visual Media Query (VMQ) interface is a newer feature of Dreamweaver. 
Appearing above the document window, the VMQ interface allows you to visually 
inspect and interact with existing media queries, as well as create new ones on the 
fly using a simple point-and-click interface.

Open any webpage that is formatted by a style sheet with one or more media 
queries. If necessary, enable the VMQ interface by toggling the VMQ  icon. The 
VMQ interface will appear above the document window and display color-coded 
bars that specify the type of media query that has been defined. Media queries 
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using only a max-width specification will be displayed in green. Media queries 
using only a min-width specification will be displayed in purple. Ones that use both 
will be displayed in blue.

Using the DOM Viewer
The DOM Viewer allows you to view the Document Object Model (DOM) to 
quickly examine the structure of your webpage as well as interact with it to select, 
edit, and move existing elements and insert new ones. You’ll find that it makes 
working in complex HTML structures simple.

Using element dialogs, displays,  
and inspectors
As Dreamweaver moves to make Live view the default workspace, it has driven the 
development of new methods for editing and managing HTML elements. You will 
find a handful of new dialogs, displays, and inspectors that provide instant access 

Max-width media query 
in the VMQ interface

Min-width media query 
in the VMQ interface

Media using both  
max-width and  
min-width 
specifications
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to important element properties and specifications. All of them, except the Text 
Display, allow you to add class or id attributes to the selected element and even 
insert references to those attributes into your CSS style sheets and media queries.

Position Assist dialog
The Position Assist dialog appears whenever new elements are being inserted 
in Live view, using either the Insert menu or Insert panel. Typically, the Position 
Assist dialog will offer the options Before, After, Wrap, and Nest. Depending on 
what type of element is selected and what item is targeted by the cursor, one or 
more of the options may be grayed out.

The Position Assist dialog allows you 
to control how elements and compo-
nents are inserted in Live view.

Element Display
The Element Display appears whenever you select an element in Live view. When 
an element is selected in Live view, you can change the selection focus by pressing 
the up and down arrow keys; the Element Display will then highlight each element 
in the page, in turn, based on its position in the HTML structure.

The Element Display features a Quick Property Inspector icon where you can 
instantly access properties such as formats, links, and alignment. The Element 
Display also allows you to add a class or id to the selected element or to edit a class 
or id.

Image Display
The Image Display provides a Quick Property inspector from which you can access 
the image source, alt text, and width and height attributes; it also contains a field 
from which you can add a hyperlink.

The Element Display 
enables you to quickly 
apply classes, IDs, and 
links, as well as perform 
basic formatting.
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The Image Display gives you 
quick access to the image 
source and allows you to 
add hyperlinks.

Text Display
The Text Display appears whenever you select a portion of text in Live view. The 
Text Display allows you to apply bold <strong>, italic <em>, and hyperlink <a> 
markup to the selected text. Double-click the text to open the orange editing box. 
When you select some text, the Text Display will appear. When you are finished 
editing the text, click just outside the orange box to complete and accept the 
changes. Press Esc to cancel the changes and return the text to its previous state.

Setting up version control in Dreamweaver
Dreamweaver CC (2019 release) supports Git, a popular open source version  
control system for managing the source code of your websites. Such systems are 
very valuable for preventing conflicts and loss of work when you have a number  
of people working together on a project.

The Text Display lets 
you apply bold, italics, 
and hyperlink markup 
to selected text.
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You set up a Git repository within your site definition dialog. After that, you can 
connect your site to your remote repository and push and pull changes as needed.

Go to https://helpx.adobe.com/dreamweaver/using/git-support.html for full 
instructions on how to set up Git version control for your own project.

Exploring, experimenting, and learning
The Dreamweaver interface has been carefully crafted over many years to make the 
job of webpage design and development fast and easy. It’s a design in progress. It’s 
always changing and evolving. If you think you already know the program, you’re 
wrong. Install the latest version and check it out. Feel free to explore and experi-
ment with various menus, panels, and options to create the ideal workspace and 
keyboard shortcuts to produce the most productive environment for your own 
purposes. You’ll find the program endlessly adaptable, with power to spare for any 
task. Enjoy.

https://helpx.adobe.com/dreamweaver/using/git-support.html
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Review questions
1	 Where can you access the command to display or hide any panel?

2	 Where can you find the Code, Split, Design, and Live view buttons?

3	 What can be saved in a workspace?

4	 Do workspaces also load keyboard shortcuts?

5	 What happens in the Property inspector when you insert the cursor into various 
elements on the webpage?

6	 What features in the CSS Designer make it easy to build new rules from existing ones?

7	 What can you do with the DOM Viewer?

8	 Does the Element Display appear in Design or Code view?

9	 What is Git?

Review answers
1	 All panels are listed in the Window menu.

2	 The Code, Split, Design, and Live view buttons are components of the Document 
toolbar.

3	 Workspaces can save the configuration of the document window, the open panels, and 
the panels’ size and position on the screen.

4	 No. Keyboard shortcuts are loaded and preserved independently of a workspace.

5	 The Property inspector adapts to the selected element, displaying pertinent informa-
tion and formatting commands.

6	 The CSS Designer allows you to copy and paste styles from one rule to another.

7	 The DOM Viewer allows you to visually examine the DOM and select and insert new 
elements and edit existing ones.

8	 No. The Element Display is visible only in Live view.

9	 Git is an open source version control system that enables you to manage your website 
source code.
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HTML BASICS

Lesson overview
In this lesson, you’ll familiarize yourself with HTML and learn:

•	 What HTML is and where it came from

•	 Frequently used HTML tags

•	 How to insert special characters

•	 What semantic web design is and why it’s important

•	 New features and capabilities in HTML

This lesson will take about 45 minutes to complete. This lesson does not 
have support files.
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