


CLASSROOM IN A BOOK® 
The official training workbook from Adobe
Russell Chun

Animate CC
Adobe

2017 release



Adobe Animate CC Classroom in a Book® (2017 release)

© 2017 Adobe. All rights reserved.

If this guide is distributed with software that includes an end user license agreement, this guide, as well as the soft-
ware described in it, is furnished under license and may be used or copied only in accordance with the terms of 
such license. Except as permitted by any such license, no part of this guide may be reproduced, stored in a retrieval 
system, or transmitted, in any form or by any means, electronic, mechanical, recording, or otherwise, without the 
prior written permission of Adobe Systems Incorporated. Please note that the content in this guide is protected 
under copyright law even if it is not distributed with software that includes an end user license agreement.

The content of this guide is furnished for informational use only, is subject to change without notice, and should 
not be construed as commitment by Adobe Systems Incorporated. Adobe Systems Incorporated assumes no 
responsibiitiy or liability for any errors or inaccuracies that may appear in the informational content contained in 
this guide.

Please remember that existing artwork or images that you may want to include in your project may be protected 
under copyright law. The unauthorized incorporation of such material into your new work could be a violation of 
the rights of the copyright owner. Please be sure to obtain any permission required from the copyright owner.

Any references to company names in sample files are for demonstration purposes only and are not intended to 
refer to any actual organization.

Adobe, the Adobe logo, Adobe Animate, Flash, Flash Player, ActionScript, AIR, Dreamweaver, Illustrator, Adobe 
Media Encoder, Photoshop, Typekit, and Classroom in a Book are either registered trademarks or trademarks of 
Adobe Systems Incorporated in the United States and/or other countries. Adobe product screenshots reprinted 
with permission from Adobe Systems Incorporated.

Apple, iOS, iPad, iPhone, iPod, Mac OS, Macintosh, Safari, and Xcode are trademarks of Apple, regis-tered in the 
U.S. and other countries. Amazon, Kindle, Fire and all related logos are trademarks of Amazon.com, Inc. or its 
affiliates. NOOK® is a trademark of Barnes & Noble, Inc. Android, Chrome, Google, and YouTube are registered 
trademarks of Google Inc. Microsoft, Windows, and Internet Explorer are either registered trademarks or trade-
marks of Microsoft Corporation in the U.S. and/or other countries. All other trademarks are the property of their 
respective owners.

Adobe Systems Incorporated, 345 Park Avenue, San Jose, California 95110-2704, USA.

Notice to U.S. Government End Users. The Software and Documentation are “Commercial Items,” as that term is 
defined at 48 C.F.R. §2.101, consisting of “Commercial Computer Software” and “Commercial Computer Software 
Documentation,” as such terms are used in 48 C.F.R. §12.212 or 48 C.F.R. §227.7202, as applicable. Consistent 
with 48 C.F.R. §12.212 or 48 C.F.R. §§227.7202-1 through 227.7202-4, as applicable, the Commercial Computer 
Software and Commercial Computer Software Documentation are being licensed to U.S. Government end users 
(a) only as Commercial Items and (b) with only those rights as are granted to all other end users pursuant to the 
terms and conditions herein. Unpublished-rights reserved under the copyright laws of the United States. Adobe 
Systems Incorporated, 345 Park Avenue, San Jose, CA 95110-2704, USA. For U.S. Government End Users, Adobe 
agrees to comply with all applicable equal opportunity laws including, if appropriate, the provisions of Executive 
Order 11246, as amended, Section 402 of the Vietnam Era Veterans Readjustment Assistance Act of 1974 (38 
USC 4212), and Section 503 of the Rehabilitation Act of 1973, as amended, and the regulations at 41 CFR Parts 
60-1 through 60-60, 60-250, and 60-741. The affirmative action clause and regulations contained in the preceding 
sentence shall be incorporated by reference.

Adobe Press books are published by Peachpit, a division of Pearson Education located in San Francisco, California. 
For the latest on Adobe Press books, go to www.adobepress.com. To report errors, please send a note to errata@
peachpit.com. For information on getting permission for reprints and excerpts, contact permissions@peachpit.com.

Executive Editor: Nancy Davis
Senior Production Editor: Tracey Croom
Development Editor: Victor Gavenda
Project Editor: Happenstance Type-O-Rama
Copy Editor and Proofreader: Elizabeth Welch
Technical Reviewer: Joseph Labrecque
Keystroker: David L. Smith

Compositor: Happenstance Type-O-Rama
Indexer: Jack Lewis
Cover Designer: Eddie Yuen
Cover Illustration: Daniele De Nigris (Italy),  
behance.net/DNDesign
Interior Designer: Mimi Heft

Printed and bound in the United States of America

ISBN-13: 978-0-134-66523-8
ISBN-10: 0-134-66523-6

9  8  7  6  5  4  3  2  1

http://www.adobepress.com


ANIMATE CC CLASSROOM IN A BOOK (2017 RELEASE)  iii

WHERE ARE THE LESSON FILES?
Purchase of this Classroom in a Book in any format gives you access to the lesson 
files you’ll need to complete the exercises in the book. 

You’ll find the files you need on your Account page at peachpit.com on the 
Registered Products tab.

1	 Go to www.peachpit.com/register.

2	 Sign in or create a new account.

3	 Enter the ISBN: 9780134665238.

4	 Answer the questions as proof of purchase.

5	 Access the lesson files through the Registered Products tab on your  
Account page.

6 	 Click the Access Bonus Content link below the title of your product to proceed 
to the download page. Click the lesson file links to download them to your 
computer.

http://www.peachpit.com/register
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GETTING STARTED
The 2017 release of Adobe Animate CC provides a comprehensive authoring envi-
ronment for creating sophisticated animations and interactive, media-rich applica-
tions that you can publish to a variety of platforms. Animate CC is widely used in 
the creative industry to develop engaging projects integrating video, sound, graph-
ics, and animation. You can create original content in Animate CC or import assets 
from other Adobe applications such as Photoshop or Illustrator, quickly design 
animation and multimedia, and use code to integrate sophisticated interactivity.

Use Animate CC to generate graphics and animation assets, to build innovative and 
immersive websites, to create stand-alone applications for the desktop, or to create 
apps to distribute to mobile devices running on the Android or iOS system.

With extensive controls for animation, intuitive and flexible drawing tools, and 
output options for HD video, HTML5, mobile apps, desktop applications, and Flash 
Player, Adobe Animate CC is a rare example of a robust multimedia authoring 
environment that enables your imagination to become reality.

About Classroom in a Book
Adobe Animate CC Classroom in a Book (2017 release) is part of the official training 
series for Adobe graphics and publishing software developed with the support of 
Adobe product experts. The lessons are designed so you can learn at your own pace. 
If you’re new to Animate, you’ll learn the fundamental concepts and features you’ll 
need to use the program. Classroom in a Book also teaches many advanced features, 
including tips and techniques for using the latest version of this application.

Although each lesson provides step-by-step instructions for creating a specific proj-
ect, there’s room for exploration and experimentation. You can follow the book from 
start to finish, or do only the lessons that correspond to your interests and needs. 
Each lesson concludes with review questions to reinforce what you’ve learned.

What’s New
The 2017 release of Adobe Animate CC provides more expressive tools, powerful 
controls for animation, and robust support for a wider variety of playback platforms.

The lessons in this book provide opportunities to use some of the updated features 
and improvements in Animate CC, including

•	 The new Camera tool that puts you in the director’s chair to frame the action 
with camera moves such as zooming and panning
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•	 The expanded Paintbrush tool featuring flexible controls and customizations of 
Art and Pattern brushes for vector-based painterly effects

•	 Integration of Typekit and Google Web fonts in HTML5 Canvas projects

•	 Support for HTML5 video

•	 A new Framepicker for graphic symbols to provide better controls for character 
lip syncing

•	 Tagged swatches that allow quick and easy editing of colors

•	 Collaboration with other designers and with other Adobe applications through 
Creative Cloud libraries

Prerequisites
Before you begin using Adobe Animate CC Classroom in a Book (2017 release), make 
sure your system is set up correctly and that you’ve installed the required software. 
You should have a working knowledge of your computer and operating system. You 
should know how to use the mouse and standard menus and commands, and also 
how to open, save, and close files. If you need to review these techniques, see the 
printed or online documentation included with your Microsoft Windows or Apple 
Mac OS software.

In addition, you need to download the free Adobe AIR runtime, available at  
get.adobe.com/air/, to publish desktop applications in Lesson 10.

Installing Animate CC
You must purchase the Adobe Animate CC application as part of Adobe Creative 
Cloud. The following specifications are the minimum required system configurations.

Windows

•	 Intel® Pentium 4, Intel Centrino®, Intel Xeon®, or Intel Core™ Duo (or compatible) 
processor

•	 Microsoft® Windows® 7 (64 bit), Windows 8.1 (64 bit), or Windows 10 (64 bit)

•	 2 GB of RAM (8 GB recommended)

•	 1024x900 display (1280x1024 recommended)

•	 4 GB of available hard-disk space for installation; additional free space required 
during installation (cannot install on removable flash storage devices)

•	 Broadband Internet connection and registration are necessary for required 
software activation, validation of subscriptions, and access to online services.
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Mac OS

•	 Multicore Intel® processor

•	 Mac OS X v10.10 (64-bit), 10.11 (64-bit), or 10.12 (64-bit)

•	 2 GB of RAM (8 GB recommended)

•	 1024x900 display (1280x1024 recommended)

•	 QuickTime 12.x software recommended

•	 4 GB of available hard-disk space for installation; additional free space required 
during installation (cannot install on a volume that uses a case-sensitive file 
system or on removable flash storage devices)

•	 Broadband Internet connection and registration are necessary for required 
software activation, validation of subscriptions, and access to online services.

For updates on system requirements and complete instructions on installing the 
software, visit helpx.adobe.com/animate/system-requirements.html.

Install Animate CC from Adobe Creative Cloud at creative.adobe.com and make 
sure that you have your login and password accessible.

Online Content
Your purchase of this Classroom in a Book includes online materials provided by 
way of your Account page on peachpit.com. These include:

Lesson files

To work through the projects in this book, you will need to download the lesson 
files from peachpit.com. You can download the files for individual lessons or it may 
be possible to download them all in a single file. 

Web Edition

The Web Edition is an online interactive version of the book providing an enhanced 
learning experience. Your Web Edition can be accessed from any device with a con-
nection to the Internet and it contains: 

•	 The complete text of the book

•	 Hours of instructional video keyed to the text

•	 Interactive quizzes

In addition, the Web Edition may be updated when Adobe adds significant feature 
updates between major Creative Cloud releases. To accommodate the changes, sec-
tions of the online book may be updated or new sections may be added. 
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Accessing the Lesson files and Web Edition

If you purchased an eBook from peachpit.com or adobepress.com, your Web 
Edition will automatically appear under the Digital Purchases tab on your Account 
page. Click the Launch link to access the product. Continue reading to learn how to 
register your product to get access to the lesson files.

If you purchased an eBook from a different vendor or you bought a print book,  
you must register your purchase on peachpit.com in order to access the online content:

1	 Go to www.peachpit.com/register.

2	 Sign in or create a new account.

3	 Enter the ISBN: 9780134665238.

4	 Answer the questions as proof of purchase.

5	 The Web Edition will appear under the Digital Purchases tab on your Account 
page. Click the Launch link to access the product.

The Lesson Files can be accessed through the Registered Products tab on your 
Account page. Click the Access Bonus Content link below the title of your 
product to proceed to the download page. Click the lesson file links to download 
them to your computer.

Bonus material

We’ve provided additional material for both Lessons 9 and 10 on peachpit.com. 
You’ll find “Working with Sound and Video—Supplement” for Lesson 9 and 
“Publishing—Supplement” for Lesson 10 in your account once you register 
your book as described earlier in “Accessing the Lesson files and Web Edition”. 
Download the supplements from the same page as the lesson files.

How to Use the Lessons
Each lesson in this book provides step-by-step instructions for creating one or more 
specific elements of a real-world project. Some lessons build on projects created in 
preceding lessons; most stand alone. All the lessons build on one another in terms 
of concepts and skills, so the best way to learn from this book is to proceed through 
the lessons in sequential order. In this book, some techniques and processes are 
explained and described in detail only the first few times you perform them.

You will create and publish final project files, such as SWF files, HTML files, videos, 
or AIR desktop applications, in some lessons in this book. The files in the End fold-
ers (01End, 02End, and so on) within the Lesson folders are samples of completed 
projects for each lesson. Use these files for reference if you want to compare your 
work in progress with the project files used to generate the sample projects. 

http://www.peachpit.com/register
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The organization of the lessons is also project-oriented rather than feature-oriented. 
That means, for example, that you’ll work with symbols on real-world design projects 
over several lessons rather than in just one chapter.

Additional Resources
Adobe Animate CC Classroom in a Book (2017 release) is not meant to replace 
documentation that comes with the program or to be a comprehensive reference 
for every feature. Only the commands and options used in the lessons are explained 
in this book. For comprehensive information about program features and tutorials, 
refer to these resources:

Adobe Animate Learn and Support: helpx.adobe.com/animate.html is where you 
can find and browse Help and Support content on Adobe.com. You can also reach 
that page by choosing Help > Animate Help or Help > Animate Support Center or 
pressing F1.  Visit helpx.adobe.com/animate/topics.html for documentation on indi-
vidual features and to download a PDF of the Help file.

Adobe Creative Cloud Learn: For inspiration, key techniques, cross-product 
workflows, and updates on new features, go to the Creative Cloud Learn page, 
helpx.adobe.com/creative-cloud/learn/tutorials.html. Available to all.

Adobe Forums: forums.adobe.com lets you tap into peer-to-peer discussions, ques-
tions, and answers on Adobe products. The Adobe Animate CC forum is accessible 
by choosing Help > Adobe Online Forums.

Adobe Create: create.adobe.com/ offers thoughtful articles on design and design issues, 
a gallery showcasing the work of top-notch designers, tutorials, and more.

Resources for educators: www.adobe.com/education and edex.adobe.com offer 
a treasure trove of information for instructors who teach classes on Adobe soft-
ware. Find solutions for education at all levels, including free curricula that use an 
integrated approach to teaching Adobe software and can be used to prepare for the 
Adobe Certified Associate exams.

Also check out these useful sites:

Adobe Add-ons: creative.adobe.com/addons is a central resource for finding tools, 
services, extensions, code samples, and more to supplement and extend your Adobe 
products.

Adobe Animate CC product home page: www.adobe.com/products/animate.html

Adobe Authorized Training Centers
Adobe Authorized Training Centers offer instructor-led courses and training on Adobe 
products. A directory of AATCs is available at training.adobe.com/trainingpartners.

http://www.adobe.com/education
http://www.adobe.com/products/animate.html
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GETTING ACQUAINTED

Lesson Overview

In this lesson, you’ll learn how to do the following:

•	 Create a new file in Adobe Animate CC

•	 Adjust Stage settings and document properties

•	 Add layers to the Timeline

•	 Understand and manage keyframes in the Timeline

•	 Work with imported images in the Library panel

•	 Move and reposition objects on the Stage

•	 Open and work with panels

•	 Select and use tools in the Tools panel

•	 Preview your animation

•	 Save your file
This lesson will take less than 1 hour to complete. Copy the Lesson01 
folder, which contains the images you’ll use in this lesson, onto your 
hard drive if it’s not already there. Download the project files for this 
lesson from the Registered Products tab on your Account page at  
www.peachpit.com (click the Access Bonus Content link for this product) 
and store them on your computer in a convenient location, as described 
in the Getting Started section of this book. Your Account page is also 
where you’ll find any updates to the chapters or to the lesson files. 

1

http://www.peachpit.com
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In Animate, the Stage is where you lay out all your 
visual elements, the Timeline organizes frames and 
layers, and other panels let you edit and control your 
creation. 
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Starting Adobe Animate CC and Opening a File
The first time you start Adobe Animate CC you’ll see a Welcome screen with links 
to standard file templates, tutorials, and other resources. In this lesson, you’ll create 
a simple slideshow-type animation to showcase a few vacation snapshots. You’ll 
add a background, photos, and some decorative elements, and in the process you’ll 
learn about positioning elements on the Stage and placing them along the Timeline 
so they appear one at a time, in sequence. You’ll begin learning how to use the Stage 
to organize your visual elements spatially, and how to use the Timeline to organize 
your elements temporally.

1	 Start Adobe Animate CC. In Windows, choose Start > Programs > Adobe 
Animate CC. On a Mac , double-click Adobe Animate CC in the Adobe Animate 
CC folder in the Applications folder. 

2	 Choose File > Open. In the Open dialog box, select the 01End.fla file in the 
Lesson01/01End folder and click Open to see the final project.

3	 Choose File > Publish. 

Animate creates the necessary files to play in the target platform. In this 
example, the HTML5 Canvas Document creates an HTML file, a JavaScript file, 
and a folder of images to display the final animation in a browser. The files are 
saved in the same folder as your Animate document.

4	 Double-click the HTML file. 

An animation plays. During the animation, several overlapping photos appear 
one by one, with stars appearing at the end.

5	 Close the browser.

## Note  If you have not 
already downloaded 
the project files for this 
lesson to your computer 
from your Account page 
on peachpit.com, make 
sure to do so now. See 
“Getting Started” at the 
beginning of the book.

�� Tip  You can also 
start Animate by 
double-clicking an 
Animate file (*.fla or 
*.xfl), such as the  
01End.fla file that is 
provided to show you 
the completed project.

## Note  The Output 
panel will display an 
error message saying 
that EaselJS is starting 
frame numbers at 0 
instead of 1. You can 
ignore that warning 
since you will not be 
dealing with different 
frame numbers on the 
Timeline in this lesson.
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Creating a new document
You’ll create the simple animation that you just previewed by starting a new 
document.

1	 In Animate, choose File > New. 

The New Document dialog box opens. 

2	 Under the General tab, choose the first option, HTML5 Canvas.

The other options target different playback technologies. For example, WebGL 
is a document type for animation that takes advantage of hardware-accelerated 
support for graphics. ActionScript 3.0 is a document type that targets the Flash 
Player. AIR for Android and AIR for iOS are documents configured for playback 
as apps on an Android or an Apple mobile device. AIR for Desktop are documents 
for playback as stand-alone programs on Windows or Mac desktop computers.

3	 On the right-hand side of the dialog box, you can choose the dimensions of 
the Stage by entering new pixel values for the Width and Height. Enter 800 
for Width and 600 for Height. Keep the Ruler units as Pixels.



4  LESSON 1  Getting Acquainted

Leave the Frame Rate and Background Color for the Stage at their default 
settings. You can always edit these document properties, as explained later in 
this lesson.

4	 Click OK.

Animate creates a new HTML5 Canvas document with all the specified settings.

5	 Choose File > Save. Name the file 01_workingcopy.fla, and from the File Format/
Save As Type menu, choose Animate document (*.fla). Although the software 
application is called Animate, be aware that the file extension is still .fla or .xfl, 
which both preserve echoes of the name of the ancestor of Animate: “Flash.”

Save it in the 01Start folder. Saving your file right away is a good working habit that 
ensures your work won’t be lost if the application or your computer crashes. You 
should always save your Animate file with the extension .fla (or .xfl if you save it as 
a Animate Uncompressed Document) to identify it as the Animate source file.

Understanding Document Types
Adobe Animate CC is an animation and multimedia authoring tool that creates 
media for multiple platforms and playback technologies. Knowing where your final 
animation will play determines what type of document you’ll choose as a new file. 

Playback environment
The playback, or runtime, environment is the technology that your final, published 
files use to play. Your animation could play in a browser with the Flash Player, or 
they could play in a browser with HTML5 and JavaScript. Or, they could play as an 
app on a mobile device. You should make that decision first so you can choose the 
appropriate document type.

Regardless of the playback environment and document type, all document types are 
saved as FLA or XFL (Animate) files. The difference is that each document type is 
configured to export different, final published files.

•	 Choose HTML5 Canvas to create animated assets that play back in a modern 
browser using HTML5 and JavaScript. You can add interactivity by inserting 
JavaScript within Animate CC, or to the final published files.

•	 Choose WebGL for pure animated assets to take advantage of hardware-
accelerated support of graphics. 

•	 Choose ActionScript 3.0 to create animation and interactivity that plays in 
the Flash Player in a desktop browser. ActionScript 3.0 is the latest version 
of Animate’s scripting language, which is similar to JavaScript. Choosing an 
ActionScript 3.0 document doesn’t mean you have to include ActionScript code. 
It simply means that your playback target is the Flash Player.

## Note  Not all features 
are supported across 
all document types. 
For example, WebGL 
documents don’t 
support text and HTML5 
Canvas documents 
don’t support the 3D 
Rotation or Translation 
tool. Unsupported tools 
are grayed out.

## Note  This latest 
version of Animate 
CC supports only 
ActionScript 3.0. If you 
need ActionScript 1.0 or 
2.0, you must work with 
Flash Professional CS6 
or lower. 

## Note  The 
ActionScript 3.0 
document also supports 
publishing content as 
a projector for either 
Mac or Windows. A 
projector plays as a 
stand-alone application 
on the desktop, without 
needing a browser. 
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•	 Choose AIR to create animation and interactivity that plays as an application on 
Windows or Mac desktops, without needing a browser. You can add interactivity 
in an AIR document using ActionScript 3.0.

•	 Choose AIR for Android or AIR for iOS to publish an app for an Android or 
an Apple mobile device. You can add interactivity for your mobile app using 
ActionScript 3.0.

Getting to Know the Workspace
The Adobe Animate CC work area includes the command menus at the top of the 
screen and a variety of tools and panels for editing and adding elements to your 
movie. You can create all the objects for your animation in Animate, or you can 
import elements you’ve created in Adobe Illustrator, Adobe Photoshop, Adobe 
After Effects, or other compatible applications. 

By default, Animate displays the menu bar, Timeline, Stage, Tools panel, Properties 
panel, Edit bar, and a few other panels. As you work in Animate, you can open, 
close, group, ungroup, dock, undock, and move panels around the screen to fit your 
work style or your screen resolution. 

Layers Timeline

Edit bar Application bar Properties panel

Tools 
panel

Stage

Workspace 
switcher

�� Tip  You can easily 
switch from one 
document type to 
another. For example, 
you can convert 
an ActionScript 3.0 
document into 
an HTML5 Canvas 
document if you have 
an old Flash banner 
ad animation that you 
want to update. Use 
Commands > Convert 
To Other Document 
Formats to choose a 
new document type. 
Some functionality 
and features may be 
lost in the conversion, 
however. For example, 
conversion to an HTML5 
Canvas document 
will comment out 
ActionScript code.
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Choosing a new workspace
Animate also provides a few preset panel arrangements (“workspaces”) that may 
better suit the needs of particular users. Use the Window > Workspaces submenu 
to choose a different workspace or to save a new one. The same functionality is pro-
vided by the workspace switcher at the right end of the Application bar.

1	 Click the workspace switcher and choose a new workspace.

The various panels are rearranged and resized according to their importance in 
the chosen workspace. For example, the Animator and Designer workspaces put 
the Timeline at the top for easy and frequent access.

2	 If you’ve moved some of the panels around and want to return to one of the 
prearranged workspaces, choose Window > Workspaces > Reset [preset name] 
and click OK in the confirmation dialog box.

3	 To return to the default workspace, choose Window > Workspaces > Essentials. 
In this Classroom in a Book, we’ll be using the Essentials workspace.

Saving your workspace
If you find an arrangement of panels that suits your style of work, you can save it as 
a custom workspace and return to it at a later date.

1	 Open the workspace switcher and choose New Workspace.

The New Workspace dialog box appears.
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2	 Enter a name for your new workspace. Click OK.

Animate saves the current arrangement of panels and adds it to the options in 
the Workspace menu, which you can access at any time.

About the Stage
The big white rectangle in the middle of your screen is called the Stage. As with 
a theater stage, the Stage in Animate is the area that viewers see when a movie is 
playing. It contains the text, images, and video that appear on the screen. Move ele-
ments on and off the Stage to place them in and out of view. You can use the rulers 
(View > Rulers) or grids (View > Grid > Show Grid) to help you position items on 
the Stage. Additionally, you can pull guides from the ruler (View > Guides) or use 
the Align panel and other tools you’ll learn about in later lessons in this book.

By default, you’ll see the gray area off the Stage where you can place elements that 
won’t be visible to your audience. The gray area is called the pasteboard. To see 
only the Stage, choose View > Pasteboard to deselect the option. For now, leave the 
option to view the pasteboard selected.

You can also click the Clip The Content Outside Stage button to crop the graphic 
elements that fall beyond the Stage area to see how your audience will view your 
final project. 

Default Stage Stage with Clip The Content Outside Stage selected

�� Tip  By default, the 
Animate interface is 
dark. However, you can 
change the interface 
to a lighter gray if 
you prefer. Choose 
Edit > Preferences 
(Windows) or Animate > 
Preferences (Mac), 
and in the General 
preferences option, 
select Light for User 
Interface.
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To scale the Stage so that it fits completely in the application window, choose View > 
Magnification > Fit In Window. You can also choose different magnification view 
options from the menu just above the Stage. 

Changing the Stage properties
Now you’ll change the color of the Stage. The Stage color, along with other docu-
ment properties such as the Stage dimensions and frame rate, are available in the 
Properties panel, which is the vertical panel just to the right of the Stage.

1	 In the Properties pane of the Properties panel, note that the dimensions of the 
current Stage are set at 800 x 600 pixels, which you chose when you created 
the new document.

�� Tip  You can view 
the Stage in full-screen 
mode without the 
distraction of the various 
panels by choosing 
View > Screen Mode > 
Full Screen Mode. Use 
F4 to toggle the panels, 
and press the Esc key 
to return to Standard 
Screen Mode.
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2	 Click the Background color button next to the Stage and choose a new color 
from the color palette. Choose dark gray (#333333).

Your Stage is now a different color. You can change the Stage properties at 
any time.

Working with the Library Panel
The Library panel is accessible from a tab just to the right of the Properties 
panel. The Library panel is where you store and organize symbols created in 
Animate, as well as imported files, including bitmaps, graphics, sound files, and 
video clips. Symbols are graphics used frequently for animation and for interactivity. 

About the Library panel
The Library panel lets you organize library items in folders, see how often an item is 
used in a document, and sort items by type. When you import items into Animate, 
you can import them directly onto the Stage or into the library. However, any 
item you import onto the Stage is also added to the library, as are any symbols you 
create. You can then easily access the items to add them to the Stage again, edit 
them, or see their properties.

To display the Library panel, choose Window > Library, or press Ctrl+L (Windows) 
or Command+L (Mac).

Importing an item to the Library panel
Often, you’ll create graphics directly with Animate’s drawing tools and save them 
as symbols, which are stored in the library. Other times you’ll import media such as 
JPEG images or MP3 sound files, which are also stored in the library. In this lesson, 
you’ll import several images into the library to be used in the animation.

1	 Choose File > Import > Import To Library. In the Import To Library dialog box, 
select the background.png file in the Lesson01/01Start folder, and click Open.

Animate imports the selected PNG image and places it in the Library panel.

## Note  You’ll learn 
much more about 
symbols in Lesson 3.

�� Tip  You can also 
access the assets that 
you’ve stored in your 
Creative Cloud  account 
by clicking the CC 
Libraries icon (Window > 
CC Libraries).
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2	 Continue importing photo1.jpg, photo2.jpg, and photo3.jpg from the 01Start 
folder. Don’t import the last image, photo4.jpg. You’ll use that image later in this 
lesson.

You can also hold down the Shift key to select multiple files and import all of the 
images at once.

The Library panel displays all the imported images with their filenames and a 
thumbnail preview. These images are now available to be used in your Animate 
document.

Adding an item from the Library panel to the Stage
To use an imported image, simply drag it from the Library panel onto the Stage.

1	 Choose Window > Library to open the Library panel if it isn’t already open.

2	 Select the background.png item in the Library panel.

3	 Drag the background.png item onto the Stage and place it approximately in the 
center of the Stage.

�� Tip  You can also 
choose File > Import > 
Import To Stage, or 
press Ctrl+R (Windows) 
or Command+R (Mac) 
to import an image 
file to the library and 
put it on the Stage all in 
one step.
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Understanding the Timeline
In the default Essentials workspace, the Timeline is located below the Stage. Like 
films, Animate documents measure time in frames. As the movie plays, the play-
head, shown as a red vertical line, advances through the frames in the Timeline. 
You can change the content on the Stage for different frames. To display a frame’s 
content on the Stage for any particular time, move the playhead to that frame in the 
Timeline. 

At the bottom of the Timeline, Animate indicates the selected frame number, 
the current frame rate (how many frames play per second), and the time that has 
elapsed so far in the movie.

Frame rate

Elapsed time (seconds)Current frame

The Timeline also contains layers, which help you organize the artwork in your 
document. At the moment, your project only has one layer, which is called Layer 1. 
Think of layers as multiple film strips stacked on top of one another. Each layer 
can contain a different image that appears on the Stage, and you can draw and 
edit objects on one layer without affecting objects on another layer. The layers are 
stacked in the order in which they overlap each other, so that objects on the bottom 
layer in the Timeline are on the bottom of the stack on the Stage. You can hide, lock, 
or show the contents of layers as outlines by clicking the dots in the layer under the 
layer option icons. 

Show Layer As Outlines

Layer 
Name Show/Hide Layer

Lock/Unlock Layer
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Changing the appearance of  
the Timeline
You can adjust the Timeline’s appearance to accommodate your workflow. When 
you want to see more layers, select Short from the Frame View menu in the upper-
right corner of the Timeline. The Short option decreases the height of frame cell 
rows. The Preview and Preview In Context options display thumbnail versions of the 
contents of your keyframes in the Timeline.

You can also change the width of the frame cells by selecting Tiny, Small, Normal, 
Medium, or Large. In this book, we show the Timeline frames in their default, 
Normal, size.

Reset Timeline Zoom Resize Timeline Zoom

For finer control over the Timeline frame sizes, drag the Resize Timeline View slider. 
The slider adjusts the size of the frames so you can see more or less of the Timeline. 
Click the Reset Timeline Zoom To The Default Level button to revert the Timeline 
view to its Normal size.

Renaming a layer
It’s a good idea to separate your content on different layers and name each layer to 
indicate its contents so that you can easily find the layer you need later.

1	 Select the existing layer in the Timeline, called Layer 1.

2	 Double-click the name of the layer to rename it and type background. 
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3	 Click outside the name box to apply the new name. 

4	 Click the dot below the lock icon to lock the layer. Locking a layer prevents you 
from accidentally making changes to it.

The pencil icon with a diagonal slash that appears after the layer name indicates 
that you can’t make edits to the layer because it is locked.

Adding a layer
A new Animate document contains only one layer, but you can add as many layers 
as you need. Objects in the top layers will overlap objects in the bottom layers.

1	 Select the background layer in the Timeline. 

2	 Choose Insert > Timeline > Layer. You can also click the New Layer button 
below the Timeline. A new layer appears above the background layer. 

3	 Double-click the new layer to rename it and type photo1. Click outside the name 
box to apply the new name. 

Your Timeline now has two layers. The background layer contains the 
background photo, and the newly created photo1 layer above it is empty.

4	 Select the top layer called photo1.

5	 Choose Window > Library to open the Library panel if it isn’t already open.
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6	 Drag the library item called photo1.jpg from the library onto the Stage.

The photo1 JPEG appears on the Stage and overlaps the background image.

7	 Choose Insert > Timeline > Layer, or click the New Layer button ( ) below 
the Timeline to add a third layer.

8	 Rename the third layer photo2.

## Note  As you 
add more layers and 
your overlapping 
graphics become more 
complicated, click the 
dot below the eye icon 
in your layer to hide the 
contents of any layer. 
Alternatively, hold down 
the Shift key and click 
the dot below the eye 
icon to make the layer 
transparent so you can 
see what’s below it. 
Hiding or making a layer 
transparent only affects 
how you see your project 
in Animate—it doesn’t 
affect your final exported 
project. Double-click the 
Layer icon to modify the 
level of transparency 
in the Layer Properties 
dialog box.
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Working with layers
If you don’t want a layer, you can easily delete it by selecting it and then clicking 
the Delete button below the Timeline. 

If you want to rearrange your layers, simply drag any layer to move it to a new posi-
tion in the layer stack.

Inserting frames
So far, you have a background photo and another overlapping photo on the Stage, 
but your entire animation exists for only a single frame. To create more time on the 
Timeline and make this animation run for a longer duration, you must add addi-
tional frames.

1	 Select frame 48 in the background layer. Use the Resize Timeline View slider at 
the bottom-right corner of the Timeline to expand the Timeline frames to make 
it easier to identify frame 48.

2	 Choose Insert > Timeline > Frame (F5). You can also right-click and choose 
Insert Frame from the context menu that pops up. 
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Animate adds frames in the background layer up to the selected frame, frame 48.

3	 Select frame 48 in the photo1 layer.

4	 Choose Insert > Timeline > Frame (F5). You can also right-click and choose 
Insert Frame from the menu. 

Animate adds frames in the photo1 layer up to the selected frame, frame 48. 

5	 Select frame 48 in the photo2 layer and insert frames on this layer. 

You now have three layers, all with 48 frames on the Timeline. Since the frame rate 
of your Animate document is 24 frames per second, your current animation lasts 
2 seconds. 

Selecting multiple frames
Just as you can hold down the Shift key to select multiple files on your desktop, you can 
hold down the Shift key to select multiple frames on the Animate Timeline. If you 
have several layers and want to insert frames into all of them, hold down the Shift 
key and drag where you want to add frames. Then choose Insert > Timeline > Frame.

Creating a keyframe
A keyframe indicates a change in content on the Stage. Keyframes are indicated on 
the Timeline as a circle. An empty circle means there is nothing in that particular 
layer at that particular time. A filled-in black circle means there is something in that 
particular layer at that particular time. The background layer, for example, con-
tains a filled keyframe (black circle) in the first frame. The photo1 layer also contains 
a filled keyframe in its first frame. Both layers contain photos. The photo2 layer, 
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however, contains an empty keyframe in the first frame, indicating that it is cur-
rently empty. 

Filled keyframe

Empty keyframe

You’ll insert a keyframe in the photo2 layer at the point in time when you want the 
next photo to appear.

1	 Select frame 24 on the photo2 layer. As you select a frame, Animate displays the 
frame number beneath the Timeline.

2	 Choose Insert > Timeline > Keyframe (F6).

A new keyframe, indicated by an empty circle, appears in the photo2 layer in 
frame 24.

3	 Select the new keyframe at frame 24 in the photo2 layer.

4	 Drag photo2.jpg from your library onto the Stage.

The empty circle at frame 24 becomes filled, indicating that there is now 
content in the photo2 layer. At frame 24, your photo appears on the Stage. You 
can drag the red playhead from the top of the Timeline to “scrub,” or show 
what’s happening on the Stage, at any point along the Timeline. You’ll see 
that the background photo and photo1 remain on the Stage throughout the 
Timeline, but photo2 appears only at frame 24. 
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Understanding frames and keyframes is essential for mastering Animate. Be sure 
you understand how the photo2 layer contains 48 frames with 2 keyframes—an 
empty keyframe at frame 1 and a filled keyframe at frame 24.

photo2 layer contains 
content from frames 24–48

photo2 layer is empty 
from frames 1–23
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Moving a keyframe
If you want your photo2.jpg to appear later or earlier in time, you need to move the 
keyframe in which it appears closer or further to the right on the Timeline. You can 
easily move any keyframe along the Timeline by simply selecting it, and then drag-
ging it to a new position. 

1	 Select the keyframe in frame 24 on the photo2 layer.

2	 Move your mouse cursor slightly, and you’ll see a box icon appear near your 
cursor indicating that you can reposition the keyframe.

3	 Drag the keyframe to frame 12 in the photo2 layer.

The photo2.jpg now appears on the Stage much earlier in the animation.

Removing keyframes
If you want to remove a keyframe, do not press the Delete key! Doing so will delete 
the contents of that keyframe on the Stage. Instead, select the keyframe and choose 
Modify > Timeline > Clear Keyframe (Shift+F6). Your keyframe will be removed from 
the Timeline.

Organizing Layers in a Timeline
At this point, your working Animate file has only three layers: a background layer, a 
photo1 layer, and a photo2 layer. You’ll be adding additional layers for this project, 
and as in most other projects, you’ll end up having to manage multiple layers. Layer 
folders help you group related layers to keep your Timeline organized and manage-
able, just like you make folders for related documents on your desktop. Although it 
may take some time to create the folders, you’ll save time later because you’ll know 
exactly where to look for a specific layer.
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Creating layer folders
For this project, you’ll continue to add layers for additional photos, and you’ll place 
those layers in a layer folder.

1	 Select the photo2 layer and click the New Layer button at the bottom of the 
Timeline.

2	 Name the layer photo3.

3	 Insert a keyframe at frame 24.

4	 Drag the photo3.jpg from the library onto the Stage.

You now have four layers. The top three contain photos of scenes from Coney 
Island that appear at different keyframes.

5	 Select the photo3 layer and click the New Folder icon at the bottom of the 
Timeline ( ).

A new layer folder appears above the photo3 layer.
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6	 Name the folder photos.

Adding layers to layer folders
Now you’ll add the photo layers to the photos folder. As you arrange layers, remem-
ber that Animate displays the content in the layers in the order in which they appear 
in the Timeline, with the top layer’s content at the front and the bottom layer’s 
content at the back.

1	 Drag the photo1 layer into the photos folder.

Notice how the bold line indicates the destination of your layer. When you place 
a layer inside a folder, Animate indents the layer name.

2	 Drag the photo2 layer into the photos folder.

3	 Drag the photo3 layer into the photos folder.

All three photo layers should be in the photos folder, in the same stacking order 
as they were outside the folder. 
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You can collapse the folder by clicking the arrow just to the left of the folder name. 
Expand the folder by clicking the arrow again. Be aware that if you delete a layer 
folder, you delete all the layers inside that folder as well.

Cut, copy, paste, and duplicate layers
When managing multiple layers and layer folders, you can rely on cut, copy, paste, 
and duplicate layer commands to make your workflow easier and more efficient. 
All the properties of the selected layer are copied and pasted, including its frames, 
keyframes, any animation, and even the layer name and type. You can also copy and 
paste layer folders and their contents.

To cut or copy any layer or layer folder, simply select the layer and right-click the 
layer name. In the menu that appears, choose Cut Layers or Copy Layers.

Right-click the Timeline again and choose Paste Layers. The layer or layers that you 
cut or copied are pasted into the Timeline. Use Duplicate Layers to copy and paste in 
one operation.

You can also cut, copy, paste, or duplicate layers from the application menu bar. 
Choose Edit > Timeline > and choose Cut Layers, Copy Layers, Paste Layers, or 
Duplicate Layers.
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Using the Properties Panel 
The Properties panel gives you quick access to the attributes you’re most likely to 
need. What appears in the Properties panel depends on what you’ve selected. For 
example, if nothing is selected, the Properties panel includes options for the general 
Animate document, including changing the Stage color or dimensions. If you’ve 
selected an object on the Stage, the Properties panel shows its x and y coordinates 
and its width and height, among other information. You’ll use the Properties panel 
to move your photos on the Stage. 

Positioning an object on the Stage
You’ll begin by moving the photos with the Properties panel. You’ll also use the 
Transform panel to rotate the photos.

1	 At frame 1 of the Timeline, select the photo1.jpg image that you dragged onto 
the Stage in the photo1 layer. A blue outline indicates that the object is selected.

2	 In the Properties panel, type 50 for the X-value and 50 for the Y-value. Press Enter 
(Windows)/Return (Mac) to apply the values. You can also drag over the X- and 
Y-values to change their values. The photo moves to the left side of the Stage. 

The X- and Y-values are measured on the Stage from the top-left corner. X begins 
at 0 and increases to the right, and Y begins at 0 and increases downward. The 
registration point (the point from which Animate makes measurements) for 
imported photos is at the top-left corner.

3	 Choose Window > Transform to open the Transform panel. 

4	 In the Transform panel, select Rotate, and type -12 in the Rotate box, or drag 
over the value to change the rotation. Press Enter (Windows)/Return (Mac) to 
apply the value.

�� Tip  If the Properties 
panel is not open, 
choose Window > 
Properties, or press 
Ctrl+F3 (Windows)/
Command+F3 (Mac).
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The selected photo on the Stage rotates 12 degrees counterclockwise.

5	 Select frame 12 of the photo2 layer. Now click the photo2.jpg on the Stage to 
select it.

6	 Use the Properties panel and Transform panel to position and rotate the second 
photo in an interesting way. Use X=200, Y=40, and a Rotate of 6 to give it some 
contrast with the first photo.
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7	 Select frame 24 in the photo3 layer. Now click photo3.jpg on the Stage to 
select it.

8	 Use the Properties panel and Transform panel to position and rotate the 
third photo in an interesting way. Use X=360, Y=65, and a Rotate of –2 so 
all your photos have visual variety.

Working with panels
Just about everything you do in Animate involves a panel. In this lesson, you use the 
Library panel, Tools panel, Properties panel, Transform panel, History panel, and the 
Timeline. In later lessons, you’ll learn to use other panels to control various aspects 
of your project. Because panels are such an integral part of the Animate workspace, 
it pays to know how to manage them. 

## Note  When images 
are scaled or rotated 
in Animate, they may 
appear jagged. You can 
smooth each image 
by double-clicking 
the bitmap icon in the 
Library panel. In the 
Bitmap Properties 
dialog box that appears, 
select the Allow 
Smoothing option.
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To open any panel in Animate, choose its name from the Window menu.

Panel groups

Expand Icons
Collapse Panels 

To Icons

Dock containing 
panels collapsed 
to icons

Dock containing 
only the Tools 
panel

Panel docks

Individual panels float freely, and they can be combined in docks, groups, or stacks.

•	 A dock is a collection of panels or panel groups in a vertical column. Docks stick 
to the left or right edges of the user interface.

•	 A group is a collection of panels that can be placed within a dock or can float 
freely.

•	 A stack is similar to a dock but can be placed anywhere in the interface.

In the default Essentials workspace, most of the panels are organized in three docks 
on the right side of the screen. The Timeline and Output panels are grouped at the 
bottom, and the Stage is on the top. However, you can move a panel to any position 
that is convenient for you. 

•	 To move a panel, drag it by its tab to a new location. 

•	 To move a panel group or stack, drag it by the area next to the tabs.

	 As the panel, group, or stack passes over other panels, groups, docks, or stacks, a 
blue highlighted drop zone will appear. If you release the mouse button while  
a drop zone is visible, the panel will be added to the group, dock, or stack.
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•	 To dock a panel, drag it by its tab into a new position at the left or right edge 
of the screen. If you drag it over the top or bottom of an existing dock, a 
horizontal drop zone will show you the panel’s new location. If a vertical drop 
zone appear, dropping the panel will create a new dock.

•	 To group a panel, drag its tab onto the tab of another panel or the drop zone at 
the top of an existing group.

•	 To create a stack, drag a group out of a dock or an existing stack so it floats 
freely. Alternatively, drag one free-floating panel onto the tab of another 
floating panel.

You also have the option of displaying most of the panels as icons to save space but 
still maintain quick access. Click the double arrowheads in the top-right corner of a 
dock or stack to collapse the panels to icons. Click the double arrowheads again to 
expand the icons into panels.

Using the Tools Panel
The Tools panel—the long, narrow panel on the far right side of the work area—
contains selection tools, drawing and type tools, painting and editing tools, 
navigation tools, and tool options. You’ll use the Tools panel frequently to switch 
to tools designed for the task at hand. Most often, you’ll use the Selection tool, 
which is the black arrow tool at the top of the Tools panel, for selecting and 
clicking on items on the Stage or the Timeline. When you select a tool, check 
the options area at the bottom of the panel for more options and other settings 
appropriate for your task. 

Selecting and using a tool
When you select a tool, the options available at the bottom of the Tools panel and 
the Properties panel change. For example, when you select the Rectangle tool, the 
Object Drawing mode and Snap To Objects options appear. When you select the 
Zoom tool, the Enlarge and Reduce options appear. 

The Tools panel contains too many tools to display all at once. Some tools are 
arranged in hidden groups in the Tools panel; only the tool you last selected from 
a group is displayed. A small triangle in the lower-right corner of the tool’s button 
indicates that there are other tools in the group. Click and hold the icon for the vis-
ible tool to see the other tools available, and then select one from the menu.

You’ll use the PolyStar tool to add a little decoration to your short animation.

1	 Select the folder in the Timeline, and then click the New Layer button.

2	 Name the new layer stars.

Selection and 
transformation 
tools

Drawing tools

Editing tools

Options
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3	 Lock the other layers below it so you don’t accidentally move anything into them.

4	 In the Timeline, move the playhead to frame 36 and select frame 36 in the 
stars layer.

5	 Choose Insert > Timeline > Keyframe (F6) to insert a new keyframe at frame 
36 in the stars layer.

You will create star shapes to appear at frame 36 in this layer.

6	 In the Tools panel, select the PolyStar tool, which is indicated by the 
hexagon shape.

7	 In the Properties panel, click the colored square next to the pencil icon, which 
indicates the color of the outline, or stroke, and choose the red diagonal line.

The red diagonal line represents a color of None for the stroke. 

8	 Click the colored square next to the paint bucket icon, which indicates the 
color of the fill, and choose a bright, cheery color such as yellow. You can click 
the color wheel at the upper right to access the Adobe Color Picker, or you can 
change the Alpha percentage at the upper right, which determines the level of 
transparency.

## Note  If you’re 
working with a smaller 
display, the bottom of 
the Tools panel may 
be cut off. That makes 
some of the tools and 
buttons invisible. But 
there’s an easy way to 
fix the problem: drag 
the left edge of the 
Tools panel to widen it 
so it can show multiple 
columns of tools.
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Color Picker

Color choices

Current color Transparency

9	 In the Properties panel, click the Options buttons under Tool Settings.

The Tool Settings dialog box appears.

10	For Style, choose star. For Number Of Sides, enter 5, and for Star Point Size, 
enter 0.5. Click OK.

	 The options determine the shape of your star.

11	Make sure the empty keyframe in frame 36 of the title layer is selected. Click on 
the Stage where you want to begin adding a star and drag to change the width 
of your star. Move your cursor around the first click to rotate the star. Make 
multiple stars of different sizes and with different angles of rotation.
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12	Exit the PolyStar tool by selecting the Selection tool.

13	Use the Properties panel or the Transform panel to reposition or rotate your 
stars on the Stage, if desired. Or, choose the Selection tool and simply click to 
select a star and drag it to a new position on the Stage. The X- and Y-values in 
the Properties panel update as you drag the star around the Stage.

14	Your animation for this lesson is finished! Compare the Timeline in your file with 
the Timeline in the final file, 01End.fla.

Undoing Steps in Animate
In a perfect world, everything would go according to plan. But sometimes you need 
to move back a step or two and start over. You can undo steps in Animate using the 
Undo command or the History panel. 

To undo a single step in Animate, choose Edit > Undo or press Ctrl+Z (Windows)/
Command+Z (Mac). To redo a step you’ve undone, choose Edit > Redo. 

The easiest way to undo multiple steps in Animate is to use the History panel, which 
displays a list of all the last 100 steps you’ve performed. Closing a document clears 
its history. To access the History panel, choose Window > History. 

For example, if you aren’t satisfied with the newly added stars, you can undo your 
work and return your Animate document to a previous state.

1	 Choose Edit > Undo to undo the last 
action you made. You can choose the Undo 
command multiple times to move backward 
as many steps as are listed in the History 
panel. You can change the maximum 
number of Undo commands by selecting 
Animate > Preferences.

2	 Choose Window > History to open the 
History panel.

3	 Drag the History panel slider up to the step 
just before your mistake. Steps below that 
point are dimmed in the History panel and 
are removed from the project. To add a step 
back, move the slider back down. 

## Note  If you remove 
steps in the History 
panel and then perform 
additional steps, the 
removed steps will no 
longer be available.
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Previewing Your Movie
As you work on a project, it’s a good idea to preview it frequently to ensure that 
you’re achieving the desired effect. To quickly see your animation within the 
Animate environment, choose Control > Play, or simply press the Enter/Return key.

To see how an animation or movie will appear to a viewer in its runtime environ-
ment, choose Control > Test Movie > In Browser. You can also press Ctrl+Enter 
(Windows) or Command+Return (Mac) to preview your movie.

1	 Choose Control > Test.

Animate creates the required published files in the same location as your FLA 
file and opens and plays the animation in your default browser.

Animate automatically loops your movie in this preview mode.

If you don’t want the animation to loop when you test your movie, in Animate 
choose File > Publish Settings, and deselect the Loop Timeline option.


