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Lesson files
Each lesson has its own folder 
inside the Lessons folder. You will 
need to copy these lesson folders 
to your hard drive before you can 
begin each lesson

Where are the lesson files?
Purchasing this Classroom in a Book gives you access to the lesson files that you’ll 
need to complete the exercises in the book, as well as other content to help you 
learn more about Adobe software and use it with greater efficiency and ease. The 
diagram below represents the contents of the lesson files directory, which should 
help you locate the files you need. Please see the Getting Started section for full 
download instructions.

Adobe Press
Find information about other 
Adobe Press titles, covering the 
full spectrum of Adobe products, 
in the Online Resources file.

Online resources
Links to Adobe Community Help, product 
Help and Support pages, Adobe certification 
programs, Adobe TV, and other useful online 
resources can be found inside a handy HTML 
file. Just open it in your web browser and 
click on the links, including a special link 
to this book’s product page where you can 
access updates bonus material.
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Getting Started

Adobe Flash Professional CC provides a comprehensive authoring environ-
ment for creating interactive and media-rich applications. Flash is widely 
used to create engaging projects integrating video, sound, graphics, and 
animation. You can create original content in Flash or import assets from 
other Adobe applications such as Photoshop or Illustrator, quickly design 
animation and multimedia, and use Adobe ActionScript 3.0 to integrate 
sophisticated interactivity.

Use Flash Professional to build innovative and immersive Web sites, to create 
standalone applications for the desktop, or to create apps to distribute to 
mobile devices running on the Android or the iOS system.

With extensive controls for animation, intuitive and flexible drawing tools, 
and a powerful, object-oriented coding language, Flash delivers one of the few 
robust authoring environments that let your imagination become reality. 

About Classroom in a Book
Adobe Flash Professional CC Classroom in a Book is part of the official training 
series for Adobe graphics and publishing software developed with the sup-
port of Adobe product experts. The lessons are designed so you can learn at 
your own pace. If you’re new to Flash, you’ll learn the fundamental concepts 
and features you’ll need to use the program. Classroom in a Book also teaches 
many advanced features, including tips and techniques for using the latest ver-
sion of this application.



2  Getting Started

What’s New
The lessons in this book provide opportunities to use some of the updated features 
and improvements in Flash Professional, including:

•	 A fresh, modern user interface

•	 Working in full-screen mode

•	 Distributing symbols and bitmaps to keyframes

•	 Swapping multiple symbols or bitmaps

•	 A powerful Find and Replace panel

•	 Improved Photoshop and Illustrator file import

•	 A re-engineered Actions panel

•	 Smoother, more responsive drawing and editing

•	 Exporting videos with Adobe Media Encoder

•	 Resizing the Stage relative to an anchor point

•	 An integrated Toolkit for CreateJS, which publishes animation to HTML5 
and JavaScript

•	 Comprehensive testing tools, such as device testing via USB and SWF analysis 
with Adobe Scout

•	 Synchronizing preferences on multiple machines with Creative Cloud

Streamlined Feature Set
In order to provide a more focused creative environment, Adobe Flash Professional 
CC has streamlined its feature set. The following is a list of the notable tools that 
have been dropped from the previous version:

•	 Support for ActionScript 1 and 2

•	 TLF text 

•	 Motion Editor for motion tweens

•	 Bone tool for inverse kinematics

•	 Deco tool

•	 Project panel

•	 Printing

•	 Strings panel
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•	 Behaviors panel

•	 Object-level undo

•	 Spelling panel

•	 Movie Explorer

•	 Bandwidth profiler in Test Movie mode

•	 FXG file import or export

•	 Kuler panel

•	 Video Cue Points (but still available in Media Encoder and through ActionScript)

•	 Closed captioning

•	 Video playback on Stage with FLV playback component

•	 Device Central

•	 Importing SWFs

•	 Pick whip in the Code Snippets panel

•	 Auto-Save

•	 File Info (XMP Metadata)

•	 Import support for some bitmap formats (BMP, TIFF, AutoCad) and some 
sound formats (AIFF, Sound Designer, Around AU, Adobe Sounds Document)

•	 Publishing projectors

Prerequisites
Before you begin using Adobe Flash Professional CC Classroom in a Book, make 
sure your system is set up correctly and that you’ve installed the required software. 
You should have a working knowledge of your computer and operating system. You 
should know how to use the mouse and standard menus and commands, and also 
how to open, save, and close files. If you need to review these techniques, see the 
printed or online documentation included with your Microsoft Windows or Apple 
Mac OS software.

If you’re working on Microsoft Windows, you need to download Apple’s 
QuickTime software, free from http://www.apple.com/quicktime/download/ 
in order to work with the videos in Lesson 7.

In addition, you need to download the free Adobe AIR runtime, available at  
http://get.adobe.com/air/ to publish desktop applications in Lesson 11.

http://www.apple.com/quicktime/download/
http://get.adobe.com/air/


4  Getting Started

Installing Flash
You must purchase the Adobe Flash Professional application as part of the Adobe 
Creative Cloud. The following specifications are the minimum required system 
configurations.

Windows

•	 Intel® Pentium 4, Intel Centrino®, Intel Xeon®, or Intel Core™ Duo 
(or compatible) processor

•	 Microsoft® Windows® 7 64-bit and Microsoft® Windows® 8 64-bit

•	 2GB of RAM (4GB recommended)

•	 1024x768 display (1280x800 recommended)

•	 Java Runtime Environment 1.7 (included)

•	 QuickTime 10.x software recommended

•	 2GB of available hard-disk space for installation; additional free space required 
during installation (cannot install on removable flash storage devices)

•	 Broadband Internet connection and registration are necessary for required 
software activation, validation of subscriptions, and access to online services.

Mac OS

•	 Multicore Intel® processor

•	 Mac OS X v10.7 64-bit and 10.8 64-bit

•	 2GB of RAM (4GB recommended)

•	 1024x768 display (1280x800 recommended)

•	 Java™ Runtime Environment 1.7

•	 QuickTime 10.x software recommended

•	 2.5GB of available hard-disk space for installation; additional free space required 
during installation (cannot install on a volume that uses a case-sensitive file 
system or on removable flash storage devices)

•	 Broadband internet connection and registration are necessary for required 
software activation, validation of subscriptions, and access to online services.

For updates on system requirements and complete instructions on installing the 
software, visit http://www.adobe.com/products/flash/tech-specs.html. 

Install Flash from the Adobe Creative Cloud at https://creative.adobe.com/ and 
make sure that you have your login and password accessible.

http://www.adobe.com/products/flash/tech-specs.html
https://creative.adobe.com/
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Copying the Lesson Files
The lessons in Adobe Flash Professional CC Classroom in a Book use specific source 
files, such as image files created in Adobe Illustrator, video files created in Adobe 
After Effects, audio files, and prepared Flash documents. To access the Classroom 
in a Book files:

1	 On a Mac or PC, go to www.peachpit.com/redeem and enter the code found at 
the back of your book.

2	 If you do not have a Peachpit.com account, you will be prompted to create one.

3	 The downloadable files will be listed under Lesson & Update Files tab on your 
Account page. 

4	 Click the lesson file links to download them to your computer.

5	 On your hard drive, create a new folder in a convenient location and name it 
FlashProCC, following the standard procedure for your operating system:

•	 If you’re running Windows, right-click and choose New > Folder. Then enter 
the new name for your folder.

•	 If you’re using Mac OS, in the Finder, choose File > New Folder. Type the 
new name and drag the folder to the location you want to use.

Now you can download the lesson files onto your hard drive.

6	 Drag the Lessons folder (which contains folders named Lesson01, Lesson02, 
and so on) that you downloaded onto your hard drive to your new 
FlashProCC folder.

When you begin each lesson, navigate to the folder with that lesson number to access 
all the assets, sample movies, and other project files you need to complete the lesson.

If you have limited storage space on your computer, you can copy each lesson 
folder as you need it, and then delete it after you’ve completed the lesson if desired. 
Some lessons build on preceding lessons; in those cases, a starting project file is 
provided for you for the second lesson or project. You do not have to save any fin-
ished project if you don’t want to or if you have limited hard drive space.

Copying the sample movies and projects
You will create and publish SWF animation files in some lessons in this book. 
The files in the End folders (01End, 02End, and so on) within the Lesson folders are 
samples of completed projects for each lesson. Use these files for reference if you 
want to compare your work in progress with the project files used to generate the 
sample movies. The end project files vary in size from relatively small to a couple of 
megabytes, so you can either copy them all now if you have ample storage space or 
copy just the end project file for each lesson as needed. Then you can delete it when 
you finish that lesson.

http://www.peachpit.com/redeem
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How to Use the Lessons
Each lesson in this book provides step-by-step instructions for creating one or 
more specific elements of a real-world project. Some lessons build on projects 
created in preceding lessons; most stand alone. All the lessons build on one 
another in terms of concepts and skills, so the best way to learn from this book is 
to proceed through the lessons in sequential order. In this book, some techniques 
and processes are explained and described in detail only the first few times you 
perform them. 

The organization of the lessons is also project-oriented rather than feature-oriented. 
That means, for example, that you’ll work with symbols on real-world design projects 
over several lessons rather than in just one chapter. 

Additional Resources
Adobe Flash Professional CC Classroom in a Book is not meant to replace docu-
mentation that comes with the program or to be a comprehensive reference for 
every feature. Only the commands and options used in the lessons are explained in 
this book. For comprehensive information about program features and tutorials, 
refer to these resources:

Adobe Flash Professional CC Help and Support: www.adobe.com/support/flash 
is where you can find and browse Help and Support content on Adobe.com. 
Adobe Flash Professional Help and Adobe Flash Professional Support Center are 
accessible from Flash Professional’s Help menu.

Adobe Creative Cloud Learning: For inspiration, key techniques, cross-product 
workflows, and updates on new features, go to the Creative Cloud Learn page 
https://helpx.adobe.com/creative-cloud/tutorials.html. Available only to Creative 
Cloud members.

Adobe Forums: forums.adobe.com lets you tap into peer-to-peer discussions, 
questions, and answers on Adobe products. The Flash Professional forum is acces-
sible from Flash Professional’s Help menu.

Adobe TV: tv.adobe.com is an online video resource for expert instruction and 
inspiration about Adobe products, including a How To channel to get you started 
with your product.

Adobe Design Center: www.adobe.com/designcenter offers thoughtful articles 
on design and design issues, a gallery showcasing the work of top-notch designers, 
tutorials, and more.

http://www.adobe.com/support/flash
https://helpx.adobe.com/creative-cloud/tutorials.html
http://www.adobe.com/designcenter
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Resources for educators: www.adobe.com/education and http://edex.adobe.com 
offer a treasure trove of information for instructors who teach classes on Adobe 
software. Find solutions for education at all levels, including free curricula that use 
an integrated approach to teaching Adobe software and can be used to prepare for 
the Adobe Certified Associate exams.

Also check out these useful links:

Adobe Marketplace & Exchange: www.adobe.com/cfusion/exchange is a central 
resource for finding tools, services, extensions, code samples, and more to supple-
ment and extend your Adobe products.

Adobe Flash Professional CC product home page: www.adobe.com/products/
flash

Adobe Labs: labs.adobe.com gives you access to early builds of cutting-edge tech-
nology, as well as forums where you can interact with both the Adobe development 
teams building that technology and other like-minded members of the community.

Adobe Certification
The Adobe training and certification programs are designed to help Adobe 
customers improve and promote their product-proficiency skills. There are four 
levels of certification:

•	 Adobe Certified Associate (ACA)

•	 Adobe Certified Expert (ACE)

•	 Adobe Certified Instructor (ACI)

•	 Adobe Authorized Training Center (AATC)

The Adobe Certified Associate (ACA) credential certifies that individuals have the 
entry-level skills to plan, design, build, and maintain effective communications 
using different forms of digital media.

The Adobe Certified Expert program is a way for expert users to upgrade their 
credentials. You can use Adobe certification as a catalyst for getting a raise, finding 
a job, or promoting your expertise.

If you are an ACE-level instructor, the Adobe Certified Instructor program takes your 
skills to the next level and gives you access to a wide range of Adobe resources.

Adobe Authorized Training Centers offer instructor-led courses and training 
on Adobe products, employing only Adobe Certified Instructors. A directory of 
AATCs is available at partners.adobe.com.

For information on the Adobe Certified programs, visit www.adobe.com/support/
certification/main.html.

http://www.adobe.com/education
http://edex.adobe.com
http://www.adobe.com/cfusion/exchange
http://www.adobe.com/products/
http://www.adobe.com/support/certification/main.html
http://www.adobe.com/support/certification/main.html
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Getting Acquainted

Lesson Overview
In this lesson, you’ll learn how to do the following:

•	 Create a new file in Flash

•	 Adjust Stage settings and document properties

•	 Add layers to the Timeline

•	 Manage keyframes in the Timeline

•	 Work with imported images in the Library panel

•	 Move and reposition objects on the Stage

•	 Open and work with panels

•	 Select and use tools in the Tools panel

•	 Preview your Flash animation

•	 Save your Flash file

•	 Access online resources for Flash

This lesson will take less than 1 hour to complete. Copy the Lesson01 
folder, which contains the images you’ll use in this lesson, onto your 
hard drive if it’s not already there. Download the project files for this  
lesson from the Lesson & Update Files tab on your Account page at  
www.peachpit.com and store them on your computer in a convenient 
location, as described in the Getting Started section of this book. Your 
Accounts page is also where you’ll find any updates to the chapters or to 
the lesson files. Look on the Lesson & Update Files tab to access the most 
current content.

1

http://www.peachpit.com
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In Flash, the Stage is where the action takes place, 
the Timeline organizes frames and layers, and other 
panels let you edit and control your creation. 
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Starting Flash and Opening a File
The first time you start Flash you’ll see a Welcome screen with links to standard 
file templates, tutorials, and other resources. In this lesson, you’ll create a simple 
animation to showcase a few vacation snapshots. You’ll add photos and a title, 
and in the process you’ll learn about positioning elements on the Stage and 
placing them along the Timeline. You’ll begin learning how to use the Stage to 
organize your visual elements spatially, and how to use the Timeline to organize 
your elements temporally.

1	 Start Adobe Flash Professional. In Windows, choose Start > Programs > Adobe 
Flash Professional CC. In Mac OS, click Adobe Flash CC in the Adobe Flash CC 
folder in the Applications folder. 

2	 Choose File > Open. In the Open dialog box, select the 01End.fla file in the 
Lesson01/01End folder and click Open to see the final project.

3	 Choose File > Publish. 

Flash creates the necessary files (an HTML file and a SWF) to display the final 
animation in a browser. The files are saved in the same folder as an .fla file.

4	 Double-click the HTML file. 

An animation plays. During the animation, several overlapping photos appear 
one by one, ending with a title.

5	 Close the browser.

P	Note:  If you have 
not already downloaded 
the project files for this 
lesson to your computer 
from your Account page, 
make sure to do so now. 
See “Getting Started” 
at the beginning of 
the book.

P	Note:  You can also 
start Flash by double-
clicking a Flash file 
(*.fla or *.xfl), such as 
the 01End.fla file that is 
provided to show you 
the completed project.
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Creating a New Document
You’ll create the simple animation that you just previewed by starting a new document.

1	 In Flash, choose File > New. 

The New Document dialog box opens. 

2	 Under the General tab, choose ActionScript 3.0.

ActionScript 3.0 is the latest version of Flash’s scripting language, which you use 
to add interactivity. In this lesson, you will not be working with ActionScript, 
but choosing ActionScript 3.0 creates a new document configured for playback 
in a desktop browser (such as Chrome, Safari, or Firefox) with Flash Player.

The other options target alternative playback environments. For example, AIR 
for Android and AIR for iOS create new documents configured for playback 
with AIR on an Android or an Apple mobile device.

3	 On the right-hand side of the dialog box, you can choose the dimensions of 
the Stage by entering new pixel values for the Width and Height. Enter 800 
for Width and 600 for Height. Keep the Ruler units as Pixels.

Leave the Frame rate and Background color for the Stage at their default settings. 
You can always edit these document properties, as explained later in this lesson.

P	Note:  This latest 
version of Flash supports 
only ActionScript 3.0. If 
you need ActionScript 
1.0 or 2.0, you must work 
with previous versions of 
the software.
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4	 Click OK.

Flash creates a new ActionScript 3.0 file with all the specified settings.

5	 Choose File > Save. Name the file 01_workingcopy.fla, and from the File 
Format/Save as type pull-down menu, choose Flash document (*.fla). Save it 
in the 01Start folder. Saving your file right away is a good working habit that 
ensures your work won’t be lost if the application or your computer crashes. 
You should always save your Flash file with the extension .fla (or .xfl if you save 
it as a Flash Uncompressed Document) to identify it as the Flash source file.

Getting to Know the Workspace
The Adobe Flash Professional work area includes the command menus at the top 
of the screen and a variety of tools and panels for editing and adding elements to 
your movie. You can create all the objects for your animation in Flash, or you can 
import elements you’ve created in Adobe Illustrator, Adobe Photoshop, Adobe 
After Effects, or other compatible applications. 

By default, Flash displays the menu bar, Timeline, Stage, Tools panel, Properties 
inspector, Edit bar, and a few other panels. As you work in Flash, you can open, 
close, dock, undock, and move panels around the screen to fit your work style or 
your screen resolution. 

Tools panel 

Layers 

Stage 

Timeline 

Properties inspectorEdit bar
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Choosing a new workspace
Flash also provides a few preset panel arrangements that may better suit the 
needs of particular users. The various workspace arrangements are listed in a 
pull-down menu at the top right of the Flash workspace or in the top menu under 
Window > Workspaces.

1	 Click the Essentials button at the top right of the Flash workspace and choose 
a new workspace.

The various panels are rearranged and resized according to their importance in 
the chosen workspace. For example, the Animator and Designer workspaces put 
the Timeline at the top for easy and frequent access.

2	 If you’ve moved some of the panels around and want to return to one of the 
prearranged workspaces, choose Window > Workspaces > Reset and the name 
of the preset workspace.

3	 To return to the default workspace, choose Window > Workspaces > Essentials. 
In this Classroom in a Book, we’ll be using the Essentials workspace.

Saving your workspace
If you find an arrangement of panels that suits your style of work, you can save it as 
a custom workspace and return to it at a later date.

1	 Click the Essentials button at the top-right corner of the Flash workspace and 
choose New Workspace.

The New Workspace dialog box appears.
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2	 Enter a name for your new workspace. Click OK.

Flash saves the current arrangement of panels and adds it to the options in the 
Workspace pull-down menu, which you can access at any time.

About the Stage
The big white rectangle in the middle of your screen is called the Stage. As with a 
theater stage, the Stage in Flash is the area that viewers see when a movie is playing. 
It contains the text, images, and video that appear on the screen. Move elements on 
and off the Stage to place them in and out of view. You can use the rulers (View > 
Rulers) or grids (View > Grid > Show Grid) to help you position items on the Stage. 
Additionally, you can use the Align panel and other tools you’ll learn about in the 
lessons in this book.

By default, you’ll see the gray area off the Stage where you can place elements that 
won’t be visible to your audience. The gray area is called the Pasteboard. To just 
see the Stage, choose View > Pasteboard to deselect the option. For now, leave the 
option selected.

To scale the Stage so that it fits completely in the application window, choose 
View > Magnification > Fit in Window. You can also choose different magnification 
view options from the pop-up menu just above the Stage. 

Changing the Stage properties
Now you’ll change the color of the Stage. The Stage color, along with other docu-
ment properties such as the Stage dimensions and frame rate, are available in the 
Properties inspector, which is the vertical panel just to the right of the Stage.

P	Note:  By default, 
the Flash interface is 
dark. However, you can 
change the interface to 
a lighter gray if you’re 
more comfortable 
with how it looked in 
previous versions of 
Flash. Choose Flash > 
Preferences, and in the 
General preferences 
option, select Light for 
User Interface.

P	Note:  You can 
view the Stage in full-
screen mode without 
the distraction of the 
various panels by 
choosing View > Screen 
Mode > Full Screen 
Mode. Use F4 to toggle 
the panels, and press 
the Esc key to return to 
Standard Screen Mode.
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1	 At the bottom of the Properties inspector, note that the dimensions of the 
current Stage are set at 800 x 600 pixels, which you chose when you created 
the new document.

2	 Click the Background color button next to Stage and choose a new color from 
the color palette. Choose dark gray (#333333).

Your Stage is now a different color. You can change the Stage properties at 
any time.

Working with the Library Panel
The Library panel is accessible from a tab just to the right of the Properties inspec-
tor. The Library panel is where you store and organize symbols created in Flash, 
as well as imported files, including bitmaps, graphics, sound files, and video clips. 
Symbols are graphics used frequently for animation and for interactivity. 

P	Note:  You’ll learn 
much more about 
symbols in Lesson 3.
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About the Library panel
The Library panel lets you organize library items in folders, see how often an item 
is used in a document, and sort items by type. When you import items into Flash, 
you can import them directly onto the Stage or into the library. However, any item 
you import onto the Stage is also added to the library, as are any symbols you cre-
ate. You can then easily access the items to add them to the Stage again, edit them, 
or see their properties.

To display the Library panel, choose Window > Library, or press Ctrl+L (Windows) 
or Command+L (Mac).

Importing an item to the Library panel
Often, you’ll create graphics directly with Flash’s drawing tools and save them as 
symbols, which are stored in the library. Other times you’ll import media such as 
JPEG images or MP3 sound files, which are also stored in the library. In this lesson, 
you’ll import several JPEG images into the library to be used in the animation.

1	 Choose File > Import > Import to Library. In the Import to Library dialog box, 
select the background.jpg file in the Lesson01/01Start folder, and click Open.

Flash imports the selected JPEG image and places it in the Library panel.

2	 Continue importing photo1.jpg, photo2.jpg, and photo3.jpg from the 01Start folder. 
Don’t import the last image, photo4.jpg. You’ll use that image later in this lesson.

You can also hold down the Shift key to select multiple files and import all of 
the images at once.

3	 The Library panel displays all the imported JPEG images with their filenames 
and a thumbnail preview. These images are now available to be used in your 
Flash document.



Adobe Flash Professional CC Classroom in a Book  17

Adding an item from the Library panel to the Stage
To use an imported image, simply drag it from the Library panel onto the Stage.

1	 Choose Window > Library to open the Library panel if it isn’t already open.

2	 Select the background.jpg item in the Library panel.

3	 Drag the background.jpg item onto the Stage and place it approximately in the 
center of the Stage.

Understanding the Timeline
The Timeline is located below the Stage. Like films, Flash documents measure time 
in frames. As the movie plays, the playhead, shown as a red vertical line, advances 
through the frames in the Timeline. You can change the content on the Stage for 
different frames. To display a frame’s content on the Stage, move the playhead to 
that frame in the Timeline. 

At the bottom of the Timeline, Flash indicates the selected frame number, the cur-
rent frame rate (how many frames play per second), and the time that has elapsed 
so far in the movie.

Current frame

Frame rate

Elapsed time (seconds)

P	Note:  You can also 
choose File > Import > 
Import to Stage, or press 
Ctrl+R (Windows) or 
Command+R (Mac) to 
import an image file to 
the Library and put it on 
the Stage all in one step.
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The Timeline also contains layers, which help you organize the artwork in your 
document. At the moment, your project only has one layer, which is called Layer 1. 
Think of layers as multiple film strips stacked on top of one another. Each layer 
can contain a different image that appears on the Stage, and you can draw and 
edit objects on one layer without affecting objects on another layer. The layers are 
stacked in the order in which they overlap each other, so that objects on the bottom 
layer in the Timeline are on the bottom of the stack on the Stage. You can hide, 
lock, or show the contents of layers as outlines by clicking the dots in the layer 
under the layer option icons. 

Layer name

Show/Hide Layer

Lock/Unlock Layer

Show Layer as Outlines

Renaming a layer
It’s a good idea to separate your content on different layers and name each layer to 
indicate its contents so that you can easily find the layer you need later.

1	 Select the existing layer in the Timeline, called Layer 1.

2	 Double-click the name of the layer to rename it and type background. 

3	 Click outside the name box to apply the new name. 

4	 Click the dot below the lock icon to lock the layer. Locking a layer prevents you 
from accidentally making changes to it.

The pencil icon with a diagonal slash that appears after the layer name indicates 
that you can’t make edits to the layer because it is locked.

Adding a layer
A new Flash document contains only one layer, but you can add as many layers as 
you need. Objects in the top layers will overlap objects in the bottom layers.
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1	 Select the background layer in the Timeline. 

2	 Choose Insert > Timeline > Layer. You can also click the New Layer button 
below the Timeline. A new layer appears above the background layer. 

3	 Double-click the new layer to rename it and type photo1. Click outside the 
name box to apply the new name. 

Your Timeline now has two layers. The background layer contains the 
background photo, and the newly created photo1 layer above it is empty.

4	 Select the top layer called photo1.

5	 Choose Window > Library to open the Library panel if it isn’t already open.

6	 Drag the library item called photo1.jpg from the library onto the Stage.

The photo1 JPEG appears on the Stage and overlaps the background JPEG.
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7	 Choose Insert > Timeline > Layer, or click the New Layer button ( ) below the 
Timeline to add a third layer.

8	 Rename the third layer photo2.

Working with Layers
If you don’t want a layer, you can easily delete it by selecting it, and then clicking 
the Delete button below the Timeline. 

If you want to rearrange your layers, simply click and drag any layer to move it to a 
new position in the layer stack.

Inserting frames
So far, you have a background photo and another overlapping photo on the Stage, 
but your entire animation exists for only a single frame. To create more time on the 
Timeline, you must add additional frames.

1	 Select frame 48 in the background layer.
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2	 Choose Insert > Timeline > Frame (F5). You can also right-click/Ctrl-click 
and choose Insert Frame from the context menu that pops up. 

Flash adds frames in the background layer up to the selected frame, frame 48.

3	 Select frame 48 in the photo1 layer.

4	 Choose Insert > Timeline > Frame (F5). You can also right-click/Ctrl-click 
and choose Insert Frame from the context menu. 

Flash adds frames in the photo1 layer up to the selected frame, frame 48. 

5	 Select frame 48 in the photo2 layer and insert frames on this layer. 

You now have three layers, all with 48 frames on the Timeline. Since the frame 
rate of your Flash document is 24 frames per second, your current animation lasts 
2 seconds. 

Selecting Multiple Frames
Just as you can hold down the Shift key to select multiple files on your desktop, 
you can hold down the Shift key to select multiple frames on the Flash Timeline. 
If you have several layers and want to insert frames into all of them, hold down the 
Shift key and click and drag where you want to add frames. Then choose Insert > 
Timeline > Frame. 



22  Lesson 1  Getting Acquainted

Creating a keyframe
A keyframe indicates a change in content on the Stage. Keyframes are indicated on 
the Timeline as a circle. An empty circle means there is nothing in that particular 
layer at that particular time. A filled-in black circle means there is something in 
that particular layer at that particular time. The background layer, for example, 
contains a filled keyframe (black circle) in the first frame. The photo1 layer also 
contains a filled keyframe in its first frame. Both layers contain photos. The photo2 
layer, however, contains an empty keyframe in the first frame, indicating that it is 
currently empty. 

Empty keyframe

Filled keyframe

You’ll insert a keyframe in the photo2 layer at the point in time when you want the 
next photo to appear.

1	 Select frame 24 on the photo2 layer. As you select a frame, Flash displays the 
frame number beneath the Timeline.

2	 Choose Insert > Timeline > Keyframe (F6).

A new keyframe, indicated by an empty circle, appears in the photo2 layer in 
frame 24.

3	 Select the new keyframe at frame 24 in the photo2 layer.

4	 Drag photo2.jpg from your library onto the Stage.
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The empty circle at frame 24 becomes filled, indicating that there is now 
content in the photo2 layer. At frame 24, your photo appears on the Stage. You 
can click and drag the red playhead from the top of the Timeline to “scrub,” or 
show what’s happening on the Stage at any point along the Timeline. You’ll see 
that the background photo and photo1 remain on the Stage throughout the 
Timeline, but photo2 appears only at frame 24. 

Understanding frames and keyframes is essential for mastering Flash. Be sure you 
understand how the photo2 layer contains 48 frames with 2 keyframes—an empty 
keyframe at frame 1 and a filled keyframe at frame 24.

photo2 layer 
is empty from 
frames 1–23

photo2 layer  
contains content from  

frames 24–48
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Moving a keyframe
If you want your photo2.jpg to appear later or earlier, you need to move the key-
frame in which it appears later or earlier along the Timeline. You can easily move 
any keyframe along the Timeline by simply selecting it, and then dragging it to a 
new position. 

1	 Select the keyframe in frame 24 on the photo2 layer.

2	 Move your mouse cursor slightly, and you’ll see a box icon appear near your 
cursor indicating that you can reposition the keyframe.

3	 Click and drag the keyframe to frame 12 in the photo2 layer.

The photo2.jpg now appears on the Stage much earlier in the animation.

Removing Keyframes
If you want to remove a keyframe, do not press the Delete key! Doing so will delete 
the contents of that keyframe on the Stage. Instead, select the keyframe and choose 
Modify > Timeline > Clear Keyframe (Shift+F6). Your keyframe will be removed from 
the Timeline.

Organizing Layers in a Timeline
At this point, your working Flash file has only three layers: a background layer, a 
photo1 layer, and a photo2 layer. You’ll be adding additional layers for this project, 
and as in most other projects, you’ll end up having to manage multiple layers. Layer 
folders help you group related layers to keep your Timeline organized and manage-
able, just like you make folders for related documents on your desktop. Although it 
may take some time to create the folders, you’ll save time later because you’ll know 
exactly where to look for a specific layer.
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Creating layer folders
For this project, you’ll continue to add layers for additional photos, and you’ll place 
those layers in a layer folder.

1	 Select the photo2 layer and click the New Layer button at the bottom of the 
Timeline ( ).

2	 Name the layer photo3.

3	 Insert a keyframe at frame 24.

4	 Drag the photo3.jpg from the library onto the Stage.

You now have four layers. The top three contain photos of scenes from Coney 
Island that appear at different keyframes.

5	 Select the photo3 layer and click the New Folder icon at the bottom of the 
Timeline ( ).

A new layer folder appears above the photo3 layer.
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6	 Name the folder photos.

Adding layers to layer folders
Now you’ll add the photo layers to the photo folder. As you arrange layers, remem-
ber that Flash displays the content in the layers in the order in which they appear 
in the Timeline, with the top layer’s content at the front and the bottom layer’s 
content at the back.

1	 Drag the photo1 layer into the photos folder.

Notice how the bold line indicates the destination of your layer. When you place 
a layer inside a folder, Flash indents the layer name.

2	 Drag the photo2 layer into the photos folder.

3	 Drag the photo3 layer into the photos folder.

All three photo layers should be in the photos folder. 

You can collapse the folder by clicking the arrow just to the left of the folder name. 
Expand the folder by clicking the arrow again. Be aware that if you delete a layer 
folder, you delete all the layers inside that folder as well.

Changing the appearance of the Timeline
You can adjust the Timeline’s appearance to accommodate your workflow. When 
you want to see more layers, select Short from the Frame View pop-up menu in the 
upper-right corner of the Timeline. The Short option decreases the height of frame 
cell rows. The Preview and Preview in Context options display thumbnail versions 
of the contents of your keyframes in the Timeline.
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You can also change the width of the frame cells by selecting Tiny, Small, Normal, 
Medium, or Large. 

Cut, Copy, Paste, and  
Duplicate Layers
When managing multiple layers and layer folders, 
you can rely on cut, copy, paste, and duplicate 
layer commands to make your workflow easier 
and more efficient. All the properties of the 
selected layer are copied and pasted, including its 
frames, keyframes, any animation, and even the 
layer name and type. You can also copy and paste 
layer folders and their contents.

To cut or copy any layer or layer folder, simply select the layer and right-click/Ctrl-click 
the layer. In the contextual menu that appears, choose Cut Layers or Copy Layers.

Right-click/Ctrl-click on the Timeline again, and choose Paste Layers. The layer or lay-
ers that you cut or copied are pasted into the Timeline. Use Duplicate Layers to copy 
and paste in one operation.

You can also Cut, Copy, Paste, or Duplicate layers from the top Flash menu. Choose Edit > 
Timeline > and choose Cut Layers, Copy Layers, Paste Layers, or Duplicate Layers.

Using the Properties Inspector 
The Properties inspector gives you quick access to the attributes you’re most likely 
to need. What appears in the Properties inspector depends on what you’ve selected. 
For example, if nothing is selected, the Properties inspector includes options for 
the general Flash document, including changing the Stage color or dimensions; 
if you’ve selected an object on the Stage, the Properties inspector shows its x and 
y coordinates and its width and height, among other information. You’ll use the 
Properties inspector to move your photos on the Stage. 
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Positioning an object on the Stage
You’ll begin by moving the photos with the Properties inspector. You’ll also use the 
Transform panel to rotate the photos.

1	 At frame 1 of the Timeline, select the photo1.jpg image that you dragged onto 
the Stage in the photo1 layer. A blue outline indicates that the object is selected.

2	 In the Properties inspector, type 50 for the X value and 50 for the Y value. Press 
Enter (Windows)/Return (Mac OS) to apply the values. You can also click and 
drag your mouse cursor over the X and Y values to change their values. The 
photo moves to the left side of the Stage. 

The X and Y values are measured on the Stage from the top-left corner. X begins 
at 0 and increases to the right, and Y begins at 0 and increases downward. 
The registration point (the point from which Flash makes measurements) for 
imported photos is at the top-left corner.

3	 Choose Window > Transform to open the Transform panel. 

4	 In the Transform panel, select Rotate, and type -12 in the Rotate box, or click 
and drag over the value to change the rotation. Press Enter (Windows)/Return 
(Mac OS) to apply the value.

The selected photo on the Stage rotates 12 degrees counterclockwise.

5	 Select frame 12 of the photo2 layer. Now click on the photo2.jpg on the Stage.

P	Note:  If the 
Properties inspector 
is not open, choose 
Window > Properties, or 
press Ctrl+F3 (Windows)/
Command+F3 (Mac OS).
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6	 Use the Properties inspector and Transform panel to position and rotate the 
second photo in an interesting way. Use X=80, Y=50, and a Rotate of 6 to give it 
some contrast with the first photo.

7	 Select frame 24 in the photo3 layer. Now click on photo3.jpg on the Stage.

8	 Use the Properties inspector and Transform panel to position and rotate the 
third photo in an interesting way. Use X=120, Y=55, and a Rotate of –2 so all 
your photos have visual variety.

P	Note:  When images 
are scaled or rotated in 
Flash, they may appear 
jagged. You can smooth 
them out by double-
clicking the bitmap icon 
in the Library panel. In 
the Bitmap Properties 
dialog box that appears, 
select the Allow 
Smoothing option.
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Working with Panels
Just about everything you do in Flash involves a panel. In this lesson, you use the 
Library panel, Tools panel, Properties inspector, Transform panel, History panel, and 
the Timeline. In later lessons, you’ll use the Actions panel, the Color panel, the Align 
panel, and other panels that let you control various aspects of your project. Because 
panels are such an integral part of the Flash workspace, it pays to know how to 
manage them. 

To open any panel in Flash, choose its name from the 
Window menu.

By default, the Properties inspector, Library panel, and 
Tools panel appear together at the right of the screen; 
the Timeline is at the bottom; and the Stage is on the top. 
However, you can move a panel to any position that is 
convenient for you. 

•	 To undock a panel from the right side of the screen, 
drag it by its tab to a new location.

•	 To dock a panel, drag it by its tab into the dock at a 
new position on the screen. You can drag it to the top, 
bottom, or in between other panels. A blue highlight 
indicates where you can dock a panel.

•	 To group a panel with another, drag its tab onto the 
other panel’s tab.

•	 To move a panel group, drag the group by its dark 
gray top bar.

You also have the option of displaying most of the panels 
as icons to save space but still maintain quick access. Click 
the double arrowheads at the upper right to collapse the 
panels to icons. Click the double arrowheads again to 
expand the panels. 

Using the Tools Panel
The Tools panel—the long, narrow panel on the far right side of the work area—
contains selection tools, drawing and type tools, painting and editing tools, naviga-
tion tools, and tool options. You’ll use the Tools panel frequently to switch to tools 
designed for the task at hand. Most often, you’ll use the Selection tool, which is the 
black arrow tool at the top of the Tools panel, for selecting and clicking on items 
on the Stage or the Timeline. When you select a tool, check the options area at the 
bottom of the panel for more options and other settings appropriate for your task. 


