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Introduction

Microsoft Excel 2013 has evolved from being a robust grid-based number-cruncher, 
to becoming the world’s most robust grid-based number-cruncher that also hap-
pens to be pretty good at text manipulation, graphics, and many other things 

that were barely imaginable back in the days of Excel 1.0.

Excel is a tool that can be applied to many business tasks, including statistics, finance, data 
management, forecasting, analysis, inventory, billing, business intelligence, even word 
processing and graphic design. Excel is also one of the world’s most popular programs 
for keeping all kinds of business and personal lists, from professional contacts to family 
addresses to home inventories.

There are a lot of great features to learn about, so let’s get started.

Who this book is for
This book offers a comprehensive look at the features most people will use in Excel 2013 
and serves as an excellent reference for users who need to understand how to accomplish 
what they need to do. In addition, this book goes a step or two further, providing useful 
information to advanced users who need to understand the bigger picture.

Assumptions about you
The Inside Out series is designed for readers who have some experience with Excel and are 
pretty comfortable finding their way around the program. You don’t have to be a power 
user or an Excel developer.

How this book is organized
This book gives you a comprehensive look at the various features you will use. This book is 
structured in a logical approach to all aspects of using and managing Excel 2013.

Part 1, “Examining the Excel environment,” covers the new features in the 2013 release, and 
also discusses the basics of using Excel.

Part 2, “Building worksheets,” covers the details of how to construct and organize work-
sheets, and how to work with multiple sheets and workbooks.
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Part 3, “Formatting and editing worksheets,” covers all aspects of editing text and data, and 
applying cosmetics to make your worksheets more user-friendly.

Part 4, “Adding graphics and printing,” describes how to work with Excel’s full-featured 
graphics tools and how to prepare your worksheets for printing.

Part 5, “Creating formulas and performing data analysis,” explains in detail how to construct 
formulas, and how to use Excel’s sophisticated analysis tools.

Part 6, “Creating charts,” shows how to get the most out of Excel’s robust charting tools.

Part 7, “Managing databases and tables,” covers the special properties of tables and Pivot-
Tables, and describes how to work with external data.

Part 8, “Using Excel collaboratively,” discusses issues surrounding the use of Excel work-
books and worksheets on the Internet and with email systems, and also covers Office 365.

Part 9, “Automating Excel,” covers recording and debugging macros and creating custom 
functions.

Part 10, “Integrating and extending Excel,” discusses the use of hyperlinks, the sharing of 
data among Office programs, and more.

Does your ribbon look different?
The screen images shown in this book were captured at the screen resolution, magni-
fication, and text size that are optimum for publication purposes. The ribbon on your 
screen might not look the same as the one shown in the book. For example, you might 
see more or fewer buttons in each of the groups, the buttons you see might be repre-
sented by larger or smaller icons than those shown, or the group might be represented 
by a single button that you click to display the group’s commands.
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About the companion content
We have included this companion content to give you an opportunity to gain hands-on 
experience with some of the concepts explored in this book. You can download this book’s 
companion content from the following page:

http://aka.ms/Excel2013InsideOut/files

The companion content includes sample Excel workbooks and other sample content 
referred to in the text.

Acknowledgments
We are lucky to have the best editorial team in the business, making authors look better 
than they deserve and facing inevitable issues with grace and thoughtfulness. Many thanks 
to project manager and shepherd-in-chief Curtis Philips; eagle-eye tech editor Rozanne 
Whalen; our copy editor, the incessantly nit-picky Roger LeBlanc; our proofreader and last 
line of defense, Andrea Fox; and the intrepid Valerie Woolley and Rosemary Caperton, 
cranking the big ol’ book-making machine at Microsoft Press. It’s always a pleasure to play 
with the A-team.

Support and feedback
The following sections provide information on errata, book support, feedback, and contact 
information.

Errata & support
We’ve made every effort to ensure the accuracy of this book and its companion content. 
Any errors that have been reported since this book was published are listed on our Micro-
soft Press site:

http://aka.ms/Excel2013InsideOut/errata

If you find an error that is not already listed, you can report it to us through the same page.

If you need additional support, email Microsoft Press Book Support at 
mspinput@microsoft.com.

Please note that product support for Microsoft software is not offered through the 
addresses above.

http://aka.ms/Excel2013InsideOut/files
http://aka.ms/Excel2013InsideOut/errata
mailto:mspinput@microsoft.com


xxvi	 Introduction

We want to hear from you
At Microsoft Press, your satisfaction is our top priority and your feedback our most valuable 
asset. Please tell us what you think of this book at

http://www.aka.ms/tellpress

The survey is short, and we read every one of your comments and ideas. Thanks in advance 
for your input!

Stay in touch
Let’s keep the conversation going! We’re on Twitter: http://twitter.com/MicrosoftPress

http://aka.ms/tellpress
http://twitter.com/MicrosoftPress


		  1		  1

PART 1

Examining the Excel 
environment

CHAPTER 1

What’s new in Microsoft Excel 2013  .  .  .  .  .  .  .  .  .  3

CHAPTER 2

Exploring Excel fundamentals  .  .  .  .  .  .  .  .  .  .  .  .  .  15

CHAPTER 3

Custom-tailoring the Excel workspace .  .  .  .  .  .  75

CHAPTER 4

Security and privacy .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 105





		  3		  3

CHAPTER 1

What’s new in Microsoft Excel 2013

Considering recent computing history, including the advent of Microsoft Windows 8 
and the increasing ubiquity of tablets and touch interfaces, the modest but impor-
tant improvements made to Microsoft Excel 2013 might seem like a relative island 

of calm in rough digital seas. In 2007, there was truly a paradigm shift in Microsoft Excel 
and Office, and Office 2010 was a significant refinement. The 2013 version represents a fur-
ther refinement, a “flatter” appearance, and an increased presence of the Office brand. Web 
Apps have been available for years now, becoming ever more capable, and are available to 
anyone with even a free Microsoft account. You can run Office apps on Windows phones, 
and Microsoft Surface tablets come with Office installed. More people are using Excel in 
more places. We’re happy to say, it’s better than ever. 

New and improved for 2013. . . . . . . . . . . . . . . . . . . . . . . . . .4

Retired in 2013. .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 10

If you missed the last upgrade. .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 10

If you missed the last two upgrades. .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 11

Moving onward with Office 2013. .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 14
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New and improved for 2013
First, we’ll highlight the new features in the 2013 release of Microsoft Excel. Later, we’ll talk 
about features that have been retired from the program and summarize the features that 
will be new to you if you skipped the last upgrade or two.

New templates
It seems as if templates have always been a bit of an afterthought—as if someone slapped 
together some generic sheets quickly, after everything else was done. No more. Excel 2013 
has a new interface for templates, as shown in Figure 1-1, and now it offers some of the 
most sophisticated and useful prepackaged workbooks you’ve ever seen. They succeed in 
banishing the typical wall of numbers from your desktop, while delivering a lot of useful, 
well-thought-out functionality. These templates are useful, and what’s more, you can learn 
from them. For more information, see “Creating workbooks” in Chapter 2, “Exploring Excel 
fundamentals.”

Figure 1-1  The New command on the File tab reveals a wealth of sophisticated templates. 
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Quick analysis
If you select more than one nonempty cell, the new Quick Analysis tool appears at the 
lower right corner of the selected range. Clicking it displays a context-sensitive toolbar con-
taining tabs and controls applicable to the contents of the selected cells. As you move the 
pointer over icons on the Quick Analysis toolbar, as shown in Figure 1-2, a live preview is 
applied to the selected data on the worksheet. Just click the icon to make it stick. For more 
information, see “Using the Quick Analysis tool” in Chapter 2.

Figure 1-2  Select a range and click the Quick Analysis button to display sets of applicable tools.

Flash Fill
Microsoft describes Flash Fill as a “data assistant that finishes your work for you.” Perhaps 
it’s more like “finishing your sentences for you,” but as it turns out, Flash Fill is an impres-
sive feature that might better be described as a live concatenation function. As you type 
data into cells, Excel compares it to data in adjacent cells, and if a pattern is detected, Flash 
Fill offers a solution, such as the list of full names in column H, shown in Figure 1-3. For 
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more information, see “Automatic parsing and concatenation using Flash Fill” in Chapter 8, 
“Worksheet editing techniques.”

Figure 1-3  Typing one full name into cell H2 was all the information Flash Fill needed to 
correctly guess the desired results, which were suggested after only one letter was typed into 
cell H3.

Recommended charts
Like Flash Fill, the Recommended Charts button on the Insert tab is another brainy feature 
that attempts to figure out what you’re after and limits your choices accordingly, rather 
than presenting you with every available option. When the active cell is in a table, clicking 
the Recommended Charts button displays the Insert Chart dialog box, as shown in Figure 
1-4, which now opens to a special tab containing thumbnails of your data displayed in 
Excel’s selected chart types. If you still need more options, the All Charts tab is just a click 
away. For more information, see “Creating a new chart” in Chapter 19, “Designing charts.”
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Figure 1-4  Recommended Charts analyzes your data and suggests a few appropriate charts. 

New chart-formatting controls
After you create a chart, it is now easier than ever to modify it. The Chart Elements and 
Chart Styles buttons appear to the right of a chart when it is selected, offering instant chart-
formatting gratification, as shown in Figure 1-5. Click options to add or remove elements in 
the chart, or change the chart’s styles and colors. For more information, see “Adding, edit-
ing, and removing a chart title” in Chapter 19.

Figure 1-5  The Chart Elements and Chart Styles buttons appear whenever a chart is selected.
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Timeline
You might call the new Timeline feature a date slicer. If your data includes dates, as in Fig-
ure 1-6, you can include a Timeline with your PivotTable or PivotChart that is used to limit 
the displayed data to any date range you want—in days, months, quarters, or years. For 
more information, see ”Creating a Power View report” in Chapter 24, “Using PowerPivot.”

Figure 1-6  You can click any month segment on the Timeline bar to display only that month’s 
data, or drag a handle to include as many months as you want.

Other improvements
Here are more upgrades and enhancements you’ll find in Excel 2013:

●● Recommended PivotTables  Similar to the Recommended Charts feature, Recom-
mended PivotTables analyzes the selected data and offers appropriate suggestions. 
For more information, see Chapter 24.

●● Table slicers  Slicers were introduced in 2010, but they worked only with Pivot-
Tables. The interface has been upgraded for 2013, and you can now use slicers with 
other kinds of data tables as well. For more information, see “Creating a Power View 
report” in Chapter 24.

●● One workbook, one window, one worksheet  New workbooks contain a single 
sheet in 2013, not three. And previously, all open workbooks were enclosed within a 
single Excel window. Now, each workbook is its own window, making it easier to work 
with multiple workbooks, particularly for multiple-monitor users. For more informa-
tion, see Chapter 7, “How to work a workbook.”

●● Rich chart data labels  Data labels in charts are more customizable in 2013. You 
can create labels with text that updates automatically, you can apply rich formatting, 
and you can display text inside shapes. For more information, see “Adding and posi-
tioning data labels” in Chapter 19.
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●● Animations  As you work in Excel 2013, you’ll notice subtle animations in various 
situations, including updating charts, inserting data, and copying and pasting. For 
example, when you insert a row, the rows below the new row appear to scroll down-
ward. This was formerly referred to as visceral feedback, which is a clue to its true 
value. The animations are not exactly essential, but they help illustrate the changes 
incurred by your actions.

●● Standalone PivotCharts  Now, your Pivot Charts do not need to remain tethered 
to a PivotTable; you can copy and paste them as you wish, without the baggage. For 
more information, see “Creating PivotCharts” in Chapter 23, “Analyzing data with 
PivotTable reports.”

●● New functions  There are always new functions, and this time, most of them are 
meant to increase compatibility with the Open Document format. 

●● The Excel Data Model  Some of the power from the PowerPivot add-in that was 
introduced in Excel 2010 has now been incorporated into Excel as the Excel Data 
Model, which you can use to address multiple tables of data from within Excel. For 
more information, see Chapter 24.

●● Power View  This new feature leverages the power of the Excel Data Model, which 
you can use to construct elaborate presentation-ready reports that include graph-
ics and data from multiple tables or external data sources. For more information, see 
“Creating a Power View report” in Chapter 24.

Does your ribbon look different?
In this book, we provide instructions based on traditional keyboard and mouse input 
methods. If you’re using Excel on a touch-enabled device, you might be using a sty-
lus or your finger to give commands. If so, substitute a tapping action any time we 
instruct you to click a user interface element. Also note that when we tell you to enter 
information in Excel, you can do so by typing on a keyboard, tapping an on-screen key-
board, or even speaking aloud, depending on your computer setup and your personal 
preferences.
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Retired in 2013
These are features whose services were no longer required this time around:

●● Save Workspace  Because of the new “One workbook, one window” interface, the 
Save Workspace command lost most of its reason to exist.

●● Window Split box  Near the vertical scroll bar, lived a little box you could double-
click to split the worksheet into panes. Although you can do the job using the Split 
button on the View tab, the box was inexplicably removed—perhaps another casualty 
of the “one workbook, one window” interface. 

If you missed the last upgrade
Just in case you leapfrogged a software upgrade and missed the last big Microsoft Office 
release, here is a brief description of a few features that are essentially new to you but were 
introduced in the previous release:

●● Backstage view  The File tab opens what Microsoft calls Backstage view, a single 
location where you find essential controls and information about your documents 
and where most of Excel’s behind-the-scenes options and settings reside. The tra-
ditional File menu commands are here, too—for opening, saving, and creating new 
files; using templates; printing; and sharing information with others. 

●● Ribbon customization  Users of the static ribbon in Excel 2007 will be happy to 
know they can now freely rearrange command groups; change the order and posi-
tion of tabs; remove groups; create custom commands, groups, and tabs; and show 
or hide existing tabs. 

●● Sparklines  Sparklines are tiny charts that fit within a cell and give you a visual sum-
mary alongside your data.

●● Paste Preview  In Excel, you now can preview how copied information will look 
before you paste it. When you copy and then click the Paste menu (on the Home tab 
in the Clipboard group), hovering over the option buttons displays what each one 
will do on the worksheet if and when you actually click it.

●● Improved picture editing  Now when you want to insert a picture in a workbook, 
you can edit it directly in Excel—you no longer need to prepare it in advance using a 
photo-editing program. 

●● Office Web Apps  Providing a familiar Microsoft Office experience when you are 
away from your computer, Office Web Apps allow you to work with Excel, Word, 
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PowerPoint, and OneNote files from just about anywhere, offering browser-based 
viewing and lightweight editing. 

●● Slicers  Slicers provide an easy way to filter large PivotTables so that you can see 
exactly the data you need without being distracted by data you don’t need. 

●● Improved conditional formatting  New conditional formatting options let you 
quickly visualize and comprehend data. You will find more styles, icons, and data 
bars, and you now have the ability to highlight specified items (such as the maximum 
or minimum value) in a few clicks. 

●● New functions and functional consistency  Microsoft added a number of statisti-
cal and financial functions that extend or refine existing functionality. Most of the 
new functions are statistical distribution functions. For example, in addition to the 
existing COVAR function, a measure of deviation between data sets, you can now 
choose COVARIANCE.P or COVARIANCE.S, which applies to an entire population of 
data (P) or a representative sample (S). 

●● Improved math equation support  Create and display math equations with a rich 
set of equation-editing tools.

●● Improved charting capacity  Two-dimensional charts in Excel 2007 were limited to 
32,000 data points per series. Chart series are now limited only by system memory.

●● Additional SmartArt graphics  Incorporate great-looking graphics into your pro-
fessional documents without a large consulting team or time commitment. 

●● 64-bit edition  Excel 2010 introduced 64-bit scalability for the Excel guru or analyst 
working with massive, memory-intensive datasets. 

●● Office Mobile  Microsoft Office Mobile brought Office tools to the mini screen of 
your mobile device.

If you missed the last two upgrades
If you are one of the people clinging to Excel 2007 and managed to hang in there all this 
time, well . . . hey, it’s time to upgrade. Here is a summary of the things that were changed 
in Excel 2007: 

●● Results-oriented user interface  The old toolbars and menu bar have been 
replaced by a single toolbar and a new dashboard called the ribbon, which has a task-
oriented structure and easily recognizable tools. Most of the old menus have been 
reborn as tabs.



Chapter 1

12	 Chapter 1  What’s new in Microsoft Excel 2013

●● Graphics enhancements  Excel has improved greatly over the years as a platform 
for graphics and design, and the 2007 release incorporated a few subtle enhance-
ments, including a robust SmartArt feature; improvements to conditional formatting, 
shapes, and charting; and new document themes and cell styles.

●● Improved formatting  Microsoft built a lot more intelligence into the formatting 
features of Excel 2007—including themes, cell styles, and galleries. You can use Live 
Previews to rest the pointer on an item in a palette of options to see what will hap-
pen when and if you click. 

●● Page Layout view  Really more than a view, Page Layout view became a working 
mode with rulers and page previews in which you have full editing functionality and 
control over the appearance of your documents. 

●● Increased capacity and speed  The new XML file format and other internal 
improvements gave Excel 2007 greatly increased capacities in just about every 
specification—for example, spreadsheets that can hold more than one million rows 
of data, 64 levels of nesting in formulas, and built-in support for multicore processors 
and multithreaded chipsets. Other major specification changes included

❍❍ The total number of available columns: 16,384 (was 256).

❍❍ The total number of available rows: 1,048,576 (was 65,536).

❍❍ The total amount of computer memory: Excel can now use the maximum 
allowed by Windows (was 1 gigabyte).

❍❍ The number of unique colors allowed in a single workbook: 4.3 billion (was 56).

❍❍ The number of conditional format conditions on a cell: Limited only by avail-
able memory (was 3).

❍❍ The number of levels of sorting you can perform on a range or table: 64 
(was 3).

❍❍ The number of items allowed in the Filter drop-down list: 10,000 (was 1,000).

❍❍ The total number of unique cell formats in a workbook: 64,000 (was 4,000).

❍❍ The maximum number of characters allowed in formulas: 8,000 (was 1,000).

❍❍ The number of levels of nesting that Excel allows in formulas: 64 (was 7).

❍❍ The maximum number of arguments allowed to a function: 255 (was 30).
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❍❍ The maximum number of items returned by the Find command: 2 billion (was 
64,000).

❍❍ The number of rows allowed in a PivotTable: 1 million (was 64,000).

❍❍ The number of columns allowed in a PivotTable: 16,000 (was 255).

❍❍ The maximum number of unique items within a single PivotTable field: 1 mil-
lion (was 32,000).

❍❍ The maximum length of the MDX name for a PivotTable item, the string length 
for a relational Pivot Table, the caption length, and the field label length: 
32,000 (was 255).

❍❍ The number of fields that a single PivotTable can have: 16,000 (was 255).

❍❍ The number of array formulas that can refer to another worksheet: Limited only 
by available memory (was 65,000).

❍❍ Limit to the number of rows that you can refer to in an array formula: None 
(was 64,000).

❍❍ The number of categories allowed for custom functions: 255 (was 32).

❍❍ Excel now supports multicore processors and multithreaded chipsets.

●● Better and easier tables  Excel 2007 introduced a more robust table feature, incor-
porating PivotTable-like intelligence with easier formatting and editing. New features 
included the Table Styles gallery, structured referencing, the Remove Duplicates fea-
ture, and more. 

●● Improved PivotTables and PivotCharts  Excel 2007 added a few key improve-
ments to PivotTable filtering, design, and layout. The greatly improved appearance of 
the charting features enabled more compelling PivotCharts. 

●● Better database connectivity  Along with better PivotTables, Excel 2007 provided 
built-in access to SQL Server Analysis Services and included support for the Unified 
Dimensional Model (UDM), as well as for online analytical processing (OLAP) brows-
ers and key performance indicators (KPIs). 

●● Formula AutoComplete  Typing functions in formulas became a little easier in 
Excel 2007. When you type an equal sign (=) followed by any letter, you get a drop-
down list of functions that start with that letter, along with a ScreenTip description of 
the highlighted function. Type another letter, and the list is filtered again. If you have 
defined cell range names in your workbook, these appear in the list as well. 
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●● Tools for creating formulas  In Excel 2007, the formula bar became manually resiz-
able to let you display or hide lengthy formulas. This allowed you to enter longer 
formulas than before, with more levels of nesting (parenthetical expressions within 
expressions). The Name Manager dialog box provided greater organization and edit-
ing possibilities. In addition, Excel 2007 included many small improvements in the 
way it works internally, including improvements in subtotals and regression formulas. 

●● Built-in Analysis Toolpak functions  The trusty statistical functions of the vener-
able Analysis Toolpak were fully integrated into the program in 2007. 

●● Enhanced charting features  Excel 2007 included lots of new chart types, updated 
graphics, and a new set of Chart Tools contextual tabs, all of which made experimen-
tation and modification a whole lot easier. Microsoft Office PowerPoint 2007 and 
Office Word 2007 started using the same charting engine as Excel. 

●● XLSX file format  The Microsoft Office Open XML file formats (with the extension 
.xlsx in Excel) provided better integration with external data sources and resulted in 
significantly smaller file sizes. 

●● Improved sorting and filtering  The Sort command, which previously allowed only 
three levels of sorting at a time, was improved to allow 64 levels in Excel 2007. The 
Filter feature was improved, and the Remove Duplicates button helped make man-
aging database information easier, letting you specify in which columns to look for 
duplicate information. 

●● Enhanced security features  Microsoft added a number of new features in Excel 
2007, including the Trust Center and a digital signatures interface to help secure 
documents you share with others. 

Moving onward with Office 2013
The improvements made in Microsoft Office and Excel 2013 are solid, and the release is 
significant, considering the new intelligent features and the new platforms supported, 
including Microsoft’s first computer, Surface. If you skipped the 2010 release, you’ll find 
some nice new surprises. If you skipped the 2007 release, you have a lot of catching up to 
do. Read on!
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CHAPTER 2

Exploring Excel fundamentals

Before you can get the feel of the controls, you need to know where they are and 
what they do. This chapter discusses the essential commands, controls, tools, and 
techniques you need to operate the Microsoft Excel 2013 machine.

Examining the Excel 2013 workspace
This section takes you on a tour of not only the dashboard of Excel 2010 but also the trunk 
and the glove compartment. We might even slip on some gloves and take a peek under 
the floor mats.

Facts about worksheets
Here are some tidbits of information about the grid called the worksheet, shown in 
Figure 2-1:

●● Column letters range from A through XFD. (After column Z comes column AA, after 
column ZZ comes column AAA, and so on, up to XFD.) Row numbers range from 1 
through 1,048,576.

●● The currently selected cell is referred to as the active cell. When you select a range of 
cells, only the cell in the top-left corner is considered the active cell. The reference of 
the active cell appears in the Name box on the left end of the formula bar.

●● The headings for the columns and rows containing selected cells are highlighted, 
making it easier to identify the location of selected cells.

●● With 16,000 columns and 1,048,576 rows, your worksheet contains more than 16 
billion individual cells. Before you try to unravel the mysteries of the universe on a 
single worksheet, however, remember that the number of cells you can use at one 
time is limited by the amount of memory your computer has. Although Excel allo-
cates memory only to cells containing data, you might have trouble actually using all 
the cells on one worksheet, no matter how much memory you have.
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Figure 2-1  There is a huge amount of available space on a worksheet.

The porthole window
The workbook window is like a porthole through which you can see only a portion of a 
worksheet. To illustrate, suppose you were to cut a small, square hole in a piece of card-
board and place the cardboard over this page. At any given time, you could see only 
a portion of the page through the hole. By moving the cardboard around the page, 
however, you could eventually read the entire page through the window in your piece 
of cardboard. Viewing worksheets in Excel is much the same. You can also open another 
window to view different sections of the same worksheet simultaneously.

Using the workbook window
A new workbook, shown in Figure 2-2, originally consists of a single worksheet; you click 
the New Sheet button to add more sheets. This is a change from previous versions, in which 
new workbooks contained multiple sheets. 
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Figure 2-2  Workbooks initially comprise a single sheet, but you can add as many as you need.

For more information about using workbooks, see Chapter 7, “How to work a workbook.”

Workbooks are great organizational tools. For example, you can keep in the same work-
book all the documents that relate to a specific project, department, or individual. 
Workbooks can eliminate a considerable amount of clutter on your hard disk. The more 
documents you have to manage, the more valuable workbooks become. You can use 
workbooks as a multiuser management tool. For example, you can organize worksheets in 
groups for individual tasks or individual users. You can also share a workbook so that more 
than one person can work on it at the same time.

If you routinely create folders on your hard disk to contain groups of related files, you can 
think of workbooks as folders where you can keep all related worksheets.

For more information about using and sharing workbooks, see Chapter 26, “Collaborating on 
a network or by email.” 
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Getting around in the workbook

At the bottom of the workbook window are controls you can use to move from sheet to 
sheet in a workbook. Just click any sheet tab to activate it, but if there are too many tabs 
to fit across your screen at once, sheet-navigation controls appear to help you get around, 
as shown in Figure 2-3. Note that the More Sheets (ellipsis …) buttons will not appear until 
there are too many sheets to display at once. 

            More Sheets
        Scroll Right
   Scroll Left

         Tab split handle
     New Sheet
More Sheets

Figure 2-3  Use the workbook navigational controls to move among undisplayed worksheets. 

If you have a wheel mouse
If you have one, you can use the wheel on your Microsoft IntelliMouse (and most other 
wheeled pointing devices) to scroll through your worksheet. Turn the wheel toward 
you to scroll down or away from you to scroll up. To scroll left or right (called panning), 
press the wheel button, and drag the mouse in the direction you want to move. A gray 
four-headed arrow appears, anchored to the spot where you pressed the wheel but-
ton. The speed of panning depends on how far you drag away from the anchor. As you 
press the button down and drag, a black arrow appears, pointing in the direction you’re 
dragging: 

You can change the default behavior of the wheel from scrolling to zooming. To do 
so, click the File tab and then click Options. In the Advanced category, below Editing 
Options, select the Zoom On Roll With IntelliMouse check box. For more information, 
see “Zooming worksheets” in Chapter 6, “How to work a worksheet.”
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Workbook navigation tips

Many features and controls can help you navigate through the rows, columns, and work-
sheets in a workbook. Here are the highlights:

●● Use the sheet tab navigation buttons to view all the sheet tabs in your workbook; 
click a tab to view the contents of that worksheet.

●● Drag the tab split handle to the right if you want to see more sheet tabs at the 
expense of the horizontal scroll bar’s width. To return to the usual tab display, 
double-click the tab split handle.

●● Press Ctrl+Page Down to activate the next worksheet in the workbook; press 
Ctrl+Page Up to activate the previous worksheet.

●● Press Ctrl+Home to jump to cell A1 from anywhere on a worksheet.

●● Right-click any scroll bar to display a shortcut menu dedicated to scrolling actions, as 
shown in Figure 2-4.

Figure 2-4  Right-click a scroll bar to display a shortcut menu of navigational commands.

●● Drag the scroll box (also known as the scroll thumb) to move around the worksheet. 
Click the scroll bar anywhere outside the scroll box to move one screen at a time in 
the direction in which you clicked.

●● The size of the scroll box changes depending on the size of the scrollable area. For 
example, the scroll boxes shown in Figure 2-4 are more than half as large as the 
scroll bars themselves, indicating there is little more to see in the active area of the 
worksheet—nothing, in fact, because this is a blank worksheet. As you add data to 
more columns and rows than can appear on a single screen, the scroll boxes get 
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proportionally smaller, giving you immediate feedback about the size of the work-
sheet. A tiny scroll thumb indicates a huge worksheet.

●● Using the scroll arrows at either end of the scroll bars, you can move through the 
worksheet one column or row at a time.

●● The Name box at the left end of the formula bar always displays the active cell refer-
ence, regardless of where you scroll the window.

●● To scroll the worksheet without changing the active cell, press Scroll Lock. For exam-
ple, to scroll to the right one full screen without moving the active cell, press Scroll 
Lock and then press Ctrl+Right Arrow.

Note
The active area of a worksheet is simply the rectangular area that encompasses all the 
data the worksheet contains. So, if you have just three rows and columns of actual data 
in the top-left corner of the worksheet, the active area would be A1:C3. If, on the same 
worksheet, a stray character (even a space) happens to be in cell AB1299, the active 
area would be A1:AB1299. On a new blank worksheet, however, Excel considers the 
default active area to be roughly what you can see on the screen, even before you enter 
any data.

Working with workbook windows

In Excel 2013, workbook windows behave differently than in any previous version. Previ-
ously, there was one Excel window that contained all open worksheets, which appeared as 
separate windows within the Excel workspace. (Even the term “workspace” has been retired 
for 2013.) Each workbook appears as a separate instance of Excel in the 2013 version. If you 
have three workbooks open, there will be three windows, each with a complete Excel inter-
face, including ribbon tabs, a formula bar, a status bar, and other such items. 

So workbook windows now behave like any other windows in Windows. At the right end 
of each title bar are the familiar Minimize, Maximize/Restore, and Close buttons. After you 
maximize a window, a button with two small boxes—the Restore button—takes the place 
of the Maximize button. Clicking the Restore button changes the maximized window into a 
floating window.
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INSIDE OUT �  See more rows on your screen

You can set the Windows taskbar at the bottom of the screen to automatically hide 
itself when not in use. Right-click the taskbar to display the shortcut menu, click the 
Properties command, and on the Taskbar tab of the Taskbar Properties dialog box select 
the Auto-Hide The Taskbar check box and then click OK. Now the taskbar stays hidden 
and opens only when you move the pointer to the bottom of the screen.

When you click the Minimize button (the one with a small line at the bottom), the window 
collapses and is relegated to an icon in the Windows taskbar, which you can click at any 
time to restore the window to its previous configuration. You can also drag the borders of 
any window to control its size. 

Because you can open multiple windows for the same workbook, you might find it con-
venient to view different parts of the workbook, or even different parts of an individual 
worksheet, side by side in separate windows, rather than switching between worksheets or 
scrolling back and forth in one large window.

For more information, see “Opening multiple windows for the same workbook” in Chapter 7.

INSIDE OUT �  Microsoft and the SDI

What is SDI? The single document interface (SDI) initiative that Microsoft implemented 
in its Office programs several versions ago was only an option in Excel 2010, but now…
it’s the law! Prior to SDI, regardless of the number of documents you had open, the 
applications were individual; if you had three Excel workbooks open, only one instance 
of Excel was visible in the Windows taskbar. 

Microsoft’s SDI initiative now dictates that each document now generates its own win-
dow, each of which becomes a separate item on the Windows taskbar. Open three Excel 
workbooks, and three items appear on the taskbar. This is arguably a more realistic way 
to handle documents, which is why Microsoft did it in the first place. Multiple-monitor 
users rejoice! 

So in 2013, multiple document interface (MDI) is no more; long live the SDI. By the 
way, you won’t see these terms used very much—for good reason: “multiple” DI creates 
a single window, and “single” DI creates multiple windows. Geek double-speak! 
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Exploring the ribbon
After you get the raw data into Excel by whatever means, you’ll spend a lot of time using 
the ribbon to massage and beautify your data. The ribbon was introduced in Microsoft 
Office 2007 and was one of the most sweeping user interface (UI) changes ever imple-
mented, redefining the workflow in every Office program. By this time—the third genera-
tion of the ribbon—the dust has settled, and even grumpy, old Excel users have come to 
terms with it. Figure 2-5 shows the ribbon at rest.

Figure 2-5  The ribbon dominates the top of the Excel window.

Does your ribbon look different?
The screen images shown in this book were captured at the screen resolution, magni-
fication, and text size that is optimum for publication purposes. The ribbon on your 
screen might not look the same as the one shown in the book. For example, you might 
see more or fewer buttons in each of the groups, the buttons you see might be repre-
sented by larger or smaller icons than those shown, or the group might be represented 
by a single button that you click to display the group’s commands. 

The ribbon comprises a number of tabs, each containing several ribbon groups, which in 
turn contain sets of related controls: commands, buttons, menus, galleries, and dialog box 
launchers. The hierarchy within and among ribbon tabs is designed to approximate a gen-
eral workflow model, with the most-often-used features and options stacked more or less 
from left to right within and among tabs. For example, the Home tab contains commands 
you need when you create a new worksheet and start performing tasks such as cutting 
and pasting, formatting, and sorting, while the Review tab contains commands related to 
documents that are more or less complete, addressing issues such as verifying spelling and 
protecting the document.

Note
The 2007 version of the ribbon was not customizable; thankfully, this was remedied in 
Excel 2010 and continues to be customizable in 2013. Die-hard toolbar-modification 
aficionados such as your friendly Excel book authors were thrilled. This is explored 
in detail in “Customizing the ribbon” in Chapter 3, “Custom-tailoring the Excel 
workspace.” 
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The ribbon speaks

For years now, many of us in the computer-book-writing business have been anticipat-
ing early retirement due to the expected advent of stunningly simple user interfaces and 
the holy grail of “self-documenting” software. In reality, this goal has proven as elusive as 
the “paperless office,” so we’ve kept pretty busy. But Office 2013 represents another fine 
attempt at rendering our jobs obsolete. You can gain helpful information about your imme-
diate surroundings simply by brandishing your pointer. For example, the left side of Figure 
2-6 shows the ScreenTip that opens when you rest the pointer anywhere in the Number 
Format drop-down list. The right side of Figure 2-6 shows what happens when you click the 
Number Format drop-down list. 

The icons representing the various options in the Number Format drop-down list shown in 
Figure 2-6 are another step in the right documentation direction, although further explora-
tion might be required to discover the meaning of items such as the cryptic “12” icon for 
the Number format. (See “Using Accounting formats” in Chapter 9, “Worksheet formatting 
techniques.”) And, as always, you can press F1 at any time to open the Excel Help window 
and gain additional insight.

Figure 2-6  Rest your pointer on an object on the ribbon to display an explanatory ScreenTip. 
Click any arrow on the ribbon to display a menu, list, or gallery of options.
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Note
If you need to maximize your worksheet area, you can temporarily hide the ribbon by 
double-clicking the active tab. Once it is hidden, clicking any tab puts the ribbon back 
into view.

Drop-down lists and dialog box launchers

The Number group on the Home tab, shown in Figure 2-6, contains the aforementioned 
Number Format drop-down list, four regular buttons, and a menu button (the $ sign), 
which acts like any other button when you click the button proper, but when you click the 
arrow next to it, it displays a drop-down list of alternate actions for that button. Anytime 
you see an arrow directly to the right of a button or a box on the ribbon, clicking the arrow 
reveals more options. (Just to confuse the issue a bit, the Increase Font Size and Decrease 
Font Size buttons in the Font group display arrows that are identical to the menu arrows 
but are actually part of the button images and don’t invoke drop-down lists.)

Many groups display a tiny button in the bottom-right corner called a dialog box launcher 
(labeled for your convenience in Figure 2-2). This is a visual cue telling you there is more 
you can do there. When you rest the pointer on a dialog box launcher, a ScreenTip opens 
with details about its function; click the dialog box launcher to display the promised result, 
as shown in Figure 2-7. 

INSIDE OUT �  Just pin it

Whether you have Windows 7 or Windows 8, Excel lives in similar surroundings. In 
Windows 8, Excel runs on the desktop, which is similar to Windows 7, but without a 
Start button. This means that there is no Start menu with programs pinned to it, and no 
All Programs menu, either. If you are on the Windows 8 Start screen, click the Excel tile, 
which activates the desktop and starts Excel. But if you’re on the desktop, you have to 
go back to the Start screen to start Excel. Or you can pin it to the taskbar. The taskbar is 
standard equipment in both Windows versions. On the Windows 8 Start screen, right-
click the Excel tile, and then click the Pin To Taskbar icon. In Windows 7, right-click the 
Excel icon and click the Pin To Taskbar command.
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Figure 2-7  Rest the pointer on a dialog box launcher for an explanation of its function; click it to 
open the corresponding dialog box.

Sometimes dialog box launchers actually launch dialog boxes, as shown in Figure 2-7; other 
times, clicking the dialog box launcher displays a task pane on the side of the window, as 
shown in Figure 2-8. In the latter case, the dialog box launcher acts as a toggle—that is, 
clicking it opens the task pane, and clicking it again closes the task pane.

Another way to access advanced options relegated to dialog boxes is to look for commands 
sporting an ellipsis (…) at the bottom of menus and galleries. For example, at the bottom of 
the Number Format drop-down list shown in Figure 2-6 is a command called More Num-
ber Formats. Just as you can with the dialog box launcher, you can click this command to 
display the Format Cells dialog box. As was the case in previous versions of Excel, an ellipsis 
adjacent to the name of a command indicates that clicking that command displays a dialog 
box with additional options rather than immediately issuing the command. 
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Figure 2-8  Clicking some dialog box launchers causes a task pane to open, docked to the left or 
the right of the worksheet.

Galleries and live preview

The concept of galleries goes way back. The idea is to provide a visual clue about what’s 
going to happen when you click something, besides just the name of a command or but-
ton. Microsoft has done this with fonts for some time now. When you click the Font menu 
or drop-down list, each font name appears in its own font. Excel 2013 includes a bunch of 
other galleries that provide similar visuals and adds nifty functionality called live preview. 
Taking the same example one step further, Figure 2-9 shows the Font drop-down list dis-
playing the available fonts in situ. With live preview, you simply rest the pointer on the 
font name to momentarily cause selected cells to display that font. (In the figure, the entire 
worksheet is selected.) Helpfully, the selection highlight temporarily disappears while you 
are previewing fonts. 

As you can see in Figure 2-9, Berlin Sans FB Demi is perhaps a questionable choice for a 
table of sales totals, but it’s easy to get a look at a lot of options this way. And helpfully, 
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although you need to select the cells you want to format, the selection highlight goes away 
temporarily while you are live-previewing. The cell contents are not affected; this is simply 
a way to visualize what would happen if you actually commit by clicking. Have some fun 
by dragging the pointer up and down the list of fonts, and watch the cell contents change 
almost as fast as you can drag.

Figure 2-9  Not only are font names displayed in their respective fonts in the drop-down list, but 
simply resting the pointer on a font name temporarily displays that font in selected cells. (All cells 
are selected here.)

Note
Not all of the seemingly gallery-like items on the ribbon exhibit live preview behavior. 
For example, you might think the Number Format drop-down list would be an excel-
lent application of live preview, but it doesn’t work that way. As we explain features in 
detail throughout the book, we’ll point out any live preview opportunities.
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The omnipotent Excel Options dialog box
The dialog box that opens when you click the File tab and then click Options is prob-
ably the most important dialog box in Excel. The Excel Options dialog box controls 
nearly every aspect of Excel, including general settings such as how many sheets 
appear in a default workbook and the name and point size of the default font:

You’ll see little i (for information) icons adjacent to many of the items shown in the 
dialog box; rest the pointer on them to display ScreenTips. The Excel Options dialog 
box also provides special settings for default file-saving formats, worksheet-level and 
workbook-level display settings, and many other hard-to-classify options. If you take a 
moment to click each category on the left side of the dialog box and look through the 
options available, you’ll get an idea of the scope of the program as well as the degree 
of control you have over your workspace. If you’re unsure about what a particular set-
ting or option does, simply click the Help button (the question mark icon) in the title 
bar of the dialog box to open the Help system.
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Understanding contextual tool sets

Microsoft has been dancing with context sensitivity for several releases now. In Office 2000, 
Excel shipped with default “learning” menus and toolbars that modified themselves based 
on usage patterns, which turned out to be somewhat unpopular because commands would 
tend to “disappear” with lack of use. Some of this functionality carried through to Excel 
2003, with a somewhat better implementation. Since the 2007 release, context sensitivity is 
smarter and, best of all, does not take little-used items away like the previous approaches—
in fact, the ribbon and its normal contents remain steadfast, while additional context-
triggered tools appear on ribbon tabs that are displayed only when needed. Figure 2-10 
shows what happens when you click a chart object.

Figure 2-10  When you select an object, tabs appear containing tools that apply only to that 
object. Here, two tabs of chart tools appear on the ribbon when you select a chart.

Not only do two new tabs appear on the ribbon in Figure 2-10—Design and Format—but 
a higher-level heading, entitled Chart Tools, is displayed above the new tabs. Headings like 
this appear over sets of contextually triggered tabs to define their overall function. Chart 
objects are complex enough that clicking one triggers several tabs’ worth of contextual 
tools; other objects might generate only one tab. This functionality helps reduce clutter in 
the interface, taking groups of task-specific tools out of the way until you need them.
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Using the Quick Access Toolbar
It’s hard not to think of the ribbon as a toolbar, especially if you skipped a couple of 
upgrades. The ribbon is not a toolbar according to Microsoft, and only one “real” toolbar 
is left. It’s at the top of the screen, and it’s called the Quick Access Toolbar, as shown in 
Figure 2-11.

Figure 2-11  The Quick Access Toolbar sits atop the Excel workspace unless you move it under 
the ribbon.

Note
To suit your work style, you can add buttons and even entire ribbon groups to the 
Quick Access Toolbar. For more information, see “Customizing the Quick Access Tool-
bar” in Chapter 3.

The Quick Access Toolbar is pretty much like toolbars as you knew them, with a few excep-
tions. You can dock it in only two locations—either above or below the ribbon—unlike 
previous toolbars that could “float” over the worksheet or be docked at the top, bottom, or 
sides of the screen. And you cannot close or hide the Quick Access Toolbar. 

INSIDE OUT �  Toolbar and ribbon customization

Some of us have spent a lot of time modifying the UI of pre-2007 versions of Excel 
by changing and adding toolbars and menus. Since Excel 2007, there has been only 
one toolbar, and you cannot create new ones. Perhaps not surprisingly, 98 percent of 
the Excel-using public will not miss this functionality. (This statistic was gleaned from 
usability surveys.) Those of us in the other 2 percent can customize the Quick Access 
Toolbar, and since 2007, we have been able to tweak the ribbon as well. Hooray! See 
“Customizing the Quick Access Toolbar” in Chapter 3 for more information.
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Accessing commands with the keyboard
When you press the Alt key, Excel activates keyboard command mode and displays little 
pop-up labels adjacent to each tab and toolbar button, as shown at the top of Figure 2-12.

Figure 2-12  Press the Alt key to activate keyboard command mode and display pop-up labels 
showing you the keys you can press to activate the respective tab, button, or command.

For example, after you press the Alt key to activate the pop-up labels, you can press the 
N key to display the Insert tab and add pop-up labels to the commands it contains. Then, 
press the H key—the pop-up letter adjacent to the Hyperlink button—to display the Insert 
Hyperlink dialog box, as shown in Figure 2-12. So, instead of reaching for the mouse, simply 
pressing Alt, N, H gets you there. This makes for extremely fast command access after you 
learn the right keys for tasks you do often.
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Keyboard command activation options
You can use the slash (/) key just like the Alt key to access the Excel command structure. 
But you can alternatively set a different key to activate menus. Click the File tab, click 
Options, select the Advanced category, scroll way down to the Lotus Compatibility 
options, and then type a different character in the Microsoft Excel Menu Key text box.

The joy of shortcut menus
Shortcut menus contain only those commands that apply to the item indicated by the posi-
tion of the pointer when you activate the menu. Shortcut menus provide a handy way to 
access the commands most likely to be useful at the pointer’s location and to help mini-
mize mouse movements (which are hard on wrists!).

To access a shortcut menu, right-click. The menu opens adjacent to the pointer, as shown in 
Figure 2-13.

Figure 2-13  Right-clicking almost anywhere displays a shortcut menu with pertinent commands.
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Shortcut menus can contain many combinations of commands, depending on the position 
of the pointer and the type of worksheet. For example, if you display a shortcut menu when 
the pointer is on a cell rather than a column heading, some of the commands change to 
ones specific to cells rather than columns. 

Belly up to the mini-bar
A small floating toolbar opens along with the shortcut menu whenever the selected 
object might contain any kind of text, as you can see in Figure 2-13. You can control 
whether the Mini toolbar appears by using the Excel Options dialog box. Click the File 
tab, and click Options. Then, in the General category, select or clear the Show Mini 
Toolbar On Selection check box.

Using the Quick Analysis tool
The top 2013 addition to the Excel cavalcade of context-sensitivity is the Quick Analysis 
tool, which pops up in the lower-right corner of the selected range any time you select 
more than one non-empty cell. The Quick Analysis tool takes some of the most sophisti-
cated features of Excel and puts them right near the action. One reason this is helpful is 
that, often, menus and palettes on the ribbon drop down and obscure the cells you are 
trying to format. Putting the Quick Analysis tool in the lower-right corner of the range 
allows you to position the selection on the screen so that you can see more of the cells you 
are modifying. For example, in Figure 2-14, we selected the totals in cells B4:E15, scrolled 
the worksheet down a bit to allow room below the table, and clicked the Quick Analysis 
tool. Resting the mouse pointer over any icon displays a live preview.

The Quick Analysis tool is like a mini-ribbon; across the top are categories (tabs) you click 
to reveal different sets of icons. The type of data you select determines the tools that 
are active and available for application. You can use the Quick Analysis tool to apply and 
remove formatting, insert formulas and tables, create charts and PivotTables, and more. 
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Figure 2-14  Click the Quick Analysis tool to display a context-sensitive “ribbon” with “tabs” 
containing appropriate actions you can apply to the selected cells.

Meet the formula bar
Worksheet cells are the building blocks of Excel. They store and display the information 
you enter on an Excel worksheet so that you can perform worksheet calculations. You can 
enter information directly in a cell, or you can enter information through the formula bar, 
as shown in Figure 2-15.

The contents of the active cell appear in the formula bar, and the address of the active cell 
appears in the Name box at the left end of the formula bar. The formula bar split handle 
and the Insert Function button are always available, but the other two formula-editing but-
tons are active only while you are entering or editing data in a cell, as shown in Figure 2-15. 
Click the Cancel button to cancel the current action in the cell, which is the same as press-
ing the Esc key. Click the Enter button to consummate the current action in the cell, which 
is the same as pressing the Enter key. 
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Name box
          Formula bar split handle

Cancel      Enter         Insert Function

Figure 2-15  The formula bar displays the contents of the active cell.

Note
When you press Enter, Excel finishes the action in the active cell and moves the selec-
tion down one cell. You can change this behavior by clicking the File tab, clicking 
Options, and clicking the Advanced category. If you clear the After Pressing Enter, 
Move Selection check box, the active cell does not change after you press Enter. Or 
leave the option selected and choose a different direction (Up, Right, or Left) from the 
drop-down list.

You can drag the formula bar split handle to the left to make more room for formulas, or 
to the right to increase the size of the Name box; double-click it to return to the default 
position. Clicking the Insert Function button displays a dialog box that helps you construct 
formulas. For information about creating formulas and using the Insert Function dialog box, 
see Chapter 12, “Building formulas.”

Note
By default, Excel displays the formula bar in your workspace. If you prefer to hide the 
formula bar, click the View tab and clear the Formula Bar check box in the Show group. 
To redisplay the formula bar, simply reverse this process.
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Excel allows you to expand and contract the formula bar to display or hide long formulas. 
The formula bar split handle helps a bit, but for really long formulas the formula bar is ver-
tically expandable, as shown in Figure 2-16. 

When you select a cell containing a long formula, you see only part of the formula in the 
formula bar. If there is more of the formula to be seen, Excel displays a set of up and down 
arrows at the right end of the formula bar that you can use to scroll through the formula 
one line at a time. At the far right end of the formula bar is the Expand Formula Bar button 
(down arrow), which when clicked expands the formula bar as shown in Figure 2-16. If you 
need to see more, drag the bottom border of the formula bar as far as you need to. (This 
particular 100-cell formula is good for illustrating the expanding formula bar, but failure to 
use the SUM function in this situation might get you drummed out of the Sensible Formu-
las Guild.) The next time you click the Expand Formula Bar arrow, the bar expands to the 
last size you specified. 

Figure 2-16  The formula bar expands and contracts to show or hide long formulas.

To return the formula bar to its regular size, click the Collapse Formula Bar button. (The 
Expand Formula Bar button changes its name when the formula bar is expanded.) Note 
that in the bottom screen shot in Figure 2-16, the pointer turns into a double-headed 
arrow when you position it over the lower border of the formula bar. You can also drag this 
border to expand the formula bar.
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Note
Functions are the Clydesdales of Excel—they do most of the heavy work. To learn all 
about them, see Chapter 13, “Using functions.”

Facts about the status bar
The status bar, located at the bottom of the Excel window, displays information about 
what’s happening in your workspace. For example, most of the time, Excel displays the word 
Ready at the left end of the status bar. When you type, the status bar displays the word 
Enter; when you double-click a cell that contains data, the status bar displays the word Edit.

Several items appear at the right end of the status bar: a few buttons, a slider, and a dis-
play area for various purposes—including summary information, keyboard modes, page 
numbers, and much more—any of which you can turn on or off. Right-click the status bar 
anywhere to show the Customize Status Bar shortcut menu filled with options, as shown in 
Figure 2-17.

         Record Macro                                                              Normal view
   Mode indicator                                                                Page Layout view
                                                                                             Page Break Preview

Zoom controls

Figure 2-17  You have numerous options for displaying information on the status bar.
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All the commands on the Customize Status Bar menu with check marks adjacent to them 
are turned on by default. Most of the commands on this menu control the display of dif-
ferent types of information, depending on what is selected. Cell Mode refers to the afore-
mentioned Ready/Enter/Edit indicators when working in cells. The icon that looks like a 
worksheet with a dot, shown in Figure 2-17 on the left side of the status bar, is a record 
button for macros. The Macro Recording command controls its display. (If any macros are 
available, a Play arrow appears next to the icon, the display of which is controlled by the 
Macro Playback command.) The last three commands on the menu control the display of 
items on the right end of the status bar. View Shortcuts turns on or off the display of the 
three buttons (Normal View, Page Layout View, and Page Break Preview) visible next to the 
Zoom percentage and the Zoom slider, which also have corresponding commands control-
ling their display. Drag the Zoom slider to change the percentage, or click the percentage 
indicator to display the Zoom dialog box for more precision.

For more information about keyboard modes, see “Navigating regions with the keyboard” in 
Chapter 6. For more about views, see Chapter 11, “Printing and presenting.” For more about 
macros, see Chapter 28, “Recording macros.”

Quick totals on the status bar
When you select two or more cells that contain values, Excel displays summary infor-
mation using those values on the status bar:

This is the AutoCalculate feature. The status bar normally displays the sum and average 
of the selected values, as well as the number of cells selected that contain any kind of 
data (blank cells are ignored). As you can see in Figure 2-17, additional AutoCalculate 
options are available, including Minimum and Maximum values in selected cells and 
Numerical Count, which counts only cells containing numbers and ignores cells con-
taining text. 
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Introducing Backstage view
At first, when you begin working with one of the “ribbon versions” of Excel (starting with 
Excel 2007), it looks like the old menus are still there across the top of the screen—until 
you start clicking and you see that no menus are dropping down. Even more interesting 
if you have been using Excel 2007 is that the File menu, which had been removed, came 
back in Excel 2010 (and remains in 2013) as a tab, and the Office Button, which was where 
the File menu used to be, is gone. Now, when you click the File tab, what you see is not so 
much a menu or a dialog box, but a screen full of information and options that Microsoft 
calls Backstage view. Here you can find the familiar File menu commands, and Backstage 
view also serves as the access point for most of Excel’s “behind-the-scenes” commands and 
settings. 

Clicking the File tab on the ribbon reveals the default Info screen in Backstage view, as 
shown in Figure 2-18. 

Figure 2-18  Click the File tab to open Backstage view, which includes the old File menu 
commands; click the arrow button in the upper-left corner to return to the worksheet.

As you can see, many of the old File menu commands are still here as clickable items on the 
left side of the screen, and the right side of the screen provides additional clickable items. 
Clicking Info, New, Open, Save As, Print, Share, Export, or Account controls the content 



Chapter 2

40	 Chapter 2  Exploring Excel fundamentals

visible on the right side of the screen, which offers pertinent options and commands. Click-
ing Save, Open, Close, or Options launches a separate dialog box. 

You can use the new Account command to change settings for your Microsoft account, 
including connected services such as SkyDrive, and to select a common theme. There is also 
a Background menu you can use to personalize the appearance of your Office programs 
using selected designs that appear in the title bar area.

You’ll be seeing more of Backstage view and all of its “children” throughout this book. 

Exploring file-management fundamentals
One of the advantages of working with computers is the convenience of electronic files. In 
this section, we describe both the usual and unusual ways you can manage your Excel files.

Creating workbooks
To create a new workbook, click the File tab and then click New to display the screen shown 
in Figure 2-19. Click the arrow at the top left of the New screen at any time to return to the 
worksheet. Click Blank Workbook, and a fresh workbook opens. Each new blank workbook 
you create during the current Excel session is numbered sequentially: Book1, Book2, and 
so on.

Excel 2013 offers a staggering array of sophisticated templates representing hundreds of 
hours of thought and effort, and revealing the potential of Excel. There are a lot of helpful 
templates you can use right away. And if you ever need some inspiration, open a template 
you find interesting and examine it to see how it was constructed. There is a lot to learn just 
by looking. Templates are continually added to the online inventory, so be sure to use the 
search box to see what’s new and available on the web. Suggested Searches are clickable 
links that display categories of available templates gleaned from the Microsoft website at 
the moment. 

Excel is more web connected than ever. Some templates are installed on your system, but 
most are in the cloud. This not only saves space for you, but also makes it possible to offer 
more templates, more complex templates, and a constant source of new templates. Keep-
ing templates in the cloud also makes it easy for developers to fix problems and make 
enhancements. Figure 2-19 shows the nifty templates available with an Internet connec-
tion. Figure 2-20 shows the search box disabled and the selection of relatively Spartan (but 
equally useful) templates that are available when your computer is offline.
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Figure 2-19  Click the File tab and then click New to display a selection of available templates, 
both installed and online.

Figure 2-20  The selection of available templates narrows considerably when no Internet 
connection is available.
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Installing your own templates

Creating your own templates is a great idea for worksheets you use a lot. The steps 
involved are a little different in Excel 2013 than in previous versions. First, organize and 
format a workbook the way you want (minus the data). Then when you’re ready to save the 
template, click the File tab, click Save As, click Computer, and then click Browse to display 
the Save As dialog box. Click the Save As Type box and select Excel Template (*.xltx) from 
the list, and the destination folder immediately changes to the Custom Office Templates 
folder, as shown in Figure 2-21. 

Figure 2-21  Choosing the Excel Template file type activates the Custom Office Templates folder.

When you click the Save button, your new template is installed. You can find this folder in 
the following locations:

●● Windows XP  C:\Documents and Settings\<your name>\Application Data\
Microsoft\Custom Office Templates

●● Windows 7 or Windows Vista  C:\Users\<your name>\AppData\Roaming\
Microsoft\Custom Office Templates

●● Windows 8  C:\Users\<your name>\My Documents\Custom Office Templates

Templates in this folder appear on the New screen in the Personal category, as shown in 
Figure 2-22. The two categories, Featured and Personal, appear only after you save a tem-
plate for the first time. 
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Figure 2-22  When you save a template, two new categories appear on the New screen, Featured 
and Personal; in this figure, the Personal category is active.

INSIDE OUT �  Hidden Windows folders revealed

You probably have to change a Windows setting to find the AppData folder (Applica-
tion Data in Windows XP) because it is normally hidden. To reveal it, navigate to the 
folder that bears your name in File Explorer (or Windows Explorer in Windows 7, Win-
dows Vista, or WIndows XP), as shown in the previous paths. Then, in Windows 8, click 
the View tab and select the Hidden Items option in the Show/Hide group. In Windows 
7, click the Organize menu (the Tools menu in Windows XP), click Folder And Search 
Options, and on the View tab, select Show Hidden Files And Folders. Note that <your 
name> is the user name you use when logging on to Windows.



Chapter 2

44	 Chapter 2  Exploring Excel fundamentals

Saving files
Arguably, the most important function of any computer application is preserving data. In 
Excel, you can save your files in many ways, including by clicking the Save, Save As, Share, 
or Export command. You can also click the Close command or click the Windows Close but-
ton (X) and you’ll be prompted to save, if you have made any changes. The easiest way to 
save is either by clicking the Save button on the Quick Access Toolbar or by pressing Ctrl+S 
on the keyboard.

One other command that saves your workbooks is the Share Workbook command in the 
Changes group on the Review tab. When you click this command, you save your workbook 
in shared mode. Besides saving the file, this command makes the workbook available to 
others on a network, who can then open it and make changes of their own.

For more information, see “Sharing workbooks on a network” in Chapter 26.

The first time you save a file, the Save As screen appears in Backstage view, as shown in Fig-
ure 2-23.

Figure 2-23  The Save As screen appears when you save a file for the first time.
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Note
If you use the same folder most of the time, you can specify that folder as the default 
location that the Open, Save, and Save As dialog boxes use when you first open them. 
Click the File tab, click Options, select the Save category, and type the full path and file 
name for the folder you want to use in the Default Local File Location text box.

The Save As screen offers another set of choices, including SkyDrive and your computer. 
The most recent folders used in the location selected on the left are shown on the right. If 
the one you want is not listed, click the Browse button, which displays the Save As dialog 
box, as shown in Figure 2-24.

Figure 2-24  When you select a destination or click Browse, the Save As dialog box appears, 
which you can use to specify a date or date range, if desired.

The Save As dialog box (along with other dialog boxes that are provided by the operating 
system, including Save and Open) has a sophisticated file interface that includes a number 
of useful features, such as the ability to find files by using a date range you specify using 
a calendar, as shown in Figure 2-24. For details, click the Help button (the question mark 
icon) in the Save As dialog box to display the corresponding Windows Help file.
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Rules for file naming

File names in Excel can have up to 218 characters. They can include any combination of 
alphanumeric characters, spaces, and special characters, with the exception of the forward 
slash (/), backslash (\), greater-than sign (>), less-than sign (<), asterisk (*), question mark 
(?), quotation mark ("), pipe symbol (|), colon (:), and semicolon (;). Although you can use 
any combination of uppercase and lowercase letters, keep in mind that Excel does not dis-
tinguish case in file names. For example, to Excel the names MYFILE, MyFile, and myfile are 
identical.

The old familiar MS-DOS-style file name extensions (which are usually four characters these 
days, not three) help identify your Excel files, and they are added automatically when you 
save a file. Table 2-1 lists Excel extensions in the order in which they appear in the Save As 
dialog box’s Save As Type list.

TABLE 2-1  The Excel file extensions

Document type Extension

Excel Workbook .xlsx
Excel Macro-Enabled Workbook .xlsm
Excel Binary Workbook .xlsb
Excel 97-2003 Workbook .xls
XML Data .xml
Excel Template .xltx
Excel Macro-Enabled Template .xltm
Excel 97-2003 Template .xlt
XML Spreadsheet 2003 .xml
Microsoft Excel 5.0/95 Workbook .xls
Excel Add-In .xlam
Excel 97-2003 Add-In .xlm
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INSIDE OUT �  Hidden file name extensions revealed

File name extensions might not appear with Windows file names, depending on your 
settings. To display file name extensions in Windows 8, click the File Explorer, click the 
View tab, and select the File Name Extensions option. In Windows 7, click the Start 
button, click Computer (Control Panel in Windows XP), click the Organize menu, select 
Folder And Search Options and on the View tab, and then scroll down and clear the 
Hide Extensions For Known File Types check box. 

File formats

In addition to providing the file name and location, you can specify a different file format in 
the Save As dialog box. Click the Save As Type drop-down list, which expands to reveal all 
the formats in which you can save your files.

The default format is Excel Workbook (*.xlsx), and you’ll almost always use this option. If 
you want to export an Excel file to another program, however, you can use one of the other 
options to convert the file to a format that is readable by that program.

For more information about the Excel export formats, see “Importing and exporting text 
files” later in this chapter.

Ensuring file compatibility with previous versions of Excel

When you open a workbook in Excel 2013 that was created in a previous version of Excel, 
it automatically opens in Compatibility mode, a condition that is indicated in the Excel title 
bar, as shown in Figure 2-25. You can always tell by looking at the title bar whether you’ve 
converted a file to the new format.

Figure 2-25  Files created by any previous version of Excel open in Compatibility mode.

You can work normally with Compatibility mode, and when you save the file, it remains in 
the old file format. If, however, you make any changes using features that are not compat-
ible with the older version, the Excel Compatibility Checker intervenes when you save and 
displays a dialog box like the one in Figure 2-26.
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The Compatibility Checker lets you know exactly what is causing the problem, so you can 
click Cancel and rework your worksheet using a different approach or save it anyway. Click-
ing the Copy To New Sheet button adds a new worksheet to the current workbook titled 
Compatibility Report, containing a copy of the information displayed in the dialog box—
sort of a compatibility paper trail. If you clear the Check Compatibility When Saving This 
Workbook check box, this dialog box no longer opens when you save the current work-
book. You might prefer this if you plan to repeatedly edit and save without updating the 
workbook to the new file format. 

Figure 2-26  The Compatibility Checker opens when you try to save an old-format workbook 
containing features not supported by the older version of Excel.

But fear not, you can always look for problems at your convenience. Click the File tab, click 
the Info command, click Inspect Workbook, and click Check Compatibility to display the 
same dialog box shown in Figure 2-26. 

INSIDE OUT �  What doesn’t work in Compatibility mode?

When Compatibility mode is on, Excel disables a number of features that produce 
results that cannot be transferred to older versions of Excel. You can still click disabled 
commands, but when you do, Excel displays a ScreenTip explaining why you can’t use 
them. For example, sparklines were introduced in Excel 2010. If you are working on a 
workbook saved as an Excel 97-2003 workbook (.xls), Excel displays a ScreenTip when 
you hover the pointer over one of the sparklines buttons:
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Here are some of the things that can trigger compatibility error messages:

●● A workbook contains too many rows, columns, or both

●● A formula exceeds the maximum allowed number of characters

●● A formula exceeds seven nested levels

●● A formula exceeds the maximum number of arguments in a function

●● A formula contains more than 40 operands

●● A workbook contains too many cross-sheet array formulas

●● A workbook has more than 4,050 unique cell formats

●● A PivotTable field has more than 32,500 unique items

●● A PivotTable item has a string length greater than 255 characters

●● A PivotTable caption has more than 255 characters

●● A PivotTable field list has more than 1,024 fields

In case you’re wondering how to get out of Compatibility mode, all you have to do is 
use the Save As command to save the workbook in one of the new file formats, such as 
XLSX or XLSM, and then close and reopen the new converted file you just saved.
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If you need to save files in other formats, the Save As Type drop-down list in the Save As 
dialog box includes a number of special formats you can select, including Excel 97-2003 
Workbook and Microsoft Excel 5.0/95 Workbook.

For more information about the newer, less-restrictive limitations of Excel, see “If you missed 
the last two upgrades” in Chapter 1, “What’s new in Microsoft Excel 2013.”

Understanding the “XL” formats

Although Microsoft trimmed some of the lesser-used file formats from the last release, the 
volume of native Excel file formats has swelled somewhat, largely due to accommodat-
ing legacy file formats—that is, file formats employed in previous versions of Excel. We’ll 
explain the major differences here:

●● Excel Workbook (XLSX)  This is the default Excel 2013 (and Excel 2010 and 2007) 
file format, which is based on XML and uses ZIP compression for reduced file size and 
increased security. Unlike the default file format in older versions of Excel (XLS), this 
format does not support VBA or XLM macro code.

●● Excel Macro-Enabled Workbook (XLSM)  Microsoft created a completely separate 
XML-based file type to be used for workbook files containing VBA or XLM macro 
code. This increases security by making it impossible to inject macro code into non-
macro-enabled workbooks and makes for easier identification of files containing 
code.

●● Excel Binary Workbook (XLSB)  This is a lean and mean file format designed for 
the fastest possible loading and saving. It supports all the features of Excel 2013 and 
also supports macro code, but it is not XML based, does not use compression, and is 
less secure than XML-based formats. 

●● Excel Template (XLTX)  This is the template version of the Excel 2013 (and Excel 
2010 and 2007) file format. This format does not support VBA or XLM macro code.

●● Excel Macro-Enabled Template (XLTM)  This is the template version of the Excel 
2013 (and Excel 2010 and 2007) file format that does allow VBA and XLM macro 
code.

●● Excel 97-2003 Workbook (XLS)  This is a legacy file format used by previous ver-
sions of Excel.

●● Microsoft Excel 5.0/95 Workbook (XLS)  This is a legacy file format used by previ-
ous versions of Excel.
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●● Excel 97-2003 Template (XLT)  This is a legacy template format used by previous 
versions of Excel.

●● Excel Add-In (XLAM)  This is a special type of VBA-enabled workbook that can be 
loaded as a supplemental program in Excel.

●● Excel 97-2003 Add-In (XLM)  This is a legacy type of VBA-enabled workbook that 
can be loaded as a supplemental program in Excel.

In addition to these “XL” file types, there are two XML file types that are somewhat related. 
XML Spreadsheet 2003 (XML) is the previous XML file format provided as an option in Excel 
2003. Another format, XML Data (XML), shares the same extension but produces entirely 
different results. This format is a proprietary XML format that requires specific program-
matic data maps to be present before you can even save the file. You’ll know if you need it.

INSIDE OUT �  What is XML?

The Excel 2013 (and Excel 2010 and 2007) file format is based on XML, which was cre-
ated as a way for structured data to be interpreted and was originally envisioned for 
use on the web. Excel 2003 introduced XML as an optional file format; Excel versions 
from 2007 through 2013 use XML as their default format, indicated by the file name 
extension .xlsx. Based on a file format specification called SpreadsheetML, Microsoft’s 
implementation of XML has undergone significant improvements since being intro-
duced. At first, the format didn’t have, shall we say, sufficient language skills to inter-
pret all of what Excel could do, including objects such as charts and graphics. Now, 
SpreadsheetML can handle everything Excel can dish out and does so in a much more 
efficient manner than the old XLS format, resulting in significantly smaller file sizes. The 
new XML formats also provide improved recovery of damaged files and better overall 
security. And because SpreadsheetML is part of an overall extensible Open XML format 
initiative, it’s easier for developers to create ways to hook things together. 

For some additional information about XML, see “Working with XML files” in Chapter 
25, “Working with external data.”
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Specifying the default file format

Usually when you save a new workbook, you save it in the Excel Workbook format (XLSX). 
You can specify a different format as the default for saving files. This might be helpful, for 
example, if you share files regularly with users of Excel 2003. To do so, click the File tab, 
click Options, and select the Save category, shown in Figure 2-27.

Figure 2-27  You can specify the default format to use when saving.

The Save Files In This Format drop-down list contains all the same file formats as the Save 
As Type drop-down list in the Save As dialog box.

Creating automatic backup files

You can have Excel create a duplicate copy of your file on the same disk and in the same 
folder as the original every time you save. Click the File tab, click Save As, click Tools at 
the bottom of the Save As dialog box, and click General Options to display the dialog box 
shown in Figure 2-28. Then select the Always Create Backup check box.
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The backup file is a duplicate file that carries the same name as your original, but the name 
is preceded by “Backup of” and has the file name extension .xlk.

Figure 2-28  To display the General Options dialog box, click the File tab, click Save As, and then 
click Tools, General Options.

Protecting files

You can password protect your files by using options in the General Options dialog box 
shown in Figure 2-28. Select from two types of passwords: Password To Open and Password 
To Modify. Passwords can have up to 15 characters, and capitalization matters. Thus, if you 
assign the password Secret to a file, you can’t reopen that file by typing SECRET or secret. 

●● Password To Open  Excel prompts you to supply the password before reopening 
the file.

●● Password To Modify  Anyone can look at the file, but they need the password to 
edit it.

●● Read-Only Recommended  This politely suggests that the user open the file as 
read-only.
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INSIDE OUT �  Create a better password

Although Microsoft has tightened the under-the-hood security measures of Excel over 
the years, some people delight in finding new and better ways to crack passwords. You 
can help by simply building better passwords. Make sure your password is eight or 
more characters long—the longer, the better—and try to use a healthy mix of upper-
case and lowercase alphanumeric characters and nonalphanumeric characters. Never 
use birthdays, anniversaries, or the names of your children or pets as passwords.

Adding summary information to files

When you click the File tab, the Info screen that first appears includes a short list of prop-
erties on the right. The Properties heading is a button; click it and a menu appears. Click 
Show Document Panel to display the Document Properties panel, which appears below the 
ribbon, as shown in Figure 2-29. Use this to record general information about the active 
workbook. If you juggle a lot of files, getting into the habit of adding properties can make 
it a lot easier to find something later. Windows looks at these property values when you use 
the Search command to locate files on your computer.

You can quickly view properties for the active workbook by clicking the File tab and looking 
on the right side of the Info screen. Several properties are displayed there. Click Properties, 
and then click Advanced Properties to display the Properties dialog box, as shown in Figure 
2-30. Most of the information visible on the Document Properties panel is available and 
editable on the Summary tab.
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Figure 2-29  Use the Document Properties panel to add descriptive information you can use 
later when looking for that needle in a file stack.

Figure 2-30  View properties about any file before you open it.



Chapter 2

56	 Chapter 2  Exploring Excel fundamentals

Linking custom properties to cells
You can link your own custom-built properties to named cells on your worksheet. 
When you do, the value of the custom property becomes whatever the named cell 
contains and changes whenever the value in the cell changes. First you must name a 
cell. (See “Rules for naming” in Chapter 12.) Then click the File tab, click Properties, and 
then click Advanced Properties. On the Custom tab in the Properties dialog box, select-
ing the Link To Content check box displays the workbook’s defined names in the Value 
box (which changes to a drop-down list named Source when linking content), as shown 
in Figure 2-31.

Figure 2-31  Use named cells to create dynamic properties based on worksheet cells.

Select or create a name for the custom property in the Name box. (The Type drop-
down list becomes unavailable when you’re linking to content.) When you’ve specified 
a source (the named cell to which you want to link), click Add, and the custom property 
appears in the Properties list.

If the link is broken (the defined name is later deleted, for example), the Properties dia-
log box stores the last value recorded for that property.

If the name defines a range of cells, only the value in the cell in the upper-left corner of 
the range appears as the property value.
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Opening files
Only slightly less basic than saving files is opening them. Click the File tab, and click Open 
to display the Open screen in Backstage view, shown in Figure 2-32.

Figure 2-32  Click the Open command, and select a location or a recent workbook.

Click one of the icons on the left side of the dialog box to display the corresponding files 
on the right side. Recent workbooks are displayed when you first click the Open command. 
If you click one of the other locations, the recent folders are displayed. If you need some-
thing that is not recent, click the Browse button to display the Open dialog box, as shown 
in Figure 2-33.

The drop-down list to the right of the File Name text box at the bottom of the Open dialog 
box determines which files are available for selection. The default option is All Excel Files, 
which displays file names whose extensions begin with xl. You can display specific file types 
or all files by clicking the arrow to the right of the text box.
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Figure 2-33  Click the Browse button to display the Open dialog box.

Note
To open several files at once, press the Ctrl key and select each file you want to open.

Notice that headings appear at the top of the file list in the Open dialog box. When you 
click one of these headings, you sort the files in order, based on that heading. For example, 
if you click the Date Modified heading, you sort the files in date order. Click the same head-
ing again to re-sort in reverse order. You can further refine your quest by using the hidden 
menus adjacent to each heading. When you rest the pointer on a heading, a downward-
pointing arrow appears to the right of the heading; click it to display a menu of additional 
options pertinent to that heading.

Note
You can right-click most files listed in the Open and Save As dialog boxes to display a 
shortcut menu that contains commands you can use with the selected file. For example, 
you can delete a file displayed in the Open dialog box by using this shortcut menu.
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Each heading has its own menu of options, some of which are based on the actual files 
contained in the current folder. For example, when you click the menu arrow for the Type 
heading, you can select from a list of file types contained in the folder.

Special ways to open files

To the right of Open at the bottom of the Open dialog box is a small arrow. Clicking this 
arrow displays a menu containing the following options:

●● Open Read-Only  This opens the file so that you cannot save any changes made to 
it without renaming it.

●● Open As Copy  This creates a duplicate of the selected file, adds the words Copy of 
to the file name, and leaves the original untouched.

●● Open In Browser  This applies only to HTML documents and opens the selected file 
in your default web browser.

●● Open In Protected View  This opens the document for viewing but not editing. 
All active content is disabled, including any kind of macro or HTML code. Once you 
have established the bona fides of the file, you can click the Enable Editing button to 
carry on.

●● Open And Repair  This is a powerful feature you can use to try opening corrupted 
files. For more information, see “Recovering corrupted files” later in this chapter.

Opening files when you start Excel

If you have files you need to work on every day, you can store them in a special folder 
called XLStart. Every time you start Excel, any files in the XLStart folder automatically open. 
The XLStart folder is created when you install Excel (or you can create it yourself) and is 
located in the following place:

●● Windows 8, 7, or Vista  C:\Users\<your name>\AppData\Roaming\Microsoft\
Excel\XLStart

●● Windows XP  C:\Documents and Settings\<your name>\Application Data\
Microsoft\Excel\XLStart

If you want to start Excel and simultaneously open files that are in a folder other than the 
XLStart folder, you can specify an alternate startup folder. Click the File tab, click Options, 
and select the Advanced category. Scroll down to the General category, and in the edit box 
labeled At Startup, Open All Files In, type the full path of the folder. This feature is particu-
larly useful if your computer is connected to a network and you want to open files from a 
shared folder.
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Recovering corrupted files

Figure 2-33 shows the Open dialog box, where you can find the Open Options menu (click 
the arrow next to the Open button) containing the Open And Repair command. This com-
mand gives you a fighting chance at either repairing a corrupted file or extracting the data 
from it if it doesn’t respond to a repair attempt. When you select a file and click the Open 
And Repair command, the message box shown in Figure 2-34 opens.

Figure 2-34  The Open And Repair command gives you a ray of hope for recovering lost data.

Try the Repair button first, and if Excel still has no luck opening the file, try the Extract Data 
button, which displays the message box shown in Figure 2-35.

Figure 2-35  The Extract Data button offers two ways to recover your data.

You’ll have to make a judgment call here—if you think your formulas will be OK after 
extraction, click Recover Formulas; otherwise, click Convert To Values. Recovering formulas 
will probably work unless the formulas include references to cells that were lost in corrup-
tion. Whatever you select, the Extract Data feature pulls all the data from your workbook, 
including all worksheets and tabs, in the same order in which they appear in the original 
file. Unfortunately, the recovery process ignores all formatting, charts, and other objects—
you can recover only the actual cell contents (the important stuff).

Note that unless the part of the file that became corrupted was the part storing pass-
words, you probably won’t be able to use this technique to retrieve data from a password-
protected file.
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INSIDE OUT �  Recover data using links

You can try to recover data from a corrupted workbook by using another trick. It is 
essentially the same trick used by the Excel Open And Repair command, but it still 
might be worth a try if Open And Repair fails.

First, open two new workbooks. Select cell A1 in one of the workbooks, and then press 
Ctrl+C to copy. Activate the second workbook, and right-click cell A1. Click Paste Spe-
cial, and then click the Paste Link button. Next, click the File tab and click Edit Links To 
Files on the Info screen (this command is in tiny type at the bottom of the shaded area 
on the right), click Change Source, and locate the corrupted workbook. Click OK, and 
then click Close to close the Edit Links dialog box.

If luck is with you, data from cell A1 in the lost workbook appears in cell A1, thanks to 
the linking formula. If it does, press F2 to activate Edit mode, and press F4 three times 
to change the absolute reference $A$1 to its relative form, A1. Finally, copy the formula 
down and across until you can see all the data you need to retrieve. Repeat for each 
worksheet in the workbook. You lose the formatting and formulas, of course, and zeros 
appear in every blank cell, but at least you can get at the important stuff. Although you 
can save this worksheet with linking formulas, you might consider converting all the 
formulas to their underlying values, just in case the original corrupted file has any fur-
ther degradation. To do so, select all the cells containing the formulas you just created, 
click Ctrl+C to copy, right-click, click Paste Special, select Values, and then click OK.

For more information about document recovery, see “Recovering from crashes” later in this 
chapter. For more information about passwords, see “Hiding and protecting workbooks” in 
Chapter 7.

Importing and exporting files
Excel gracefully accepts proprietary data created in many other applications. Excel also 
makes it easy to import data from text files and helps you parse it into worksheet columns.

Note
Mountains of very specific, sleep-inducing technical details are available about import-
ing and exporting files. If you need details, you should consult Microsoft Office Online 
(office.microsoft.com). Also, for information regarding sharing data with other Micro-
soft Office 2013 applications and working with external databases, see Chapter 32, 
“Integrating Excel and Word,” and Chapter 25, “Working with external data.”

office.microsoft.com
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Importing and exporting files
To import a file from another application or from an earlier version of Excel, click the File 
tab, click Open, select a location, and click Browse to open the Open dialog box. Then to 
specify the file type you want to import, use the drop-down list adjacent to the File Name 
box. If you’re not sure, select All Files (*.*), or select a file type and only files of that type are 
displayed. 

To export an Excel file to another application or to an earlier version of Excel, click the File 
tab and click Export. Then select either Create PDF/XPS Document or Change File Type, as 
shown in Figure 2-36. 

Figure 2-36  Use the Export screen in Backstage view to change to another file type.

Portable Document Format (PDF) and XML Document (XPS) are formats that allow accurate 
visual representations of documents to be easily shared across platforms by using free and 
easily obtainable web-based viewers.
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Sharing data with Excel for the Macintosh
Excel for the Macintosh since 1998 has been using the same file format as Windows ver-
sions of Excel from Excel 97 through Excel 2003. You can share these files with Macintosh 
users by simply transferring files from one computer to the other. (Note that you cannot 
share Excel files containing macros—.xlsm files—with Macintosh Excel versions through 
2011.)

To save an Excel 2013, 2010, or 2007 file to share with someone using the Macintosh ver-
sion of Excel, click the File tab, click Save As, select a location, and click the Browse button. 
You can save it as a regular Excel Workbook (*.xlsx) file when sharing with users of Macin-
tosh Excel 2011, or for greater compatibility, select the Microsoft Excel 97-2003 Workbook 
(*.xls) option in the Save As Type drop-down list. 

To import Macintosh files to your PC, you first need to transfer the file to your PC via a 
cable, a disk, a thumb drive, a network, an email attachment, a website, or a software tool 
such as MacOpener. Exporting files from a Windows version of Excel to the Macintosh ver-
sion is just as easy as importing Macintosh files. Simply transfer the file from the Windows 
computer to the Macintosh using your method of choice, and then use the Open command 
to load it into Excel.

Adjusting date values
Although the Windows and Macintosh versions of Excel share many characteristics and 
capabilities, they might not use the same date system. In the Windows version of Excel, 
the base date is January 1, 1900. Macintosh Excel 2011 uses the same date system as 
all Windows versions, so you can share these files as you will. In Macintosh Excel ver-
sion 2008 and earlier, the base date is January 2, 1904. When you transfer files either 
to or from the Macintosh, Excel maintains the date type by selecting or clearing the 
Use 1904 Date System check box in the When Calculating This Workbook area in the 
Advanced category in the Excel Options dialog box. This technique is usually accept-
able, but it can cause problems when a date from a Macintosh file is compared with a 
date from a Windows file. For this reason, we suggest you use the same date setting on 
all your machines.
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Sharing data beyond Excel
Yes, some people don’t use Excel, and you might meet one someday. Seriously, plenty of 
reasons exist for making Excel-based data accessible outside the program, whether or not 
Excel is available at the destination. Posting data to a website or creating data sets for pro-
prietary analysis software are two possible applications where you might want data that can 
fly free, independent of the Excel mother ship.

Office Web Apps

Office Web Apps give you a familiar Office experience when you are away from your Office 
applications on your computer. With your Office files uploaded to a web storage location 
such as your own website or Windows Live SkyDrive, you don’t need your own computer or 
software to view and perform light editing of Word, Excel, PowerPoint, and OneNote files. 
You just need a computer running a popular Web browser.

For more information about Office Web Apps, see Chapter 27, “Working in the cloud.”

Using web file formats

Two options in the Save As Type drop-down list in the Save As dialog box produce files you 
can use as webpages: Web Page (HTM, HTML) and Single File Web Page (MHT, MHTML). 
They produce essentially the same result, the important difference being that the Web Page 
format saves not only a main HTML file but also a folder containing supporting files that 
must travel with the main file. As you might expect, the Single File Web Page format man-
ages to cram it all into a single file without using the supporting folder. Single File Web 
Page has the advantage of being more portable, but Web Page gives you more control 
over individual elements. A separate cascading style sheet is created using the Web Page 
format, along with individual HTML files for each worksheet in the workbook. Figure 2-37 
shows the contents of the supporting folder that is created after saving a five-sheet work-
book named Team Sales using the Web Page file format.

If you are an HTML aficionado, you can open the supporting files in other programs. 
For example, if the original workbook contains graphics, Excel saves them as separate 
image files (JPEG, PNG, or GIF) you can modify with an image-editing program. Or you 
can change the fonts used by editing the cascading style sheet with a text editor such as 
Notepad. This is not work for the timid, of course. The slightest editing error in the HTML 
code for any of the files has the potential to render them all unusable.
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Figure 2-37  The Web Page file format creates a folder full of supporting files to go with the 
main webpage.

Importing and exporting text files

To export an Excel file as a text file, select one of the following eight text formats from the 
Save As Type drop-down list in the Save As dialog box. In all of these formats, Excel saves 
only the current worksheet. Number formatting is preserved, but all other formatting is 
removed.

●● Formatted Text (Space Delimited) (*.PRN)  This creates a file in which column 
alignment is preserved by adding space characters to the data in each column so that 
each column is always filled to its maximum width. 

●● Text (Tab Delimited) (*.TXT)  This separates the cells of each row with tab 
characters. 

●● Unicode Text (*.TXT)  This is a worldwide standard text format that stores each 
character as a unique number; Unicode defines a number for every character in every 
language and on any computer platform.

●● CSV (Comma Delimited) (*.CSV)  This separates the cells of each row with com-
mas. Comma-delimited text files are preferable to tab-delimited files for importing 
into database management programs. (Many database management programs 
can accept either form of text file, but some accept only .csv files.) Also, many 
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word-processing applications can use .csv files to store the information for mail 
merge operations.

●● Text (Macintosh) (*.TXT)  This saves the current worksheet as a tab-delimited text 
file using the Macintosh character set.

●● Text (MS-DOS) (*.TXT)  This saves the current worksheet as a tab-delimited text file 
compatible with the character-based MS-DOS interface.

●● CSV (Macintosh) (*.CSV)  This saves a comma-delimited text file using the Macin-
tosh character set. The differences between the normal, Macintosh, and MS-DOS 
variants of each file type have to do only with characters that lie outside the normal 
7-bit ASCII range.

●● CSV (MS-DOS) (*.CSV)  The MS-DOS options use the IBM PC extended character 
set. (You might see this referred to also as OEM text.) Select one of these options if 
you intend to import your text file into a non-Windows-based application.

Note
Excel 2013, 2010, and 2007 use a file format that is incompatible with previous Excel 
versions. Excel versions 97 through 2003 share a file format that is incompatible with 
even older versions. However, you can use the Save As command and Save As Type list 
to export Excel 2013, 2010, and 2007 workbooks using two formats that play nicely 
with older versions of Excel: Excel 97-2003 Workbook and Microsoft Excel 5.0/95 
Workbook.

If you regularly share files with colleagues using different vintages of the program, you 
might want to read “Ensuring file compatibility with previous versions of Excel” earlier 
in this chapter.

Other file formats

You can use a few other file formats, most of which you won’t even need unless you have 
a particular program with which you want to share data. Data Interchange Format (DIF) is 
a legacy format that allows the specification of data in rows and columns, saves only the 
active worksheet, and does not process graphic content. Symbolic Link (SYLK), a format that 
dates back to the days of VisiCalc and Multiplan, is a sort of “rich-text format” for spread-
sheets that saves only the active worksheet and does not process graphic content. 
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Using the Help system
Excel was a powerful program right out of the starting gate way back in 1985. Over the 
years, Excel has developed into an extremely complex and sophisticated application. It’s 
so complex that most people need to learn only about 20 percent of its capabilities. Many 
people turn to books like this one to help them make sense of it all. But almost every Excel 
user turns to the Help system; all Excel users should. After years of working out the kinks, 
Microsoft has made the Help system more “helpful,” less obtrusive, more comprehensive, 
and much easier to use.

Help on the surface
Although the mythical, magical, space-age vision of easily understood, self-documenting 
software has yet to be fully realized, Microsoft is taking steps in the right direction. Dynamic 
pop-up labels called ScreenTips have been around for quite a while providing visual clues 
to elements in the interface. Many of these ScreenTips have increased in size considerably 
over the years, and they contain more and better information. Simply rest the pointer on 
any button or command on the ribbon or the Quick Access Toolbar to display a ScreenTip, 
as shown in Figure 2-38.

Figure 2-38  Rest the pointer on any command or button on the ribbon or the Quick Access 
Toolbar to display a ScreenTip.

Help in the form of ScreenTips is also available for many items in dialog boxes such as Excel 
Options. (To open this dialog box, click the File tab and then click Options.) In this context, 
look for the little i (for information) icons next to items in the dialog box, which indicate 
more information is available. Just rest the pointer on the icon to display the ScreenTip, as 
shown in Figure 2-39.
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Figure 2-39  A little circle icon containing an i means you can see more information by simply 
resting the pointer on the icon.

Help in depth
When you need more information than a ScreenTip can provide, it’s time to invoke the 
Help dialog box. Simply click the Help button (the question mark icon) that is always avail-
able in the upper-right corner of the screen (or any dialog box) to display the Help dialog 
box. When you first open the dialog box, it attempts to connect to the Microsoft Office 
Online website, as shown on the left in Figure 2-40. If you are connected to the Internet, 
the dialog box should quickly display an opening menu of topics, similar to the one shown 
on the right in Figure 2-40. As mentioned previously, one of the beauties of web-based 
Help is that it can be continually updated, so it is quite possible this opening screen will 
change in content and appearance over time; more and more Help topics should be added 
as well. 

As long as you have the Help dialog box open and your Internet connection remains active, 
web-based Help continues to be available. If you lose your Internet connection, Excel stops 
trying to connect to the web and displays the “offline” Help system—that is, only those 
Help topics installed on your computer. You can also do this manually by clicking Con-
nected To Office.com at the bottom of the Help dialog box and clicking Show Content Only 
From This Computer.
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Figure 2-40  Your Help system works best when you’re connected to the web.

You can prevent Excel from automatically trying to connect to the web by using the Trust 
Center dialog box. See “Privacy options” in Chapter 4, “Security and privacy.”

You’ll find that not much good information is available if you’re not connected to the web. 
The few search results shown on the left in Figure 2-40 are simple Excel menu-to-ribbon 
command references. The help content is all on the web now, but it’s robust with pro-
cedures, templates, samples, interactive quizzes, tutorials, introductions, references, live 
samples, and more as time goes by. 

You’ll notice that the Help dialog box has a tiny toolbar with controls that look—and act—
similarly to the controls on your web browser’s toolbar. The first two buttons are Back and 
Forward, which operate like their browser counterparts—they move you to the next or pre-
vious topic in your history list. The Home button returns you to the opening Help screen, 
and the Print button prints the current topic. Clicking the Use Large Text button is a toggle; 
click to make the text a bit larger, and click again to return to normal. 

The pushpin button in the Help dialog box is Keep On Top. It is set to Keep On Top 
by default. When the pushpin is horizontal, the dialog box behaves like a normal win-
dow, giving way to the active window when you click outside the dialog box. When the 
pushpin button is vertical, the window stays on top of the Excel workspace, allowing an 
unobstructed view of the Help window while you work. This button is a toggle; repeated 
clicking changes the pushpin’s ScreenTip from Keep Help On Top to Don’t Keep Help On 
Top. Whatever setting was active when you close the dialog box persists the next time you 
open it.
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Note
Most dialog boxes include a Help button located in the title bar (identified by a ques-
tion mark icon). Clicking this button displays a Help topic describing the function of 
and options within that dialog box. If you click the Help button in a tabbed dialog box, 
you’ll see information pertaining to that particular tab. 

INSIDE OUT �  A user-assistance odyssey

The implication of the term online Help has changed somewhat over the years. It used 
to mean that in addition to the primary source of user assistance—the printed man-
ual—how-to topics and explanations of commands and features were available right 
on your computer by pressing F1. What a concept! Today, Help really is online, and an 
Internet connection is almost essential—preferably broadband. 

Those who write user-assistance topics and implement the Help system historically 
had to limit the amount of actual assistance they could provide, being constrained 
by the amount of space allocated for Help files on the installation CDs (or floppy 
disks!). Over the past few Office releases, the need for Help files actually shipped on 
CD has decreased because of the new user-assistance paradigm: web-based Help. 
This offers tremendous advantages over in-the-box Help. First, instead of having to 
cram increasing amounts of information into a finite amount of space on a CD, keep-
ing Help files on the web allows virtually unlimited information to be made available. 
Second, it allows information to be more up to date, which is actually an incredible 
understatement. 

Consider that under the old paradigm, Help content had to be written early and sent 
through the editorial pipeline many weeks prior to shipping the software—often 
before developers were finished tweaking features. (Add another month or so for 
printed manuals! Remember those?) With the constraints on disk space, tough deci-
sions often were made regarding helpful topics and useful aids such as videos and 
presentations that would simply have to be eliminated to save room. No wonder Help 
systems have historically been dissed for being inaccurate and incomplete. Under the 
new “truly online” Help paradigm, topics that would never have made it onto the CD 
are instead available on the web, and user-assistance writers can update and add more 
Help topics, videos, presentations, and templates long after the product ships. 
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Recovering from crashes
In the past, crash recovery largely involved an initial flurry of expletives followed by a brisk 
walk around the office and perhaps a couple of aspirin. Excel 2013 provides something 
beyond comfort and sympathy for digital mishaps—an actual mechanism that attempts to 
tuck away open files before the program comes screeching to a halt. And it works pretty 
well. If Excel encounters a problem, it attempts to save any files that are open at the time 
the problem occurs, before bad things happen to them when the program crashes and 
burns. 

Understanding AutoRecover
Over the years, Excel has greatly improved its ability to recover lost work after a crash. By 
default, all unsaved workbooks are backed up automatically every 10 minutes, storing what 
Excel calls AutoRecover information. This is not the same as saving your workbook, because 
Excel stores AutoRecover information in a different place with a cryptic file name. You 
might lose a few minutes worth of work, but you can change the time interval anywhere 
from 1 to 120 minutes. If Excel or your system crashes, the AutoRecover feature presents 
a list of rescued versions of all files that were open when the crash occurred the next time 
you start Excel. 

To change settings or turn off AutoRecover, click the File tab, select Options, and select the 
Save category to display the dialog box shown in Figure 2-41. 

AutoRecover File Location is set to a subfolder buried deep in your hard disk—this is OK 
because you should save the real files elsewhere rather than cluttering up your working 
directories with recovery files. If you want, you can easily change the location. You can also 
choose to disable AutoRecover for specific workbooks without having to turn it off and on 
manually. You can use the AutoRecover Exceptions For area in the dialog box to do this. 
Just select a workbook in which you want to disable AutoRecover from the drop-down list 
displaying all the currently open workbooks, and select the Disable AutoRecover For This 
Workbook Only check box. You can do this separately for any open workbook. 
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Figure 2-41  With AutoRecover, you can specify how often Excel automatically saves your work.

Managing versions
The AutoRecover feature essentially stores a copy of each unsaved workbook every 10 
minutes (unless you specify otherwise). So what happens to these copies? Excel stores one 
copy of each file you work on—and fail to save—for four days, deleting older copies auto-
matically. Luckily, Excel provides access to these copies. Click the File tab, click Info, click 
Manage Versions, and click Recover Unsaved Workbooks to display the dialog box shown in 
Figure 2-42, a version of the Open dialog box, which automatically opens to the specified 
AutoRecover location.
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Figure 2-42  You can recover recent versions of your workbooks by using the Recover Unsaved 
Workbooks command.

When you open an unsaved workbook, it opens in read-only format, and Excel displays 
“Unsaved File” in the message bar, along with a handy Save As button in the warning 
area above the formula bar. If you do nothing, the previously scheduled four-day deletion 
schedule remains and the draft is removed. Clicking Save As displays the dialog box of the 
same name, open to your normal documents folder.
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CHAPTER 3

Custom-tailoring the Excel workspace

You needn’t settle for the way the Microsoft Excel 2013 command and control system is 
organized. You can customize the Quick Access Toolbar and the ribbon, so if you feel 
that the Microsoft interface designers didn’t exactly have you in mind, you can make 

a lot of adjustments to Excel 2013. 

Customizing the ribbon
When the ribbon was introduced in Office 2007, it was fixed—you couldn’t modify the user 
interface unless you were conversant in VBA or XML. In Office 2013, the ribbon is open for 
interpretation; you can freely rearrange command groups; change the order and position of 
tabs; remove groups; and create custom commands, groups, and tabs. The bad news: you 
cannot add or delete commands from existing groups, and you cannot delete existing tabs. 
But this really isn’t much of a problem; a truly dedicated customizer can create a whole new 
set of tabs and stick them in front, forcing the default tabs off the screen, or simply hide all 
the default tabs.

Start by right-clicking anywhere on the ribbon and selecting the Customize The Ribbon 
command on the shortcut menu that appears. This opens the Excel Options dialog box 
with the Customize Ribbon category selected (saving you several mouse clicks), as shown in 
Figure 3-1. 

Does your ribbon look different?
The screen images shown in this book were captured at the screen resolution, magni-
fication, and text size that is optimum for publication purposes. The ribbon on your 
screen might not look the same as the one shown in the book. For example, you might 
see more or fewer buttons in each of the groups, the buttons you see might be repre-
sented by larger or smaller icons than those shown, or the group might be represented 
by a single button that you click to display the group’s commands 
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Figure 3-1  The outline on the right side of the dialog box controls the ribbon’s structure.

The Customize Ribbon category in the Excel Options dialog box displays two scrollable lists. 
The Choose Commands From list on the left displays commands you can use to create your 
own command groups and tabs. The list on the right shows the current contents of the 
ribbon as a collapsible outline, making it easy to see the ribbon’s structure. The first level 
of the outline represents tabs, and the second level of the outline represents command 
groups, corresponding to the labels at the bottom of each group (Clipboard, Font, Align-
ment, and so on) on the ribbon. Click the plus sign icons to reveal the subordinate groups 
and commands. Many groups have additional plus signs that expose another level of com-
mands. For example, Figure 3-2 shows the outline for the Font group fully expanded. There 
are a lot of commands in this one group—more than you can see at once.

Note
Some items in the outline might be wider than can be displayed in the dialog box 
at its default size. Just drag any border of the dialog box to make it wider or deeper. 
The next few figures were created after making the dialog box a bit larger for ease of 
viewing.
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Figure 3-2  The list on the right is a collapsible outline listing the current contents of the ribbon.

The drop-down list boxes above each list contain categories you use to filter the list of 
displayed commands. For example, Figure 3-3 shows the drop-down list with one of the 
more interesting categories selected: Commands Not In The Ribbon. This category is fun to 
browse just to see what you’ve been missing.

Note
You can clear the check box next to a tab in the outline to hide it on the ribbon; select 
it to display it. Note that many tabs are dynamic, such as the Add-Ins tab in Figure 3-1, 
and all of the Tool tabs in Figure 3-3. Even if they are selected in the outline, they do 
not appear on the ribbon until they’re needed.

On the right side of the dialog box in Figure 3-3, the Tool Tabs option is selected in the 
drop-down list. This displays a wealth of hidden tabs and groups on the ribbon that are 
normally invisible but that appear dynamically when the appropriate object or tool is 
selected. 
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Figure 3-3  Choose options from the drop-down lists above to filter the contents of the 
scrollable lists below.

Identifying items in the Customize Ribbon and Quick Access 
Toolbar categories
Most of the items you can see in the command list on the left side of the Customize Ribbon 
category in the Excel Options dialog box are buttons. That is, clicking the command but-
ton on the ribbon executes the associated command immediately. You can see that some 
items also have a small icon to the right of the command name in the dialog box. These are 
called command modifiers, and they tell you that although the item might still be a button, 
it is also something more, as detailed in Table 3-1. (Note that this also applies to the Quick 
Access Toolbar category in the Excel Options dialog box. The controls are almost identical 
to those in the Customize Ribbon category.)

The Quick Access Toolbar is discussed later in “Customizing the Quick Access Toolbar.” 

If you want a little more information about the commands in the command list, rest the 
pointer on any command to display a ScreenTip. 
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TABLE 3-1  Command modifiers

Item Description Image

Drop-down list A control that displays a menu or palette from which 
you select an option, such as the Conditional Formatting 
button on the Home tab

Split button A two-part item—one side looks and acts like a button, 
and the other side has a small arrow that displays a drop-
down list, such as the Font Color button on the Home tab

Edit control A control you can type into—for example, the Font drop-
down list on the Home tab

Creating a custom ribbon tab 
You can add custom groups to existing tabs, but if you have limited screen real estate, 
creating your own tabs might make more sense. To do so, first right-click the ribbon, click 
Customize The Ribbon, and then click the New Tab button. This creates a new top-level 
outline item provisionally titled New Tab (Custom). Select New Tab (Custom), and then click 
the Rename button to display the dialog box shown in Figure 3-4. The new tab is inserted 
below the selected tab in the outline.

Figure 3-4  Create a new ribbon tab by clicking the New Tab button, and then click Rename to 
give it a sensible moniker.
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After you create a tab, you need a group, because commands can be added only to groups. 
Helpfully, a custom group is created automatically whenever you create a custom tab, as 
shown in Figure 3-4. Even after you rename a tab or a group, (Custom) continues to appear, 
appended in the outline to any title you provide, which helps to quickly identify your own 
tabs and groups. 

You can reposition any tab or group in the outline by simply dragging it to a new location, 
or you can select it and click the arrow buttons located to the right of the list box. You can-
not reposition commands within preset groups, but you can move groups around from tab 
to tab all you like.

Note
The first tab in the Customize The Ribbon outline—even a custom tab—becomes the 
default tab that is active every time you start Excel.

Creating a custom command group 
Creating custom command groups is similar to creating custom tabs. First, select the tab 
where you want the custom group to live, and then click the New Group button in the Excel 
Options dialog box. (If you created a new tab, a new group already appears on the new 
tab.) Select your new group, and click the Rename button to display the dialog box shown 
in Figure 3-5.

Figure 3-5  Clicking the Rename button with a group selected allows you to select an icon for 
the group as well.
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As you can see, you can rename your new group and also assign an icon to it, which is vis-
ible only when you add the group to the Quick Access Toolbar. If you look at the Home 
tab on the ribbon, you’ll notice that most of the commands do not have labels displayed; 
they appear as buttons. For example, there are no command labels visible at all in the Font 
group. The ribbon shown at the top of Figure 3-6 displays a custom Formatting tab popu-
lated with border-specific commands with their command labels visible. If you want to cre-
ate a tab filled with other kinds of Formatting commands, you’ll need a lot more space, and 
hiding the labels helps a lot. 

To hide command labels, right-click the ribbon, select Customize The Ribbon, and then 
right-click any custom group in the outline and select Hide Command Labels. Note that this 
command appears on the shortcut menu only when you select a custom group. You cannot 
change the command labels of default groups. The ribbon shown at the bottom of Figure 
3-6 shows the result—now there is plenty of space left on the custom Formatting tab for 
more groups. Notice that hiding the command labels does more than what the command’s 
name implies; the button icons become considerably smaller as well.

Figure 3-6  It is a good idea to hide the command labels when you create new groups.

After hiding the command labels so that they are not visible on the ribbon, you can still 
easily see the command names by resting the mouse pointer over the buttons.

Adding existing command groups to custom tabs
When constructing custom tabs, you can take advantage of predefined command groups. 
Microsoft decided to make the built-in groups noncustomizable partly because a lot of 
sweat and tears went into creating them as they are today. Decades of usability studies and 
real-world usage of menus and command trees went into the design of the ribbon, and as 
such it makes sense for 80 percent of our needs. But we’re talking about the other 20 per-
cent here. Because you can create your own groups anyway, there is no harm in having the 
default groups fixed—and plenty of good reasons for you to take advantage of them. 
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Right-click the ribbon, and then click Customize The Ribbon. In the Choose Commands 
From drop-down list, click All Tabs to display an outline of all the predefined command 
groups, as shown in Figure 3-7.

Figure 3-7  Displaying All Tabs reveals all the predefined command groups.

First, select a tab or group in the outline on the right below which you want to insert a pre-
set group. Next, in the All Tabs list on the left, click the plus sign icons to expand the outline 
and locate the group you want. Select it, and click the Add button to insert the group into 
the outline on the right. If you decide you want your inserted groups somewhere else, 
you can always move them up and down the outline by using the arrow buttons. A well-
populated custom Formatting tab is shown in Figure 3-8, along with the outline in the Excel 
Options dialog box that created it.
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Figure 3-8  The modified outline in the Customize The Ribbon list and its custom tab.

Resetting and recycling your customizations
When you customize the ribbon, it stays customized; everything is still there the next time 
you start Excel. But if you ever joke about “hitting the reset button,” well, now you actu-
ally have one. In the Customize Ribbon category in the Excel Options dialog box, the Reset 
button does the eponymous trick, discarding your customizations and returning the ribbon 
and the Quick Access Toolbar to their original states. The button is also a menu, offering 
the dual options of resetting only the selected tab (if one is selected) or resetting all cus-
tomizations (which resets both the ribbon and the Quick Access Toolbar). Before you reset 
either, though, you might want to save your customization work so that you can retrieve 
it later. Below the Reset button, the Import/Export button allows you to reuse and recycle 
your work. This button is also a menu from which you can choose to import or export a 
special file containing all your customizations. Figure 3-9 shows a version of the File Open 
dialog box that appears when you select Import Customization File from the Import/Export 
menu, with a couple of saved customization files. The first file—Excel Customizations.
exportedUI—is the rather clunky default name offered. The proprietary extension for the 
resulting file—.exportedUI—is appended to any file name you supply. 
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Figure 3-9  You can export any number of ribbon customization files for retrieval later.

Using these exported customization files and a web storage location such as Microsoft 
SkyDrive, you can store your custom tool sets as well as your workbooks, making them 
available from any Internet-connected computer in the world running Office 2013. 

Customizing the Quick Access Toolbar
The Quick Access Toolbar might be small, but you can pack a lot of tools onto it. If you are 
stuck using a small screen, or if you prefer an uncluttered workspace, you can set up the 
Quick Access Toolbar as a sort of “ribbon lite” to help free up some screen real estate.

Positioning the toolbar
When you first start Excel, the Quick Access Toolbar appears above the ribbon, as shown 
in Figure 3-10. You can change this so that the toolbar appears below the ribbon. Click the 
Customize Quick Access Toolbar button (the little arrow at the right end of the toolbar), 
and click Show Below The Ribbon. If you click the Collapse The Ribbon button, as shown in 
Figure 3-11, you can reveal several more rows of worksheet. 
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Figure 3-10  The Quick Access Toolbar usually appears above the ribbon on the title bar.

Figure 3-11  You can collapse the ribbon and move the Quick Access Toolbar below it.

Moving the Quick Access Toolbar below the ribbon offers you a couple of advantages: 
it’s closer to the action on the worksheet, and more space is available for additional tools, 
which we discuss in depth next in “Adding tools to the toolbar.” Conversely, the advantage 
of leaving it at the top of the screen is that it can occupy unused space on the title bar.
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Adding tools to the toolbar
You get three tools to start with on the Quick Access Toolbar: Save, Undo, and Redo. These 
are undeniably heavily used commands, but you perform other tasks often too and might 
like to have them just a click away, readily available regardless of which ribbon tab is cur-
rently visible. It’s easy to customize the toolbar, and you have a couple of ways to do it.

Adding tools as you work

If you find yourself continually returning to the same tab on the ribbon and using a partic-
ular command, you might consider adding it to the Quick Access Toolbar. The easiest way 
to do this is to right-click the command to display the shortcut menu shown in Figure 3-12.

In Figure 3-12, we added the Switch Windows command to the Quick Access Toolbar 
by right-clicking the command and clicking Add To Quick Access Toolbar. A button then 
appears on the toolbar that looks similar to the command on the ribbon. Each new button 
you add appears to the right of the previous button. Not all toolbar buttons are easy to 
identify, but you can always rest the pointer on a button to display a ScreenTip explain-
ing its function, as shown at the bottom of Figure 3-12. If you add a lot of buttons, these 
ScreenTips are indispensable.

Figure 3-12  Right-click any command or group, and you can add it to the Quick Access Toolbar.



Ch
ap

te
r 3

	 Customizing the Quick Access Toolbar	 87

Removing tools

You can remove tools from the Quick Access Toolbar by using the same technique you 
use to add them. Right-click any tool on the toolbar, and click Remove From Quick Access 
Toolbar.

Adding and organizing tools

You can add virtually any command or group to the Quick Access Toolbar by using the 
right-click technique, but if you want to dig in and really create an organized toolbar, you 
should use the Excel Options dialog box. Right-click the toolbar, and click Customize Quick 
Access Toolbar to open the Quick Access Toolbar category in the Excel Options dialog box, 
shown in Figure 3-13.

As you can see in Figure 3-13, the list on the right shows the buttons currently visible on 
the toolbar. The controls here work just like the Customize Ribbon category—select any 
item on the left side, and then click the Add button to add it to the list on the right. Select 
any item on the right side, and click the Remove button to get rid of it; when you select 
an item, you can click the up and down arrows to reposition the item in the list. You can 
always click the Reset button if you want to discard all your changes and return to the 
original configuration.

Figure 3-13  The Quick Access Toolbar category in the Excel Options dialog box is the command 
center for the Quick Access Toolbar.
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Notice in Figure 3-13 that Separator is the first item in the list on the left. This item is first in 
each command category, and with it you can insert small vertical bars on the Quick Access 
Toolbar to visually separate groups of related commands. You can add separators and move 
them up and down the list on the right side of the dialog box, just as you do with com-
mands. (This item is not available for ribbon customization because you create groups first 
instead of using separators.)

The items in the Choose Commands From drop-down list include an eponymous item for 
each of the command tabs visible on the ribbon, plus all the other contextual tabs that 
appear on the ribbon only when an object is selected, as shown in Figure 3-14. Select any 
item from the drop-down menu, and the corresponding list of commands appears in the 
list below.

Figure 3-14  Each item in the Choose Commands From drop-down list corresponds to a tab on 
the ribbon.
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INSIDE OUT �  Create a mini ribbon

Here is a trick you can use if it just seems like too much bother to click those tabs at 
the top of the ribbon, or if you just want to maximize screen space. Saving a click here 
and there can make quite a difference if you do a lot of repetitive work. The following 
illustration shows the Quick Access Toolbar displayed below the ribbon (which is mini-
mized) and loaded with buttons that correspond to every group on every default tab 
on the ribbon:

The toolbar shown here includes only buttons that correspond to the command groups 
(not individual commands) on every default tab. Notice that clicking the Tables button 
displays a drop-down list of commands identical to those in the ribbon group of the 
same name on the Insert tab. To customize the toolbar this way, use the Excel Options 
dialog box. Although you can build a similar toolbar using the right-click approach, 
using the dialog box offers the advantage of being able to insert separators between 
groups of buttons. 

You’ll find the Ribbon Group Toolbar.xlsx file on the companion website.

Too many tools?

It is certainly possible to load more buttons onto the Quick Access Toolbar than can fit 
across the screen, even if you move the toolbar below the ribbon. If this happens, a More 
Controls button appears at the right end of the toolbar, looking like a fast-forward button 
(>>). As shown in Figure 3-15, clicking More Controls displays the hidden controls on a 
drop-down toolbar. 

Figure 3-15  If you add more buttons than can be displayed, click the More Controls button.
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Note that when the More Controls button appears, the Customize Quick Access Toolbar 
button (the downward-pointing arrow) that usually appears at the right side of the toolbar 
moves to the “overflow” area of the toolbar.

Creating your own buttons
Right-click any button on the ribbon, click Customize Quick Access Toolbar, and click the 
Choose Commands From drop-down list. You’ll see a special option listed there: Macros. 
Macros are sequences of commands you can create to help perform repetitive tasks. When 
you select the Macros option, nothing appears on the left side of the dialog box unless you 
have opened a macro-enabled workbook and the workbook actually contains macros. All 
the macros available appear here. Figure 3-16 shows the Customize Quick Access Toolbar 
list containing a single macro that has been added to the toolbar.

Figure 3-16  You can add custom buttons to run macros in macro-enabled workbooks.

You might notice that the Modify button below the list is active when you add a macro 
to the list on the right side of the dialog box. By clicking it, you can modify the button 
image displayed on the toolbar if the default image doesn’t do it for you. In case you are 
wondering, you can modify only custom macro buttons, which is why the Modify button is 
not available when you select built-in commands. When you click the Modify button, the 
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Modify Button dialog box appears, as shown in Figure 3-17, and you can use it to select a 
different image.

For more information about macro-enabled workbooks, see “Saving files” in Chapter 2, 
“Exploring Excel fundamentals.” For more information about macros and VBA, see Chapter 28, 
“Recording macros.”

Figure 3-17  You can change the default button image for your custom macro-driven buttons.

Saving and resetting your custom Quick Access Toolbar
In the Quick Access Toolbar category of the Excel Options dialog box, the default setting in 
the Customize The Quick Access Toolbar drop-down list is For All Documents. In this case, 
Excel saves the configuration of the Quick Access Toolbar when you exit the program. If 
you want to go back to the way things were, click the Reset menu and select Reset Only 
The Quick Access Toolbar or Reset All Customizations (which resets both the ribbon and the 
Quick Access Toolbar). 

If you want to save your custom toolbar so that you can use it again later, there are two 
ways to do it. The Import/Export button allows you to save or retrieve a special file con-
taining all your customizations (both toolbar and ribbon). Figure 3-9 earlier in this chapter 
shows a version of the File Open dialog box that appears when you click Import Customiza-
tion File from the Import/Export menu, displaying files with the extension .exportedUI. 

The second way to save a custom toolbar is to attach it to a workbook. To do so, right-click 
any button or tab, and click Customize Quick Access Toolbar. In the Excel Options dialog 
box, click the Customize Quick Access Toolbar drop-down list, as shown in Figure 3-18.


